summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-04-16 21:22:38 +0200
committerJeroen Roovers <jer@gentoo.org>2019-04-16 21:23:04 +0200
commit6e1f7133e11e88eca4d2df180d3a1fd4321c8576 (patch)
tree40744f47cbdc2ec9e1429c4182beddd9d5dd3f79 /net-misc
parentnet-wireless/kismet: add snapshot for wpa3 (diff)
downloadgentoo-6e1f7133e11e88eca4d2df180d3a1fd4321c8576.tar.gz
gentoo-6e1f7133e11e88eca4d2df180d3a1fd4321c8576.tar.bz2
gentoo-6e1f7133e11e88eca4d2df180d3a1fd4321c8576.zip
net-misc/youtube-dl: Version 2019.04.17
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2019.04.17.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 171ac64d511f..d3486fcf4afd 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1 +1,2 @@
DIST youtube-dl-2019.04.07.tar.gz 3139592 BLAKE2B b9b8ead15aad94e53aa92dcb7969d56138d0ec139917491710a1c86c7121a5288bbc2b443af261892e97a755e0b466a261fcf7bcdc255877313f5c2d6627d775 SHA512 9c4544f1e4437980d289127342aec1bbb93669a1ef9abde5cde20c02a153a4429f18df85fa61c6c040ea2df5987ed7d7ae4ca57684921de4f9640e8403948dc6
+DIST youtube-dl-2019.04.17.tar.gz 3146625 BLAKE2B 35f49bcb56daa3ddbeeaaab57e4be259ddd2ebd1b21f797098fecb33fc0e153947558406f91878e2bb2d2627c950b4e670dbde35a148f1c216e46d366a7bb462 SHA512 6277a96a6487d81be23e0772c8e6fa36337d5b2b90a50b9be328579334b92c6e1a6eb9634a66969435c0d47e734fb907e286578cbc2f693565055ed1111b8148
diff --git a/net-misc/youtube-dl/youtube-dl-2019.04.17.ebuild b/net-misc/youtube-dl/youtube-dl-2019.04.17.ebuild
new file mode 100644
index 000000000000..8249fc9c0e19
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2019.04.17.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6,3_7})
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+LICENSE="public-domain"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+RESTRICT="test"
+SLOT="0"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ || (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )
+"
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins ${PN}.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "${PN}(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/${PN}/blob/master/README.md#faq :"
+ elog
+ elog "${PN} works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need avconf (media-video/libav) or"
+ elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
+ elog "videos can be retrieved in a higher quality format without sound."
+ elog "${PN} will detect whether avconv/ffmpeg is present and"
+ elog "automatically pick the best option."
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+ elog
+ elog "If you want ${PN} to embed thumbnails from the metadata into the"
+ elog "resulting MP4 files, consider installing media-video/atomicparsley"
+}