summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsoredake <fdsfgs@krutt.org>2017-12-23 18:12:58 +0200
committerDavid Seifert <soap@gentoo.org>2017-12-23 17:52:15 +0100
commit95b33a4a08bd94802dc57890f05dd03fcbc61458 (patch)
tree5ebf4e46d0c8198fd726e701528ef70bd35e3cbb /net-misc
parentdev-libs/gnulib: add new snapshot, fix dosym usage (diff)
downloadgentoo-95b33a4a08bd94802dc57890f05dd03fcbc61458.tar.gz
gentoo-95b33a4a08bd94802dc57890f05dd03fcbc61458.tar.bz2
gentoo-95b33a4a08bd94802dc57890f05dd03fcbc61458.zip
net-misc/streamlink: improve live version
Closes: https://bugs.gentoo.org/637142 Closes: https://github.com/gentoo/gentoo/pull/6174
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/streamlink/streamlink-9999.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/net-misc/streamlink/streamlink-9999.ebuild b/net-misc/streamlink/streamlink-9999.ebuild
index 4a297db743e5..ff3f06dea73a 100644
--- a/net-misc/streamlink/streamlink-9999.ebuild
+++ b/net-misc/streamlink/streamlink-9999.ebuild
@@ -22,15 +22,20 @@ RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]
virtual/python-futures[${PYTHON_USEDEP}]
virtual/python-singledispatch[${PYTHON_USEDEP}]
dev-python/backports-shutil_which[$(python_gen_usedep 'python2*')]
- dev-python/backports-shutil_get_terminal_size[$(python_gen_usedep 'python2*')]
+ $(python_gen_cond_dep 'dev-python/backports-shutil_get_terminal_size[${PYTHON_USEDEP}]' 'python2*')
dev-python/pycountry[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
media-video/rtmpdump
virtual/ffmpeg"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}] )
- test? ( dev-python/mock[$(python_gen_usedep 'python2*')]
- ${RDEPEND} )"
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ )
+ test? (
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2*')
+ ${RDEPEND}
+ )"
python_configure_all() {
# Avoid iso-639, iso3166 dependencies since we use pycountry.