summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-06-28 16:00:21 -0400
committerAnthony G. Basile <blueness@gentoo.org>2018-06-28 16:00:21 -0400
commitb28378fc2358c24785f41fdf92c00d617998ea3d (patch)
treeb1dc857a481fc7f0ca9d77e80bb826d19af2ecaa /net-misc
parentapp-emulation/cloud-init: stable 17.2 amd64 and x86 (diff)
downloadgentoo-b28378fc2358c24785f41fdf92c00d617998ea3d.tar.gz
gentoo-b28378fc2358c24785f41fdf92c00d617998ea3d.tar.bz2
gentoo-b28378fc2358c24785f41fdf92c00d617998ea3d.zip
net-misc/openssh: stackprotector is broken on musl x86
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openssh/openssh-7.7_p1-r102.ebuild3
-rw-r--r--net-misc/openssh/openssh-7.7_p1-r6.ebuild3
2 files changed, 6 insertions, 0 deletions
diff --git a/net-misc/openssh/openssh-7.7_p1-r102.ebuild b/net-misc/openssh/openssh-7.7_p1-r102.ebuild
index c4747a2597ee..83b9dd347119 100644
--- a/net-misc/openssh/openssh-7.7_p1-r102.ebuild
+++ b/net-misc/openssh/openssh-7.7_p1-r102.ebuild
@@ -293,6 +293,9 @@ src_configure() {
$(use_with ssl ssl-engine)
)
+ # stackprotect is broken on musl x86
+ use elibc_musl && use x86 && myconf+=( --without-stackprotect )
+
# The seccomp sandbox is broken on x32, so use the older method for now. #553748
use amd64 && [[ ${ABI} == "x32" ]] && myconf+=( --with-sandbox=rlimit )
diff --git a/net-misc/openssh/openssh-7.7_p1-r6.ebuild b/net-misc/openssh/openssh-7.7_p1-r6.ebuild
index e84b7d126a32..2d068fd5c8e6 100644
--- a/net-misc/openssh/openssh-7.7_p1-r6.ebuild
+++ b/net-misc/openssh/openssh-7.7_p1-r6.ebuild
@@ -293,6 +293,9 @@ src_configure() {
$(use_with ssl ssl-engine)
)
+ # stackprotect is broken on musl x86
+ use elibc_musl && use x86 && myconf+=( --without-stackprotect )
+
# The seccomp sandbox is broken on x32, so use the older method for now. #553748
use amd64 && [[ ${ABI} == "x32" ]] && myconf+=( --with-sandbox=rlimit )