summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-01-09 09:29:59 +0100
committerJeroen Roovers <jer@gentoo.org>2016-01-09 09:29:59 +0100
commite553a72cabf7b7e588fc1b4b4b618313df451b63 (patch)
treee9ab0f5fa121063a1b77a11cc81f5431c44b9a64 /net-misc
parentdev-ruby/power_assert: add 0.2.7 (diff)
downloadgentoo-e553a72cabf7b7e588fc1b4b4b618313df451b63.tar.gz
gentoo-e553a72cabf7b7e588fc1b4b4b618313df451b63.tar.bz2
gentoo-e553a72cabf7b7e588fc1b4b4b618313df451b63.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.01.09.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index d818b0dcd921..3df4c019a2aa 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -2,3 +2,4 @@ DIST youtube-dl-2015.04.03.tar.gz 1472296 SHA256 0521a15a24a9b620728a2f45ea9163c
DIST youtube-dl-2015.12.23.tar.gz 1850244 SHA256 fe7088979c78eb900c3db110a577866a01e1dd537cddda25258893f099fff9ba SHA512 e6ca9197b54972ee2a1518c6d76a05c96c0b556a1b0be96bd6fbcf0cccfae4d0555e0aa4c718c6132ca9cb7243f9758b5f28c80be231d702d12a6c32928fb39b WHIRLPOOL fd1dbdb741bc6674b881829b6103b886e0f379b7a5e4d2181f672d445a7a56ceffe6619f114486546e70db3a14b92c7f6ead57586a9d090da77e56d583350b27
DIST youtube-dl-2015.12.29.tar.gz 1863530 SHA256 4ff67c9cb65f36f0409dc2f35953fe1b66164512c06d46ebb345cb8a70e46208 SHA512 15bef247acca28f29c798bda8413155c8985e0f2ffc8be35ec539de95710747c2c6af4304286eebb21cb0d6932d4d0d51f5a0e581d479d9fec5dc930e01b7e6e WHIRLPOOL 2596183f3e3897790964703c2585299d094aa63f9be112549123e56ff9f0c4b2651749b9dd80f066e01d942cd0b884ce7717a3849d67c2d99d6234cb9034c957
DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b5a5a618671fb0629c8f8deb28209a172c SHA512 fdb022bed426250e5ee1c2bcc1354dd195c0f9793ca479ca8ca4cfe2f71e07ba100b0dbcda2fb9f310308ab130587d06b16a6a86f9036f0d196b317d2e5b5e92 WHIRLPOOL 152e709ba15264c35a89644ea0d4793bb47c82b317e54043ccfff72e40bdf95e42d76605e801233632d3863537a945cfb9ecc2f75245171b8de31b51ce6af801
+DIST youtube-dl-2016.01.09.tar.gz 1888095 SHA256 463cfed59a1e2c6609a8e3d3354e0494833f1b249fe1979984b06a51ac5c904d SHA512 bc022939ec2cdd574ca5ecedbfb349d516881996b50aac6a96220d94c358a38ff4ec8f8bd50195e2a6087dee558149e820935c60eaff8bb521bc8828413d44bf WHIRLPOOL a9fcffa926a72d6558b583390f1023568ee8c97695a87e15add7d72b7bd556c23056948df2bfb55902d7f2cbc3206c69844bee8b5e8ea1e3d7786b58806108f6
diff --git a/net-misc/youtube-dl/youtube-dl-2016.01.09.ebuild b/net-misc/youtube-dl/youtube-dl-2016.01.09.ebuild
new file mode 100644
index 000000000000..5db7401e49ee
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.01.09.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+DISTUTILS_SINGLE_IMPL=true
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink chaturbate drtuber eporner eroprofile
+ extremetube fourtube foxgay goshgay hellporno hentaistigma
+ hornbunny keezmovies mofosex motherless porn91 pornhd pornotube
+ pornovoisines pornoxo redtube sexykarma sexu sunporno slutload
+ spankbang spankwire thisav trutube tube8 vporn xbef xnxx xtube
+ xvideos xxxymovies youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/__init__.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/__init__.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ youtube_dl/extractor/tumblr.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ python_domodule youtube_dl
+ dobin bin/${PN}
+ dodoc README.txt
+ doman ${PN}.1
+ newbashcomp ${PN}.bash-completion ${PN}
+ python_fix_shebang "${ED}"
+}