summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Staroszczyk <piotr.staroszczyk@get24.org>2017-07-24 10:25:14 +0200
committerDavid Seifert <soap@gentoo.org>2017-07-30 13:08:53 +0200
commitfb3a873f8eceff5a088bcbc0ddbdba256501422f (patch)
treed83b95734d70eb816ddee743252b3ef98793b310 /net-misc
parentnet-im/corebird: Version bump to 1.5.1 (diff)
downloadgentoo-fb3a873f8eceff5a088bcbc0ddbdba256501422f.tar.gz
gentoo-fb3a873f8eceff5a088bcbc0ddbdba256501422f.tar.bz2
gentoo-fb3a873f8eceff5a088bcbc0ddbdba256501422f.zip
net-misc/rclone: version bump to 1.37
Closes: https://github.com/gentoo/gentoo/pull/5199
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/rclone/Manifest1
-rw-r--r--net-misc/rclone/rclone-1.37.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/rclone/Manifest b/net-misc/rclone/Manifest
index 71ff95857b67..42d2994cec56 100644
--- a/net-misc/rclone/Manifest
+++ b/net-misc/rclone/Manifest
@@ -1 +1,2 @@
DIST rclone-1.36.tar.gz 14013564 SHA256 a573b70e3aeb355b943dddd6ae9375386fc21bf12dfba601d8d7280f97c4c884 SHA512 589b5e2370244b5609d1ec8245f9f5f5cf58d6a2d507768db2cfc5a5b882f7d277d797fd0068b904538f3700e1751df03a21697d5295c83a2bf01a78d0ac6b13 WHIRLPOOL aa75c6c32cdcebd79ecf79abd03b4dc0205517808eb232a9655e8ae3da327cd62ad7183f4e0b0f6b7b52649c0c5058fdc2b57bc7b31b7dffb05e8a1508307d5c
+DIST rclone-1.37.tar.gz 37684683 SHA256 a74e284d2368f6fb8e4ac654a31b9b1328ac6078acd3446c9a892cd4bcbe8660 SHA512 683c88c04aa3d6f7057937c431bc56b20c9218c3a01f8baa4fb63ed716a0a3397855c1a9bf485041354bc6696f54f670b5cd9945c0465b4dc65595a9f606427b WHIRLPOOL c43709f66f0de6e66f073e34e4896707db0b91cf556cc225bdc22b7195c92e5777fbf7dc6983d57bcb11cab825ec7c222e0f75c6e52949a68fe5a7b4e43da1ff
diff --git a/net-misc/rclone/rclone-1.37.ebuild b/net-misc/rclone/rclone-1.37.ebuild
new file mode 100644
index 000000000000..0c936bdca50e
--- /dev/null
+++ b/net-misc/rclone/rclone-1.37.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build
+EGO_PN="github.com/ncw/${PN}"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+ EGIT_COMMIT="v${PV}"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A program to sync files to and from various cloud storage providers"
+HOMEPAGE="https://rclone.org/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dobin ${PN}
+ doman src/${EGO_PN}/${PN}.1
+ dodoc src/${EGO_PN}/README.md
+}