summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-03-01 19:13:30 +0100
committerPacho Ramos <pacho@gentoo.org>2018-03-01 19:27:54 +0100
commit92925649ecc8a574aac7b774f99141b0e81f40ee (patch)
tree784d2c7825c75c1984cc715a6fe59bb1425925c1 /net-nntp
parentx11-apps/xkbcomp: Version bump to 1.4.1 (diff)
downloadgentoo-92925649ecc8a574aac7b774f99141b0e81f40ee.tar.gz
gentoo-92925649ecc8a574aac7b774f99141b0e81f40ee.tar.bz2
gentoo-92925649ecc8a574aac7b774f99141b0e81f40ee.zip
net-nntp/xrn: x11-libs/libXp is not really needed, keyword on amd64
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/xrn/xrn-9.02-r1.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/net-nntp/xrn/xrn-9.02-r1.ebuild b/net-nntp/xrn/xrn-9.02-r1.ebuild
new file mode 100644
index 000000000000..ab7ef9309d9c
--- /dev/null
+++ b/net-nntp/xrn/xrn-9.02-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A small and fast news reader for X"
+HOMEPAGE="http://www.mit.edu/people/jik/software/xrn.html"
+SRC_URI="ftp://sipb.mit.edu/pub/${PN}/${P}.tgz"
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt
+"
+DEPEND="${RDEPEND}
+ x11-misc/imake
+"
+
+src_compile() {
+ # English is the default language, but french and german are also
+ # supported, however only one language may be supported at a time:
+ local lingua
+ for lingua in ${LINGUAS} en ; do
+ case "${lingua}" in
+ en*)
+ MY_LANG="english"
+ break # Breaks the for loop.
+ ;;
+ fr*)
+ MY_LANG="french"
+ break # Breaks the for loop.
+ ;;
+ de*)
+ MY_LANG="german"
+ break # Breaks the for loop.
+ ;;
+ esac
+ done
+
+ # Bugs to Gentoo bugzilla:
+ sed -i \
+ -e "s,bug-xrn@kamens.brookline.ma.us,https://bugs.gentoo.org/," \
+ -e "s,\(#ifndef CONFIG_H_IS_OK\),#define CONFIG_H_IS_OK\n\1," \
+ config.h
+
+ # Generate Makefile:
+ xmkmf || die "xmkmf failed"
+
+ # Use our own CFLAGS and our desired language:
+ emake -j1 CDEBUGFLAGS="${CFLAGS}" LANGUAGE="${MY_LANG}"
+}
+
+src_install() {
+ dobin xrn
+ dodoc README README.Linux TODO CREDITS COMMON-PROBLMS
+
+ # Default settings:
+ insinto /etc/X11/app-defaults
+ newins XRn.ad XRn
+
+ newman xrn.man xrn.1
+}