summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-01-20 15:18:45 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-20 21:20:44 +0100
commit0748370ce2fbd9c49e8d8ba1a87628cd9eb0f31a (patch)
treec1366ea0249d84521e63f5aa6ba7e9487077a633 /net-p2p/airdcpp-webclient
parentnet-mail/notmuch: remove unused patch/file (diff)
downloadgentoo-0748370ce2fbd9c49e8d8ba1a87628cd9eb0f31a.tar.gz
gentoo-0748370ce2fbd9c49e8d8ba1a87628cd9eb0f31a.tar.bz2
gentoo-0748370ce2fbd9c49e8d8ba1a87628cd9eb0f31a.zip
net-p2p/airdcpp-webclient: bump to 1.4.1, fix python deps
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3562
Diffstat (limited to 'net-p2p/airdcpp-webclient')
-rw-r--r--net-p2p/airdcpp-webclient/Manifest1
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-1.4.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/net-p2p/airdcpp-webclient/Manifest b/net-p2p/airdcpp-webclient/Manifest
index 95881b292d98..d2111540fce9 100644
--- a/net-p2p/airdcpp-webclient/Manifest
+++ b/net-p2p/airdcpp-webclient/Manifest
@@ -1,2 +1,3 @@
DIST airdcpp-webclient-1.3.1.tar.gz 736889 SHA256 3ec4e2aca343a7d715008482b8197c09b00677d8cb2798470274d944e6e4f5bf SHA512 0a2b4e7a6d639167d51d7ddd4a40e577df7a8babd76df7af7a3a7eb246f73b9840a1f0d96e2a3b494cd05a881881167cc7932b676e9e7d64a28a100c4e0b7467 WHIRLPOOL ea11b7ed94cf4c1fd5ffed0b7e64781bee2b1f4a8255204d662b63bef46bf9808c006ca2b9d6bde572abbfc3e98e25e6300e5ddb99ce90d3717bf2a811433d19
DIST airdcpp-webclient-1.4.0.tar.gz 742614 SHA256 83c0cea711dab4b657b100e6c179ccf0aaa09b7cfbcbed9fd85d38ffc8b92cb0 SHA512 10bc22004870dc08ca722ff7addb5abd940141f19da777d4249621cb4437440de43238c9397498e21c856e8f2380637f81e4ca3c49b513f8d74530e31f340c21 WHIRLPOOL 3a9037be8d3f660af1095092cca22533d338a45031d422eccb6f086e8da45fc574a39167bb0d07087cbc473bff18ec61d316f83e7d34d2bcd07d691cfc5d2264
+DIST airdcpp-webclient-1.4.1.tar.gz 743631 SHA256 9acb61366c91a7aaa03cae58e9aee28ccac05ffe9dff0ec947836fa81967f27f SHA512 7b973251574cb5b49942efa868cef9f689fcf8d804be632ad17c445be98ab55ca9973c5fe9dce052d542006d47a7850af7d236953010c2c0e3158c54e448afe1 WHIRLPOOL e43ccfddc50dbdd0ce8a3cd5b00fc4c844ed69051967d67cca9c9c72b073227d1d20ac510d34b07161c231c7c7d69b945d60872d8756a0ef2c91dfe4a843fe06
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-1.4.1.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-1.4.1.ebuild
new file mode 100644
index 000000000000..ccfa4e59f1cf
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-1.4.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy{,3} )
+
+inherit cmake-utils user python-any-r1
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://airdcpp-web.github.io/"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="nat-pmp +tbb +webui"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-cpp/websocketpp
+ dev-libs/boost:=
+ dev-libs/geoip
+ dev-libs/leveldb
+ dev-libs/openssl:0=[-bindist]
+ net-libs/miniupnpc:=
+ sys-libs/zlib
+ virtual/libiconv
+ nat-pmp? ( net-libs/libnatpmp )
+ tbb? ( dev-cpp/tbb )
+"
+DEPEND="
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+ ${RDEPEND}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ enewgroup airdcppd
+ enewuser airdcppd -1 -1 /var/lib/airdcppd airdcppd
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_WEB_UI=OFF
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ newconfd "${FILESDIR}/airdcppd.confd" airdcppd
+ newinitd "${FILESDIR}/airdcppd.initd" airdcppd
+ keepdir /var/lib/airdcppd
+ fowners airdcppd:airdcppd /var/lib/airdcppd
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}