summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-05-30 01:04:04 +0200
committerAmy Winston <amynka@gentoo.org>2016-05-30 14:42:13 +0200
commite808352db4081384eb54852bb5097f7b5e8afff0 (patch)
tree2bcda470d9fac35a0712ce4ea967b548216cf69e /net-p2p/airdcpp-webclient
parentnet-im/prosody-0.9.10-r0: add amd64 keyword (diff)
downloadgentoo-e808352db4081384eb54852bb5097f7b5e8afff0.tar.gz
gentoo-e808352db4081384eb54852bb5097f7b5e8afff0.tar.bz2
gentoo-e808352db4081384eb54852bb5097f7b5e8afff0.zip
net-p2p/airdcpp-webclient: bump to 1.0.4
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'net-p2p/airdcpp-webclient')
-rw-r--r--net-p2p/airdcpp-webclient/Manifest1
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-1.0.4.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/net-p2p/airdcpp-webclient/Manifest b/net-p2p/airdcpp-webclient/Manifest
index 6f7d3e552784..bc1b1b302ece 100644
--- a/net-p2p/airdcpp-webclient/Manifest
+++ b/net-p2p/airdcpp-webclient/Manifest
@@ -1,3 +1,4 @@
DIST airdcpp-webclient-1.0.1.tar.gz 705436 SHA256 865cb00afa63076ebc1e9f8136380452f8b4d264b8381814cd209acb48525c6c SHA512 5312758d80741434941d43b1312689a25cb96f2e50ca4392074e356dc619d6949fd4ba8a6830ddb0ceb194d2f5a6616eb3b2e772d71efaeb1c49a53fcc5eb541 WHIRLPOOL 804ef5af06aa406511e10b22e320c031d59777d8f5e4ce1dfb02ea03559558741ff5ed6659c6a9175d6f4e1d9e87e0d564a01c9d23d0cba36bf1cf428d018e83
DIST airdcpp-webclient-1.0.2.tar.gz 705947 SHA256 ab5e23438d4a5ed820e5994f758a5e534ea2693096399b152c4e00f654a791fc SHA512 11b09adec44e594ca96f7bc3df81f2739f1f00261406d19277f97b336ff5a71281ad40d2b1f7238fbe1d0461e959f64e6391620ebd38166664e3a47f694d56d5 WHIRLPOOL 67f016e4a0b69410c91de188fc456913a04322fdc7a077fd1830338eaa6db2a8e5450791b9339c222e429ebb87419e8fa0accb420909b4dbe2e27f6ab0bedb26
DIST airdcpp-webclient-1.0.3.tar.gz 706279 SHA256 97239cdb973fd892b01446766b78403852ad39ec44ed9e2b94bd3a4b5514b139 SHA512 8294889d89644476e99ffa6938a52b1f5e5659a2bb51fdd409f06b56295b6fd5788b79c8ab8491af0500331fc4d0bd782535b68778b914ebb841fa16bb47fb08 WHIRLPOOL a0644a6582a9c43621e8b31cc0ed8a100ab395da3b26a3287ec746ec1c58546d8d69e8e56f1b8c0eb0e53f4e5f369e1cfe758ed938f69d676b894ad052c263b7
+DIST airdcpp-webclient-1.0.4.tar.gz 707036 SHA256 ca1bc6a8049f4dfc1d8b2d3ed3a850ea24c8b09445c53d30db9ccbf9dfcfdc49 SHA512 069ec359860b941ce18adb5883b80f75fba017367ea5901a10f08466788cde46aab019e9b275a9524b623a7e34de957e4087ebd891d3aee9cad55a5c1a47f95b WHIRLPOOL 4b4852bb162dd83fbd3ca809553122e105518decd3d2c2d870f23b0369238502e253ba232964dbc3ba0e174f9c8ff43be5abfb47f2b5214a6629e895242f4a1d
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-1.0.4.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-1.0.4.ebuild
new file mode 100644
index 000000000000..662ef58c608d
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-1.0.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils user
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://airdcpp-web.github.io/"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nat-pmp +tbb +webui"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-cpp/websocketpp
+ dev-libs/boost
+ dev-libs/geoip
+ dev-libs/leveldb
+ dev-libs/openssl:0=
+ net-libs/miniupnpc
+ sys-libs/zlib
+ virtual/libiconv
+ nat-pmp? ( net-libs/libnatpmp )
+ tbb? ( dev-cpp/tbb )
+"
+DEPEND="
+ dev-lang/python:*
+ ${RDEPEND}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_WEB_UI=OFF
+ -DLIB_INSTALL_DIR=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ newconfd "${FILESDIR}/airdcppd.confd" airdcppd
+ newinitd "${FILESDIR}/airdcppd.initd" airdcppd
+ keepdir /var/lib/airdcppd
+ fowners airdcppd:airdcppd /var/lib/airdcppd
+ cmake-utils_src_install
+}
+
+pkg_setup() {
+ enewgroup airdcppd
+ enewuser airdcppd -1 -1 /var/lib/airdcppd airdcppd
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}