summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-03-17 19:38:10 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-03-17 19:39:46 +1100
commitde14e66a9a38eb7bb84db6a9a7181a77e690fd0e (patch)
treeae100e04be4151e2e66d9f21bffa19815d077fba /net-p2p/mldonkey
parentx11-plugins/gkrelltop: remove old (diff)
downloadgentoo-de14e66a9a38eb7bb84db6a9a7181a77e690fd0e.tar.gz
gentoo-de14e66a9a38eb7bb84db6a9a7181a77e690fd0e.tar.bz2
gentoo-de14e66a9a38eb7bb84db6a9a7181a77e690fd0e.zip
net-p2p/mldonkey: remove old
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-p2p/mldonkey')
-rw-r--r--net-p2p/mldonkey/Manifest1
-rw-r--r--net-p2p/mldonkey/mldonkey-3.1.3.ebuild170
2 files changed, 0 insertions, 171 deletions
diff --git a/net-p2p/mldonkey/Manifest b/net-p2p/mldonkey/Manifest
index fccb17598553..04c00e0f62fe 100644
--- a/net-p2p/mldonkey/Manifest
+++ b/net-p2p/mldonkey/Manifest
@@ -1,2 +1 @@
-DIST mldonkey-3.1.3.tar.bz2 2848964 SHA256 7c259f9f41cc12899045710ddce02e6d25962b2cb5c22f9cf58af0483f06d9e2 SHA512 921e428743934cd7a94fcdb8fea43a5a57cc3232a68fff443dbeb7f724fbe6805c38f4ae8c6e58c552e7a42c49f1c233f622239d6c7ee1ccf920bc19b2aef8f9 WHIRLPOOL 3e544fa8000e27d16a34af19969a8830f6c22de9ec21e4da2310ca4674a009e64b3bb03b530a03bf2d4cd71346f6de13288bae4b1b04ec0dc9df92f79835afdc
DIST mldonkey-3.1.5.tar.bz2 2847382 SHA256 74f9d4bcc72356aa28d0812767ef5b9daa03efc5d1ddabf56447dc04969911cb SHA512 96e75acf91d7ecc41490f898e06d284da27404c7e567f173936d8113885a3b4b6bc93341358f92a30d3f699eef681d97ce56414a37bb02a535ad2da4d4ad13a3 WHIRLPOOL b9e15809a49cc12e69a6d1188441e9d5603ec76cb7bfe2b2e0bfce3c50abb31296904c842f487076b227f577046ccbd3ceb7cd1a601d3faa6928b1bfde8c780f
diff --git a/net-p2p/mldonkey/mldonkey-3.1.3.ebuild b/net-p2p/mldonkey/mldonkey-3.1.3.ebuild
deleted file mode 100644
index cbdce7b3600f..000000000000
--- a/net-p2p/mldonkey/mldonkey-3.1.3.ebuild
+++ /dev/null
@@ -1,170 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="2"
-WANT_AUTOCONF=2.5
-
-inherit flag-o-matic eutils autotools toolchain-funcs user
-
-IUSE="bittorrent doc fasttrack gd gnutella gtk guionly magic +ocamlopt"
-
-DESCRIPTION="A multi-network P2P application written in Ocaml, with its own Gtk GUI, web and telnet interface"
-HOMEPAGE="http://mldonkey.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ppc ~sparc x86 ~x86-fbsd"
-
-RDEPEND="dev-lang/perl
- guionly? ( >=gnome-base/librsvg-2.4.0
- >=dev-ml/lablgtk-2.6 )
- gtk? ( >=gnome-base/librsvg-2.4.0
- >=dev-ml/lablgtk-2.6[svg] )
- gd? ( >=media-libs/gd-2.0.28[truetype] )
- magic? ( sys-apps/file )"
-
-DEPEND="${RDEPEND}
- >=dev-lang/ocaml-3.10.2[ocamlopt?]"
-
-MLUSER="p2p"
-
-pkg_setup() {
- if use gtk; then
- echo ""
- einfo "If the compile with gui fails, and you have updated Ocaml"
- einfo "recently, you may have forgotten that you need to run"
- einfo "/usr/portage/dev-lang/ocaml/files/ocaml-rebuild.sh"
- einfo "to learn which ebuilds you need to recompile"
- einfo "each time you update Ocaml to a different version"
- einfo "see the Ocaml ebuild for details"
- echo ""
- fi
-
- # dev-lang/ocaml creates its own objects but calls gcc for linking, which will
- # results in relocations if gcc wants to create a PIE executable
- if gcc-specs-pie ; then
- append-ldflags -nopie
- ewarn "Ocaml generates its own native asm, you're using a PIE compiler"
- ewarn "We have appended -nopie to ocaml build options"
- ewarn "because linking an executable with pie while the objects are not pic will not work"
- fi
-}
-
-src_prepare() {
- cd "${S}"/config
- eautoconf
- cd "${S}"
- use ocamlopt || sed -i -e "s/ocamlopt/idontwantocamlopt/g" "${S}/config/configure" || die "failed to disable ocamlopt"
-}
-
-src_configure() {
- # the dirs are not (yet) used, but it doesn't hurt to specify them anyway
-
- # onlygui Disable all nets support, build only chosen GUI
-
- if use gtk || use guionly; then
- myconf="--enable-gui=newgui2"
- else
- myconf="--disable-gui"
- fi
-
- if use guionly; then
- myconf="${myconf} --disable-multinet --disable-donkey"
- fi
-
- cd "${S}"
-
- local my_extra_libs
- if use gd; then
- my_extra_libs="-lpng"
- fi
-
- econf LIBS="${my_extra_libs}"\
- --sysconfdir=/etc/mldonkey \
- --sharedstatedir=/var/mldonkey \
- --localstatedir=/var/mldonkey \
- --enable-checks \
- --disable-batch \
- $(use_enable bittorrent) \
- $(use_enable fasttrack) \
- $(use_enable gnutella) \
- $(use_enable gnutella gnutella2) \
- $(use_enable gd) \
- $(use_enable magic) \
- ${myconf}
-}
-
-src_compile() {
- export OCAMLRUNPARAM="l=256M"
- emake || die "emake failed"
-
- if ! use guionly; then
- emake utils || die "emake utils failed"
- fi;
-}
-
-src_install() {
- local myext=""
- use ocamlopt || myext=".byte"
- use ocamlopt || export STRIP_MASK="*/bin/*"
- if ! use guionly; then
- for i in mlnet mld_hash get_range copysources subconv; do
- newbin $i$myext $i || die "failed to install $i"
- done
- use bittorrent && newbin make_torrent$myext make_torrent
-
- newconfd "${FILESDIR}/mldonkey.confd-2.8" mldonkey
- fperms 600 /etc/conf.d/mldonkey
- newinitd "${FILESDIR}/mldonkey.initd" mldonkey
- fi
-
- if use gtk; then
- for i in mlgui mlguistarter; do
- newbin $i$myext $i || die "failed to install $i"
- done
- make_desktop_entry mlgui "MLDonkey GUI" mldonkey "Network;P2P"
- newicon "${S}"/packages/rpm/mldonkey-icon-48.png ${PN}.png
- fi
-
- if use doc ; then
- cd "${S}"/distrib
- dodoc ChangeLog *.txt
-
- insinto /usr/share/doc/${PF}/scripts
- doins kill_mldonkey mldonkey_command mldonkey_previewer make_buginfo
-
- cd "${S}"/docs
- dodoc *.txt *.tex *.pdf
- dohtml *.html
-
- cd "${S}"/docs/developers
- dodoc *.txt *.tex
-
- cd "${S}"/docs/images
- insinto /usr/share/doc/${PF}/html/images
- doins *
- fi
-}
-
-pkg_preinst() {
- if ! use guionly; then
- enewuser ${MLUSER} -1 -1 /home/p2p users
- fi
-}
-
-pkg_postinst() {
- if ! use guionly; then
- echo
- einfo "If you want to start MLDonkey as a system service, use"
- einfo "the /etc/init.d/mldonkey script. To control bandwidth, use"
- einfo "the 'slow' and 'fast' arguments. Be sure to have a look at"
- einfo "/etc/conf.d/mldonkey also."
- echo
- else
- echo
- einfo "Simply run mlgui to start the chosen MLDonkey gui."
- einfo "It puts its config files into ~/.mldonkey"
- fi
-}