summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Popp <Marc.Popp@sunny-computing.de>2016-08-25 18:47:48 +0200
committerAnthony G. Basile <blueness@gentoo.org>2016-08-25 14:11:35 -0400
commit2b633f72bcc0ea57e51c152dff2138552982a2ed (patch)
tree7a3fde8652e5794201eecc027fec144e83022bc8 /net-p2p
parentnet-p2p/litecoin-qt: Version Bump to 0.10.4.0, bug #592112 (diff)
downloadgentoo-2b633f72bcc0ea57e51c152dff2138552982a2ed.tar.gz
gentoo-2b633f72bcc0ea57e51c152dff2138552982a2ed.tar.bz2
gentoo-2b633f72bcc0ea57e51c152dff2138552982a2ed.zip
net-p2p/litecoind: Version Bump to 0.10.4.0, bug #592100
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/litecoind/Manifest1
-rw-r--r--net-p2p/litecoind/litecoind-0.10.4.0.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/net-p2p/litecoind/Manifest b/net-p2p/litecoind/Manifest
index 992235cce43b..a1d9c8db7200 100644
--- a/net-p2p/litecoind/Manifest
+++ b/net-p2p/litecoind/Manifest
@@ -1 +1,2 @@
DIST litecoin-0.10.2.2.tar.gz 4700783 SHA256 952c84b181323db17a8fa23217f59b576ad3ebad92c158b3a7c29d458a1130dc SHA512 46e4c014ae8527dd58af073bab96ea4fd55c69fcc63eaa4fd600bf3c1fc2102500151b49431a72b55334a409d4f5226937cd0c5337feaa4ad49e6ef9e9728aba WHIRLPOOL 5c1d5605d4afb16744fcf0b09dd52eb574aea0cdd9754f94d4cfd9ac064491a0e192d8c4b1a3324e355d71758735265b272dfa41f938212e17badb9f8a70698b
+DIST litecoin-0.10.4.0.tar.gz 4730189 SHA256 a9adb6d2ae555afdaa2a5febb81341ac506930cf04ab95b9dc3ab99a4de0405e SHA512 ae17e754d188efb1b51a376a52fe03e43b58c5059673b7dd4ecbf4f48574290b84011525fef2e10893f53e4da3d6ad9b5577001bb40aef7080d4c2479f4714a9 WHIRLPOOL 21737a593390cd8ef41e5adb77e6cd5ccb886bdbc8d2ea96078bac99ffab5c95347cd86f1e9047b5ee528a112bfe3ae0e5ef5be3498b7aa36ec169bdfdaf4818
diff --git a/net-p2p/litecoind/litecoind-0.10.4.0.ebuild b/net-p2p/litecoind/litecoind-0.10.4.0.ebuild
new file mode 100644
index 000000000000..283321c68933
--- /dev/null
+++ b/net-p2p/litecoind/litecoind-0.10.4.0.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DB_VER="4.8"
+
+inherit autotools db-use eutils flag-o-matic systemd user
+
+MyPV="${PV/_/-}"
+MyPN="litecoin"
+MyP="${MyPN}-${MyPV}"
+
+DESCRIPTION="Litecoin is a peer-to-peer Internet currency that enables instant, near-zero cost payments to anyone in the world. It's based on Bitcoin and not so widely adapted."
+HOMEPAGE="https://litecoin.org/"
+SRC_URI="https://github.com/${MyPN}-project/${MyPN}/archive/v${MyPV}.tar.gz -> ${MyP}.tar.gz"
+
+LICENSE="MIT ISC GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="logrotate upnp +wallet"
+
+RDEPEND="
+ dev-libs/boost[threads(+)]
+ dev-libs/openssl:0[-bindist]
+ logrotate? ( app-admin/logrotate )
+ upnp? ( net-libs/miniupnpc )
+ sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+ >=dev-libs/leveldb-1.18-r1
+"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-4.1
+ sys-apps/sed
+"
+
+S="${WORKDIR}/${MyP}"
+
+pkg_setup() {
+ local UG='litecoin'
+ enewgroup "${UG}"
+ enewuser "${UG}" -1 -1 /var/lib/litecoin "${UG}"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/0.9.0-sys_leveldb.patch
+ epatch "${FILESDIR}"/litecoind-0.10.2.2-memenv_h.patch
+ epatch "${FILESDIR}"/litecoind-0.10.2.2-fix-gnustack.patch
+ eautoreconf
+ rm -r src/leveldb
+}
+
+src_configure() {
+ # To avoid executable GNU stack.
+ append-ldflags -Wl,-z,noexecstack
+
+ local my_econf=
+ if use upnp; then
+ my_econf="${my_econf} --with-miniupnpc --enable-upnp-default"
+ else
+ my_econf="${my_econf} --without-miniupnpc --disable-upnp-default"
+ fi
+ econf \
+ $(use_enable wallet)\
+ --disable-ccache \
+ --disable-static \
+ --disable-tests \
+ --with-system-leveldb \
+ --with-system-libsecp256k1 \
+ --without-libs \
+ --with-daemon \
+ --without-gui \
+ --without-qrencode \
+ ${my_econf}
+}
+
+src_install() {
+ default
+
+ insinto /etc/litecoin
+ doins "${FILESDIR}/litecoin.conf"
+ fowners litecoin:litecoin /etc/litecoin/litecoin.conf
+ fperms 600 /etc/litecoin/litecoin.conf
+
+ newconfd "${FILESDIR}/litecoin.confd" ${PN}
+ newinitd "${FILESDIR}/litecoin.initd-r1" ${PN}
+ systemd_dounit "${FILESDIR}/litecoin.service"
+
+ keepdir /var/lib/litecoin/.litecoin
+ fperms 700 /var/lib/litecoin
+ fowners litecoin:litecoin /var/lib/litecoin/
+ fowners litecoin:litecoin /var/lib/litecoin/.litecoin
+ dosym /etc/litecoin/litecoin.conf /var/lib/litecoin/.litecoin/litecoin.conf
+
+ dodoc doc/README.md doc/release-notes.md
+ newman contrib/debian/manpages/bitcoind.1 litecoind.1
+ newman contrib/debian/manpages/bitcoin.conf.5 litecoin.conf.5
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/litecoind.logrotate" litecoind
+ fi
+}