summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-05-23 22:30:02 -0400
committerMike Gilbert <floppym@gentoo.org>2020-05-23 22:33:18 -0400
commit2c2c3883f3500dc67e6d7e9c789d815abc9d622a (patch)
tree088b8548a1ac32af9fa52bf5ffcd715e309d7327 /net-p2p
parentmail-filter/opensmtpd-filter-rspamd: bump to 0.1.6 (diff)
downloadgentoo-2c2c3883f3500dc67e6d7e9c789d815abc9d622a.tar.gz
gentoo-2c2c3883f3500dc67e6d7e9c789d815abc9d622a.tar.bz2
gentoo-2c2c3883f3500dc67e6d7e9c789d815abc9d622a.zip
net-p2p/transmission: disable cmake warning for subprojects
Closes: https://bugs.gentoo.org/724792 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/transmission/files/cmake-unused-command-line.patch21
-rw-r--r--net-p2p/transmission/transmission-3.00.ebuild4
2 files changed, 25 insertions, 0 deletions
diff --git a/net-p2p/transmission/files/cmake-unused-command-line.patch b/net-p2p/transmission/files/cmake-unused-command-line.patch
new file mode 100644
index 000000000000..6e0af5dc7cc9
--- /dev/null
+++ b/net-p2p/transmission/files/cmake-unused-command-line.patch
@@ -0,0 +1,21 @@
+From 63b8fd6391cd30bb45e1c9432f69c43ade9bb7ea Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Sat, 23 May 2020 22:25:42 -0400
+Subject: [PATCH] Do not warn about unused command line options
+
+---
+ cmake/TrMacros.cmake | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/cmake/TrMacros.cmake b/cmake/TrMacros.cmake
+index 5e439126f..674b2ede0 100644
+--- a/cmake/TrMacros.cmake
++++ b/cmake/TrMacros.cmake
+@@ -95,6 +95,7 @@ macro(tr_add_external_auto_library ID DIRNAME LIBNAME)
+ PREFIX "${${ID}_PREFIX}"
+ CMAKE_ARGS
+ -Wno-dev # We don't want to be warned over unused variables
++ --no-warn-unused-cli
+ "-DCMAKE_TOOLCHAIN_FILE:PATH=${CMAKE_TOOLCHAIN_FILE}"
+ "-DCMAKE_USER_MAKE_RULES_OVERRIDE=${CMAKE_USER_MAKE_RULES_OVERRIDE}"
+ "-DCMAKE_C_FLAGS:STRING=${CMAKE_C_FLAGS}"
diff --git a/net-p2p/transmission/transmission-3.00.ebuild b/net-p2p/transmission/transmission-3.00.ebuild
index 04a6fdf45294..3cfd308eb560 100644
--- a/net-p2p/transmission/transmission-3.00.ebuild
+++ b/net-p2p/transmission/transmission-3.00.ebuild
@@ -84,6 +84,10 @@ RDEPEND="${COMMON_DEPEND}
${ACCT_DEPEND}
"
+PATCHES=(
+ "${FILESDIR}"/cmake-unused-command-line.patch
+)
+
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_DOCDIR=share/doc/${PF}