summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-07-09 22:59:30 -0400
committerCraig Andrews <candrews@gentoo.org>2020-07-09 22:59:30 -0400
commit334e080e289999e06e4b4d3ddaf071ca8021733b (patch)
tree94ea035edbedc904bc64d2d34b67f3d82b813709 /net-p2p
parentmedia-tv/kodi: Cleanup old versions (diff)
downloadgentoo-334e080e289999e06e4b4d3ddaf071ca8021733b.tar.gz
gentoo-334e080e289999e06e4b4d3ddaf071ca8021733b.tar.bz2
gentoo-334e080e289999e06e4b4d3ddaf071ca8021733b.zip
net-p2p/cpuminer-opt: 3.14.3 version bump
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.14.3.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index c1c6d5e0167e..47424e20325e 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -1,2 +1,3 @@
DIST cpuminer-opt-3.12.13.tar.gz 1809807 BLAKE2B c971153fc1099dc29ae93ab341e905b3d0252d02468e0f125692a38d00121f82a2825d61e8303e45f4b41f64280d780a02f742eb61d117601a6ce47db57d4d2d SHA512 830371c4e2931101d33d124c86733e9f079ace5b4b59e3b5149db0655c93031dcbbb2dd370d4729b7e697670117c0b6874214a8aa569dcca92c6750dbc88a8b8
DIST cpuminer-opt-3.12.4.2.tar.gz 1811456 BLAKE2B a19dfa37b726020f3143bd0a11fba52aae0eaea5295e8fc568815a12ade1e5c55d560ac964316f4ed3f272873ce1a393f581dc6143504eeadeb302ba83f3c017 SHA512 97222820c321cb34748a9e0550d7b1ded3d0d3980b7855d72cd0eabf5f6a03e121552e62ee52389bf0d5182c54f226b61f0549e787fdc0b0351d2fffa7a7e7c2
+DIST cpuminer-opt-3.14.3.tar.gz 1822560 BLAKE2B 82e632577b0bd910c8a5bf1fa37bacc27c45ade178456113b986d070b46b7394eddaebcbff675d3cf842dc4f63253133244af1a706159a714ab8c043cd762e8c SHA512 ad8700a1ca0eca34cf9b15235e8c413ab7250dd47c6e1eba6a0b8c81665e7fa4aaef981f601a876d3973ef06cdbe7df56ce2d3827a5bac6de63434f1faf1d771
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.14.3.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.14.3.ebuild
new file mode 100644
index 000000000000..a5d436b3b8b8
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.14.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ >=net-misc/curl-7.15[ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}