summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-12-10 20:20:23 -0500
committerCraig Andrews <candrews@gentoo.org>2019-12-10 20:28:32 -0500
commite499d6913d27441adc1dd054f680cbf23a02ccca (patch)
tree63e0abf35a90570789e1670a14bef0a3b95fe7ac /net-p2p
parentapp-admin/spectre-meltdown-checker: 0.43 version bump (diff)
downloadgentoo-e499d6913d27441adc1dd054f680cbf23a02ccca.tar.gz
gentoo-e499d6913d27441adc1dd054f680cbf23a02ccca.tar.bz2
gentoo-e499d6913d27441adc1dd054f680cbf23a02ccca.zip
net-p2p/cpuminer-opt: 3.10.2 version bump
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.10.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 0fbdd72876b2..38ac742382cf 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -1,4 +1,5 @@
DIST cpuminer-opt-3.10.0.tar.gz 1909417 BLAKE2B 49b60bc50224c9843e2c5ba3d712d930a6ab1e5bcf486e481cf5a3f10e6b0813ea76534a28ec7113da544440f05cfcebaf95f6d70a51fad53ca5bc2c7e8511dc SHA512 d5820f65458b5281fdcb4fb0dc2f33785de2d8dfb0965e56720bb336035c2e03db4ae0bbc536952309c81df00792327ce20e73a5536b73c73690dd14bc669212
+DIST cpuminer-opt-3.10.2.tar.gz 1930097 BLAKE2B 14c2067d0fcbcbd78db346550868be5b0b109c76fc99b146054799912f66b39b6c382f221cd614ed4953aa344dc6174b47b87272d466845a7acb9b81820c0c25 SHA512 2d6907f7a577c90c9f57acb0ff593e65e855bb9e818fed5ba00f2388dbc74df829e6c6c6b9211d129a2ec160ba7d628ef789230aeeb4954aaf23b7c445601b32
DIST cpuminer-opt-3.9.10.tar.gz 1818868 BLAKE2B aa29c101af2f17b128b264c3c6639d3af9c4bfd1abf0a5139b33d06b68f9c9217d1ad19cdd53fd245fed4b5cb7a0ff81789d9929debea5b8d225c7f8b29ae940 SHA512 46da5f43df0f46a94a160310de74776880fed748ec955220544cc1ff08eada8f9dd774250913ffbaeed8a6237e69bae730c8f18c48e87b8600b9407a6de03cc4
DIST cpuminer-opt-3.9.11.tar.gz 1903437 BLAKE2B dd15fbdcefa89bd314d6ec174b8556a7157ca9347346d012d198b34961f6f0fc1b4d313ce040cd0bd36ef053897f2b2d6da4e086e780895efc5af2969039be95 SHA512 4a3589fe4d4990b78996516df91d81ae2ac6708cffd0b8342a94adfcc5eacc7b810a49efb5e4821912ca0e703e7342a70d6a97a847a92b11925475767ed357a6
DIST cpuminer-opt-3.9.6.2.tar.gz 1796238 BLAKE2B 5c9ef9e04897ac8e62196bb54606b407ae5df7f48074f91c202a7323f9ebfa5c44361df99ed83f9c67e69080580c9bf1e29607b491c872a2f1385c8c42444940 SHA512 92e96724fc40d974cd80d61c19c7d46b6581ec0e63328bf940cade12231240fa17f26639a6c344cf19c20ea6e6f7dc4178dea7db51a4c7ec85a66ab5e4a5e59d
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.10.2.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.10.2.ebuild
new file mode 100644
index 000000000000..666d27ee1c02
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.10.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ >=net-misc/curl-7.15[ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}