summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-10-28 20:56:29 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-10-28 20:56:29 +0200
commit7e6d69424774c9a6650a3c5f92f09ed4a877b5bb (patch)
treefdd401951585e951118306c1b153d87c80bb256c /net-print/hplip-plugin
parentnet-print/hplip: Version bump (diff)
downloadgentoo-7e6d69424774c9a6650a3c5f92f09ed4a877b5bb.tar.gz
gentoo-7e6d69424774c9a6650a3c5f92f09ed4a877b5bb.tar.bz2
gentoo-7e6d69424774c9a6650a3c5f92f09ed4a877b5bb.zip
net-print/hplip-plugin: Version bump to 3.6.10
Package-Manager: portage-2.3.2
Diffstat (limited to 'net-print/hplip-plugin')
-rw-r--r--net-print/hplip-plugin/Manifest1
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.16.10.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index 645507883c37..201224df3fd6 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1,2 +1,3 @@
+DIST hplip-3.16.10-plugin.run 2061876 SHA256 84ad87ef986fccc3c07c163a3eb494eda8971bdcd0e967c7ad7f60b6fd70527e SHA512 9778431b641c8566ae7bce5c812d7c3f95e3d6b166bc413f4e3b534527cd2a0871495a3b74049f74441a1f450f5e04f8895055aa5982f74bfde35af1ee512e33 WHIRLPOOL 701776290398a8bae98a69af60303b6073593d574c81c22a6ef115370fa6fdbb43b5b1250a2b3f167be1e57ad6f29b63fed51bdd1b22a070140358043e190099
DIST hplip-3.16.3-plugin.run 2084271 SHA256 b7edef2a1c5c0a5e001deb4a18c0ef7202e653596e97144b8908ae093818070f SHA512 2ae8aeb40c2604a2c6b9725700f9addf7a82e819d603631158a5d5feac931248e53e7533178100df1fc12b0dc2340cb3ae0d85f145cd023a311f77bbe67e7c7f WHIRLPOOL 928117f862030eca9c3e5813eb8c4db66570923695b0c7af17df1992f339d2478f42af67ca0e0eb8cfa1d7425b522082fde3b8c829c3f5167e1ec503c95a986b
DIST hplip-3.16.9-plugin.run 2084344 SHA256 7394ab79dd943bb530a7117266dec3f280ac0f825c4d12831c14eec922349c9f SHA512 fdf6fd5d2ff458a5c68bce039914c72d1b118dd8909ef0333861ac26472801185bea43947b983fe164b1a1f80e99800fe3e098e045a0d3c7cbebd03ab83bcbe0 WHIRLPOOL a20d5c582b817eeb1900f6e2b1d650ff63b6eb6f08c4088fc462b66bfeafcbaa4122560fda87cdd0b85d7577a092abd2213c0606d91523306f6ad6349000bc58
diff --git a/net-print/hplip-plugin/hplip-plugin-3.16.10.ebuild b/net-print/hplip-plugin/hplip-plugin-3.16.10.ebuild
new file mode 100644
index 000000000000..8408448871b0
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.16.10.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit udev unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="http://hplipopensource.com/hplip-web/index.html"
+SRC_URI="http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-${PV}-plugin.run"
+
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/udev
+"
+DEPEND=""
+
+S=${WORKDIR}
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PRESTRIPPED="
+ /usr/share/hplip/fax/plugins/fax_marvell.so
+ /usr/share/hplip/prnt/plugins/hbpl1.so
+ /usr/share/hplip/prnt/plugins/lj.so
+ /usr/share/hplip/scan/plugins/bb_marvell.so
+ /usr/share/hplip/scan/plugins/bb_soapht.so
+ /usr/share/hplip/scan/plugins/bb_soap.so
+"
+
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+src_unpack() {
+ unpack_makeself "hplip-${PV}-plugin.run"
+}
+
+src_install() {
+ local hplip_arch=$(use amd64 && echo 'x86_64' || echo 'x86_32')
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ fax_*) plugin_type=fax ;;
+ bb_*) plugin_type=scan ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ mkdir -p "${ED}/var/lib/hp/"
+ cat >> "${ED}/var/lib/hp/hplip.state" <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}