summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-04-03 16:50:17 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-04-03 16:52:47 +0200
commit7332f678c2dcbe72c4afafcbbf395a3a4559f7a3 (patch)
tree9ec959933cb473b32d63c147926f9fc59aaf1ebb /net-print
parentapp-emulation/docker-compose: remove version 1.5.1 (diff)
downloadgentoo-7332f678c2dcbe72c4afafcbbf395a3a4559f7a3.tar.gz
gentoo-7332f678c2dcbe72c4afafcbbf395a3a4559f7a3.tar.bz2
gentoo-7332f678c2dcbe72c4afafcbbf395a3a4559f7a3.zip
net-print/hplip-plugin: Version bump to 3.16.3
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-print')
-rw-r--r--net-print/hplip-plugin/Manifest1
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.16.3.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index 12e474cf1a76..5e2a6049e336 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1 +1,2 @@
DIST hplip-3.14.10-plugin.run 1869038 SHA256 b395b480ad86b9f27b6a2f63b6ecb00beb78e762a6137efb81dc1104837f9b81 SHA512 3e5bea924e989d902aea0de182941be692a124ba8c27f53ce2e4f137308bad8373462c6128c26716e481e758f76533163d311a2676df034c1b15d6ef6ed008be WHIRLPOOL 18375de4cc92cb73bcaa109927bd34f8487938b02472f0b7adbf44ad4688e5c6a1d030077b1e3c14f15f9b8e4cc86d195b0195e2d08121f746c62624db4658db
+DIST hplip-3.16.3-plugin.run 2084271 SHA256 b7edef2a1c5c0a5e001deb4a18c0ef7202e653596e97144b8908ae093818070f SHA512 2ae8aeb40c2604a2c6b9725700f9addf7a82e819d603631158a5d5feac931248e53e7533178100df1fc12b0dc2340cb3ae0d85f145cd023a311f77bbe67e7c7f WHIRLPOOL 928117f862030eca9c3e5813eb8c4db66570923695b0c7af17df1992f339d2478f42af67ca0e0eb8cfa1d7425b522082fde3b8c829c3f5167e1ec503c95a986b
diff --git a/net-print/hplip-plugin/hplip-plugin-3.16.3.ebuild b/net-print/hplip-plugin/hplip-plugin-3.16.3.ebuild
new file mode 100644
index 000000000000..8408448871b0
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.16.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit udev unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="http://hplipopensource.com/hplip-web/index.html"
+SRC_URI="http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-${PV}-plugin.run"
+
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/udev
+"
+DEPEND=""
+
+S=${WORKDIR}
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PRESTRIPPED="
+ /usr/share/hplip/fax/plugins/fax_marvell.so
+ /usr/share/hplip/prnt/plugins/hbpl1.so
+ /usr/share/hplip/prnt/plugins/lj.so
+ /usr/share/hplip/scan/plugins/bb_marvell.so
+ /usr/share/hplip/scan/plugins/bb_soapht.so
+ /usr/share/hplip/scan/plugins/bb_soap.so
+"
+
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+src_unpack() {
+ unpack_makeself "hplip-${PV}-plugin.run"
+}
+
+src_install() {
+ local hplip_arch=$(use amd64 && echo 'x86_64' || echo 'x86_32')
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ fax_*) plugin_type=fax ;;
+ bb_*) plugin_type=scan ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ mkdir -p "${ED}/var/lib/hp/"
+ cat >> "${ED}/var/lib/hp/hplip.state" <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}