summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-07-23 17:19:21 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-07-23 17:19:21 +0200
commitc2dff61a61449dd0809fee3d98aca1fa1a55e1d3 (patch)
treeb37a4e4a9a55026bd00759cb4f2e2f22c9ea36bd /net-print
parentapp-emulation/qemu: fix aarch64 tcg simd crash (diff)
downloadgentoo-c2dff61a61449dd0809fee3d98aca1fa1a55e1d3.tar.gz
gentoo-c2dff61a61449dd0809fee3d98aca1fa1a55e1d3.tar.bz2
gentoo-c2dff61a61449dd0809fee3d98aca1fa1a55e1d3.zip
net-print/hplip-plugin: Version bump to 3.18.6
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'net-print')
-rw-r--r--net-print/hplip-plugin/Manifest1
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.18.6.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index d514cc552b5e..3ba10f94b51b 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1,2 +1,3 @@
DIST hplip-3.17.10-plugin.run 2062947 BLAKE2B 86f15193a751794eb64acfbaf1b42151c34336603d4d592cc84a375ccca4e7be4177d3dda76fc153ac0a6898eff24174df43256450cd81ae8ad4d4f6abd69ade SHA512 98eef413b122527c4a7860b621baf11c04ec9d7f4e43ce4f36e7822a633c64b3d98cbc86cd7d305c74d9a49a4159ebd7280d652e1ba430cad4cc70f66d23ee07
DIST hplip-3.18.5-plugin.run 2065554 BLAKE2B af0acfbde9c5c3ff92437c86739dac339e91f7d4e1552bad46b3e3a4831317b3ddd3b18375bc8ed4e2340d7b039f11b2bf2b48145ba02b59c876c28fc51842de SHA512 5fd105f15dcc5f47948090c3cb32a2b7db5abc81d10a33e76b4274be407d56c2ff6d6a877f1931ed8a1fa01e7b109a65424fe9de7a6cb5f7eb5f968a10f4721c
+DIST hplip-3.18.6-plugin.run 2065663 BLAKE2B 501a37dd504250225ddad9712259e0e1b564aa034e433f24d277c5609fa95580417da1a0ae040a4624ff48806a3b34ec56ff31aed843e9f0f0b68b304d2ebd9e SHA512 7b5eb2f43dd014df25ccd9e72dd7efc069db47921f2de650b2ff993dbee60056063edeee6593be7d35019212daf623fff9696b13508a808db92128f5c81bde76
diff --git a/net-print/hplip-plugin/hplip-plugin-3.18.6.ebuild b/net-print/hplip-plugin/hplip-plugin-3.18.6.ebuild
new file mode 100644
index 000000000000..afbacbc8fbc3
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.18.6.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit udev unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing"
+SRC_URI="http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-${PV}-plugin.run"
+
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/udev
+"
+DEPEND=""
+
+S=${WORKDIR}
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PRESTRIPPED="
+ /usr/share/hplip/fax/plugins/fax_marvell.so
+ /usr/share/hplip/prnt/plugins/hbpl1.so
+ /usr/share/hplip/prnt/plugins/lj.so
+ /usr/share/hplip/scan/plugins/bb_escl.so
+ /usr/share/hplip/scan/plugins/bb_marvell.so
+ /usr/share/hplip/scan/plugins/bb_soapht.so
+ /usr/share/hplip/scan/plugins/bb_soap.so
+"
+
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+src_unpack() {
+ unpack_makeself "hplip-${PV}-plugin.run"
+}
+
+src_install() {
+ local hplip_arch=$(use amd64 && echo 'x86_64' || echo 'x86_32')
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ fax_*) plugin_type=fax ;;
+ bb_*) plugin_type=scan ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ mkdir -p "${ED}/var/lib/hp/"
+ cat >> "${ED}/var/lib/hp/hplip.state" <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}