summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2018-05-24 23:42:45 +0200
committerDaniel Pielmeier <billie@gentoo.org>2018-05-24 23:42:45 +0200
commitf9f74ce351b51553f62c9daaeb9db3ff53376c45 (patch)
treed61439ce4cc95f4e9c859f0c30d058c07837f871 /net-print
parentnet-print/hplip-plugin: Remove old. (diff)
downloadgentoo-f9f74ce351b51553f62c9daaeb9db3ff53376c45.tar.gz
gentoo-f9f74ce351b51553f62c9daaeb9db3ff53376c45.tar.bz2
gentoo-f9f74ce351b51553f62c9daaeb9db3ff53376c45.zip
net-print/hplip-plugin: Version bump.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-print')
-rw-r--r--net-print/hplip-plugin/Manifest1
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.18.4.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index 3114432113c3..8c10e9212a8d 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1 +1,2 @@
DIST hplip-3.17.10-plugin.run 2062947 BLAKE2B 86f15193a751794eb64acfbaf1b42151c34336603d4d592cc84a375ccca4e7be4177d3dda76fc153ac0a6898eff24174df43256450cd81ae8ad4d4f6abd69ade SHA512 98eef413b122527c4a7860b621baf11c04ec9d7f4e43ce4f36e7822a633c64b3d98cbc86cd7d305c74d9a49a4159ebd7280d652e1ba430cad4cc70f66d23ee07
+DIST hplip-3.18.4-plugin.run 2065541 BLAKE2B 0e7af5eaf3059c4e77b5213e2fcb240da898f1bb68162fedf4b36e0f47cb1fa060f908a617f7ca1d10aadf6fa59f9617fdf91374c709c3439a59ca27560f186c SHA512 8e8aaa9703b12806ebcaa10ec764489baa02ce48a3f73f82a6ae964c6ed01882e1ae315b4ccd923e96792217765d6f8ac9c01e9b6ea41af86b13ba6100229fb9
diff --git a/net-print/hplip-plugin/hplip-plugin-3.18.4.ebuild b/net-print/hplip-plugin/hplip-plugin-3.18.4.ebuild
new file mode 100644
index 000000000000..b96c3ec3601d
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.18.4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit udev unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="http://hplipopensource.com/hplip-web/index.html"
+SRC_URI="http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-${PV}-plugin.run"
+
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/udev
+"
+DEPEND=""
+
+S=${WORKDIR}
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PRESTRIPPED="
+ /usr/share/hplip/fax/plugins/fax_marvell.so
+ /usr/share/hplip/prnt/plugins/hbpl1.so
+ /usr/share/hplip/prnt/plugins/lj.so
+ /usr/share/hplip/scan/plugins/bb_escl.so
+ /usr/share/hplip/scan/plugins/bb_marvell.so
+ /usr/share/hplip/scan/plugins/bb_soapht.so
+ /usr/share/hplip/scan/plugins/bb_soap.so
+"
+
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+src_unpack() {
+ unpack_makeself "hplip-${PV}-plugin.run"
+}
+
+src_install() {
+ local hplip_arch=$(use amd64 && echo 'x86_64' || echo 'x86_32')
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ fax_*) plugin_type=fax ;;
+ bb_*) plugin_type=scan ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ mkdir -p "${ED}/var/lib/hp/"
+ cat >> "${ED}/var/lib/hp/hplip.state" <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}