summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-proxy/cntlm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-proxy/cntlm')
-rw-r--r--net-proxy/cntlm/Manifest1
-rw-r--r--net-proxy/cntlm/cntlm-0.93_beta5-r1.ebuild55
-rw-r--r--net-proxy/cntlm/files/cntlm-0.93_beta5-buildsystem.patch195
-rw-r--r--net-proxy/cntlm/files/cntlm.confd5
-rw-r--r--net-proxy/cntlm/files/cntlm.initd22
-rw-r--r--net-proxy/cntlm/files/cntlm.service9
-rw-r--r--net-proxy/cntlm/metadata.xml12
7 files changed, 299 insertions, 0 deletions
diff --git a/net-proxy/cntlm/Manifest b/net-proxy/cntlm/Manifest
new file mode 100644
index 000000000000..f42a38cd093c
--- /dev/null
+++ b/net-proxy/cntlm/Manifest
@@ -0,0 +1 @@
+DIST cntlm-0.93beta5.tar.gz 718018 SHA256 97d0d7162e1c782a74958af3b7f48f61ae72b49d2f608d21155f804583a6a754 SHA512 5cb59788a0d6dc5cd787acb36dbe6de9a3909727d63327c9a12b20973619b777add9e0acbe94ed6a3cf1c189ef0e0ac6c01aa3c1c4739881bbd371b4c90744cd WHIRLPOOL e2627cf54e3e91bcc08cbaa9e6e95cb7fb8464bf48e6f924575a86237188d976d86ef9b1cb960c2cd982316dd3ebb6d1bd7129aa4191cbd605f69df09af4b715
diff --git a/net-proxy/cntlm/cntlm-0.93_beta5-r1.ebuild b/net-proxy/cntlm/cntlm-0.93_beta5-r1.ebuild
new file mode 100644
index 000000000000..d206912adda0
--- /dev/null
+++ b/net-proxy/cntlm/cntlm-0.93_beta5-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils systemd toolchain-funcs user
+
+DESCRIPTION="Cntlm is an NTLM/NTLMv2 authenticating HTTP proxy"
+HOMEPAGE="http://cntlm.sourceforge.net/"
+SRC_URI="http://ftp.awk.cz/pub/${P//_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${P//_}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-buildsystem.patch # 334647
+}
+
+src_configure() {
+ tc-export CC
+
+ econf
+
+ # Replace default config file path in Makefile
+ sed -i -e 's~SYSCONFDIR=/usr/local/etc~SYSCONFDIR=/etc~' \
+ "${S}"/Makefile || die "sed failed"
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ dobin cntlm
+ dodoc COPYRIGHT README VERSION doc/cntlm.conf
+ doman doc/cntlm.1
+ newinitd "${FILESDIR}"/cntlm.initd cntlm
+ newconfd "${FILESDIR}"/cntlm.confd cntlm
+ systemd_dounit "${FILESDIR}"/cntlm.service
+ insinto /etc
+ insopts -m0600
+ doins doc/cntlm.conf
+}
+
+pkg_postinst() {
+ enewgroup cntlm
+ enewuser cntlm -1 -1 -1 cntlm
+}
diff --git a/net-proxy/cntlm/files/cntlm-0.93_beta5-buildsystem.patch b/net-proxy/cntlm/files/cntlm-0.93_beta5-buildsystem.patch
new file mode 100644
index 000000000000..d553e8661484
--- /dev/null
+++ b/net-proxy/cntlm/files/cntlm-0.93_beta5-buildsystem.patch
@@ -0,0 +1,195 @@
+Gentoo Bug#334647:
+Respect CC, CFLAGS, LDFLAGS (with gcc).
+Support verbose building via 'make V=1'.
+--- configure.orig 2012-10-02 14:01:48.735669564 +0200
++++ configure 2012-10-02 14:23:01.224271511 +0200
+@@ -10,7 +10,7 @@
+ # This can be disabled if neccessary.
+ #
+
+-CCS="xlc_r gcc"
++CCS=${CC-"xlc_r gcc"}
+
+ #
+ # Look for supported compilers
+@@ -31,15 +31,21 @@
+ else
+ echo "Using $CCPATH to compile Cntlm"
+ [ -h Makefile ] && rm -f Makefile 2>/dev/null
+- case "$CC" in
+- gcc)
++ if $CC -v >/dev/null 2>&1; then
+ # default Makefile is for GCC; just revert back to
+ # GCC if Makefile is linked to other compiler version
+ if [ ! -f Makefile ]; then
+ mv Makefile.gcc Makefile
+ fi
+- ;;
+- *)
++ : ${CFLAGS=-O3}
++ : ${LDFLAGS=}
++ CFLAGS="$CFLAGS -std=c99 -Wall -Wno-unused-but-set-variable -pedantic -pthread"
++ LDFLAGS="$LDFLAGS -pthread"
++ sed -e "s~^CFLAGS[ :]*=~CFLAGS=$CFLAGS ~" \
++ -e "s~^LDFLAGS[ :]*=.*~LDFLAGS=$LDFLAGS~" \
++ -e "s~^CC[ :]*=.*~CC=$CC~" \
++ -i Makefile
++ else
+ # backup default GCC Makefile and create a link to other
+ if [ -f Makefile ]; then
+ mv Makefile Makefile.gcc
+@@ -47,8 +53,7 @@
+
+ EXT=`echo "$CC" | sed 's/_.*//'`
+ ln -s Makefile.$EXT Makefile
+- ;;
+- esac
++ fi
+ fi
+
+ STAMP=configure-stamp
+@@ -62,7 +67,7 @@
+ for i in $TESTS; do
+ printf "Checking $i... "
+ printf "#define config_$i " >> $CONFIG
+- OUT=`$CC -D_POSIX_C_SOURCE=199506L -D_ISOC99_SOURCE -D_REENTRANT -o config/$i config/$i.c 2>&1`
++ OUT=`$CC $CFLAGS $LDFLAGS -D_POSIX_C_SOURCE=199506L -D_ISOC99_SOURCE -D_REENTRANT -o config/$i config/$i.c 2>&1`
+ rc=$?
+
+ if [ $rc -ne 0 ]; then # -o -n "$OUT" ]; then
+--- Makefile.orig 2012-10-02 15:31:03.986270993 +0200
++++ Makefile 2012-10-02 15:40:10.277689068 +0200
+@@ -16,14 +16,13 @@
+ CC := gcc
+ VER := $(shell cat VERSION)
+ OS := $(shell uname -s)
+-OSLDFLAGS := $(shell [ $(OS) = "SunOS" ] && echo "-lrt -lsocket -lnsl")
+-LDFLAGS := -lpthread $(OSLDFLAGS)
++LIBS := $(shell [ $(OS) = "SunOS" ] && echo "-lrt -lsocket -lnsl")
++LDFLAGS := -pthread
+ CYGWIN_REQS := cygwin1.dll cyggcc_s-1.dll cygstdc++-6.dll cygrunsrv.exe
+
++CFLAGS=-D__BSD_VISIBLE -D_ALL_SOURCE -D_XOPEN_SOURCE=600 -D_POSIX_C_SOURCE=200112 -D_ISOC99_SOURCE -D_REENTRANT -D_BSD_SOURCE -DVERSION=\"'$(VER)'\"
+ ifeq ($(DEBUG),1)
+- CFLAGS += -g -std=c99 -Wall -pedantic -D__BSD_VISIBLE -D_ALL_SOURCE -D_XOPEN_SOURCE=600 -D_POSIX_C_SOURCE=200112 -D_ISOC99_SOURCE -D_REENTRANT -D_BSD_SOURCE -DVERSION=\"'$(VER)'\"
+-else
+- CFLAGS += -O3 -std=c99 -D__BSD_VISIBLE -D_ALL_SOURCE -D_XOPEN_SOURCE=600 -D_POSIX_C_SOURCE=200112 -D_ISOC99_SOURCE -D_REENTRANT -D_BSD_SOURCE -DVERSION=\"'$(VER)'\"
++ CFLAGS += -g -O0
+ endif
+
+ ifneq ($(findstring CYGWIN,$(OS)),)
+@@ -32,28 +31,35 @@
+ OBJS=utils.o ntlm.o xcrypt.o config.o socket.o acl.o auth.o http.o forward.o direct.o scanner.o pages.o main.o
+ endif
+
++VE_=@echo
++VE_1=@:
++VE=$(VE_$(V))
++VV_=@
++VV_1=
++VV=$(VV_$(V))
++
+ $(NAME): configure-stamp $(OBJS)
+- @echo "Linking $@"
+- @$(CC) $(CFLAGS) -o $@ $(OBJS) $(LDFLAGS)
++ $(VE) "Linking $@"
++ $(VV) $(CC) $(CFLAGS) -o $@ $(OBJS) $(LDFLAGS) $(LIBS)
+
+ main.o: main.c
+- @echo "Compiling $<"
+- @if [ -z "$(SYSCONFDIR)" ]; then \
++ $(VE) "Compiling $<"
++ $(VV) if [ -z "$(SYSCONFDIR)" ]; then \
+ $(CC) $(CFLAGS) -c main.c -o $@; \
+ else \
+ $(CC) $(CFLAGS) -DSYSCONFDIR=\"$(SYSCONFDIR)\" -c main.c -o $@; \
+ fi
+
+ %.o: %.c
+- @echo "Compiling $<"
+- @$(CC) $(CFLAGS) -c -o $@ $<
++ $(VE) "Compiling $<"
++ $(VV) $(CC) $(CFLAGS) -c -o $@ $<
+
+ configure-stamp:
+ ./configure
+
+ win/resources.o: win/resources.rc
+- @echo Adding EXE resources
+- @windres $^ -o $@
++ $(VE) Adding EXE resources
++ $(VV) windres $^ -o $@
+
+ install: $(NAME)
+ # Special handling for install(1)
+@@ -115,31 +121,31 @@
+
+ $(NAME)-$(VER)-win32.exe:
+ @echo - preparing binaries for GUI installer
+- @cp $(patsubst %, /bin/%, $(CYGWIN_REQS)) win/
++ $(VV) cp $(patsubst %, /bin/%, $(CYGWIN_REQS)) win/
+ ifeq ($(DEBUG),1)
+- @cp -p cntlm.exe win/
++ $(VV) cp -p cntlm.exe win/
+ else
+- @strip -o win/cntlm.exe cntlm.exe
++ $(VV) strip -o win/cntlm.exe cntlm.exe
+ endif
+ @echo - generating GUI installer
+- @win/Inno5/ISCC.exe /Q win/setup.iss #/Q win/setup.iss
++ $(VV) win/Inno5/ISCC.exe /Q win/setup.iss #/Q win/setup.iss
+
+ $(NAME)-$(VER)-win32.zip:
+ @echo - creating ZIP release for manual installs
+- @ln -s win $(NAME)-$(VER)
++ $(VV) ln -s win $(NAME)-$(VER)
+ zip -9 $(NAME)-$(VER)-win32.zip $(patsubst %, $(NAME)-$(VER)/%, $(CYGWIN_REQS) cntlm.ini LICENSE.txt cntlm_manual.pdf)
+- @rm -f $(NAME)-$(VER)
++ $(VV) rm -f $(NAME)-$(VER)
+
+ win/cntlm.ini: doc/cntlm.conf
+- @cat doc/cntlm.conf | unix2dos > win/cntlm.ini
++ $(VV) cat doc/cntlm.conf | unix2dos > win/cntlm.ini
+
+ win/LICENSE.txt: COPYRIGHT LICENSE
+- @cat COPYRIGHT LICENSE | unix2dos > win/LICENSE.txt
++ $(VV) cat COPYRIGHT LICENSE | unix2dos > win/LICENSE.txt
+
+ win/cntlm_manual.pdf: doc/cntlm.1
+ @echo - generating PDF manual
+- @rm -f win/cntlm_manual.pdf
+- @groff -t -e -mandoc -Tps doc/cntlm.1 | ps2pdf - win/cntlm_manual.pdf
++ $(VV) rm -f win/cntlm_manual.pdf
++ $(VV) groff -t -e -mandoc -Tps doc/cntlm.1 | ps2pdf - win/cntlm_manual.pdf
+
+ win/setup.iss: win/setup.iss.in
+ ifeq ($(findstring CYGWIN,$(OS)),)
+@@ -148,16 +154,16 @@
+ @echo
+ @exit 1
+ endif
+- @sed "s/\$$VERSION/$(VER)/g" $^ > $@
++ $(VV) sed "s/\$$VERSION/$(VER)/g" $^ > $@
+
+ uninstall:
+ rm -f $(BINDIR)/$(NAME) $(MANDIR)/man1/$(NAME).1 2>/dev/null || true
+
+ clean:
+- @rm -f config/endian config/gethostname config/strdup config/socklen_t config/*.exe
+- @rm -f *.o cntlm cntlm.exe configure-stamp build-stamp config/config.h
++ $(VV) rm -f config/endian config/gethostname config/strdup config/socklen_t config/*.exe
++ $(VV) rm -f *.o cntlm cntlm.exe configure-stamp build-stamp config/config.h
+ rm -f $(patsubst %, win/%, $(CYGWIN_REQS) cntlm.exe cntlm.ini LICENSE.txt setup.iss cntlm_manual.pdf)
+- @if [ -h Makefile ]; then rm -f Makefile; mv Makefile.gcc Makefile; fi
++ $(VV) if [ -h Makefile ]; then rm -f Makefile; mv Makefile.gcc Makefile; fi
+
+ distclean: clean
+ ifeq ($(findstring CYGWIN,$(OS)),)
+@@ -169,6 +175,6 @@
+ fakeroot rpm/rules clean; \
+ fi
+ endif
+- @rm -f *.exe *.deb *.rpm *.tgz *.tar.gz *.tar.bz2 *.zip *.exe tags ctags pid 2>/dev/null
++ $(VV) rm -f *.exe *.deb *.rpm *.tgz *.tar.gz *.tar.bz2 *.zip *.exe tags ctags pid 2>/dev/null
+
+ .PHONY: all install tgz tbz2 deb rpm win uninstall clean distclean
diff --git a/net-proxy/cntlm/files/cntlm.confd b/net-proxy/cntlm/files/cntlm.confd
new file mode 100644
index 000000000000..bc3dce0fb18c
--- /dev/null
+++ b/net-proxy/cntlm/files/cntlm.confd
@@ -0,0 +1,5 @@
+# cntlm init script configuration file
+
+# here you can specify additional options to cntlm
+# NOTE that using config file is recommended
+CNTLM_OPTS=""
diff --git a/net-proxy/cntlm/files/cntlm.initd b/net-proxy/cntlm/files/cntlm.initd
new file mode 100644
index 000000000000..daa19e32313a
--- /dev/null
+++ b/net-proxy/cntlm/files/cntlm.initd
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+PIDFILE=${PIDFILE:-/var/run/cntlm.pid}
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting cntlm"
+ start-stop-daemon --start --background --make-pidfile --pidfile ${PIDFILE} --exec /usr/bin/cntlm -- -f -U cntlm ${CNTLM_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping cntlm"
+ start-stop-daemon --stop --pidfile ${PIDFILE}
+ eend $?
+}
diff --git a/net-proxy/cntlm/files/cntlm.service b/net-proxy/cntlm/files/cntlm.service
new file mode 100644
index 000000000000..01f2bcdfd803
--- /dev/null
+++ b/net-proxy/cntlm/files/cntlm.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=CNTLM HTTP Accelerator For NTLM Secured Proxies Authenticator
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/cntlm -f -U cntlm -c /etc/cntlm.conf
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-proxy/cntlm/metadata.xml b/net-proxy/cntlm/metadata.xml
new file mode 100644
index 000000000000..ff08a45e3a0f
--- /dev/null
+++ b/net-proxy/cntlm/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ NTLM authorizing proxy. Upstream seems dead, but this is still a good
+ alternative to ntlmaps.
+ </longdescription>
+</pkgmetadata>
+