summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-12-09 23:37:12 +0100
committerJeroen Roovers <jer@gentoo.org>2018-12-09 23:43:51 +0100
commita538c2bc0cfd392c7b29a9691cd1c18bffdb5cb3 (patch)
tree7b10a8d34a5b0bd4509b9140dad321cd9048df3a /net-proxy/dnsproxy
parentx11-misc/obmenu-generator: Version 0.85 (diff)
downloadgentoo-a538c2bc0cfd392c7b29a9691cd1c18bffdb5cb3.tar.gz
gentoo-a538c2bc0cfd392c7b29a9691cd1c18bffdb5cb3.tar.bz2
gentoo-a538c2bc0cfd392c7b29a9691cd1c18bffdb5cb3.zip
net-proxy/dnsproxy: Clean up patch
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-proxy/dnsproxy')
-rw-r--r--net-proxy/dnsproxy/dnsproxy-1.16-r2.ebuild25
-rw-r--r--net-proxy/dnsproxy/files/dnsproxy-1.16-include.patch4
2 files changed, 14 insertions, 15 deletions
diff --git a/net-proxy/dnsproxy/dnsproxy-1.16-r2.ebuild b/net-proxy/dnsproxy/dnsproxy-1.16-r2.ebuild
index 05f68e06d9f6..57ab8dd9b981 100644
--- a/net-proxy/dnsproxy/dnsproxy-1.16-r2.ebuild
+++ b/net-proxy/dnsproxy/dnsproxy-1.16-r2.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-
-inherit eutils flag-o-matic
+inherit flag-o-matic
DESCRIPTION="The dnsproxy daemon is a proxy for DNS queries"
HOMEPAGE="https://www.wolfermann.org/dnsproxy.html"
@@ -12,19 +11,19 @@ SRC_URI="https://www.wolfermann.org/${P}.tar.gz"
LICENSE="MIT GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND="dev-libs/libevent"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- eapply -p0 "${FILESDIR}"/${P}-include.patch
- append-cppflags -D_GNU_SOURCE
- default
-}
+DEPEND="
+ dev-libs/libevent
+"
+RDEPEND="
+ ${DEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.16-include.patch
+)
src_compile() {
+ append-cppflags -D_GNU_SOURCE
emake ${PN}
}
diff --git a/net-proxy/dnsproxy/files/dnsproxy-1.16-include.patch b/net-proxy/dnsproxy/files/dnsproxy-1.16-include.patch
index 96296f5ed2d8..81cbcce51839 100644
--- a/net-proxy/dnsproxy/files/dnsproxy-1.16-include.patch
+++ b/net-proxy/dnsproxy/files/dnsproxy-1.16-include.patch
@@ -1,5 +1,5 @@
---- dnsproxy.c.orig 2010-01-11 16:02:00.000000000 +0100
-+++ dnsproxy.c 2010-10-27 05:07:05.000000000 +0200
+--- a/dnsproxy.c
++++ b/dnsproxy.c
@@ -28,6 +28,7 @@
#include <stdio.h>
#include <stdlib.h>