summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-05-03 13:59:58 -0500
committerAustin English <wizardedit@gentoo.org>2016-05-03 14:17:01 -0500
commit4efd4972ad12c1131f32563f35abcff21c74c5ea (patch)
treeff3d74bb1d0a2a05271a8aaec25a4333b15aaf62 /net-proxy/havp
parentnet-proxy/havp: use #!/sbin/openrc-run instead of #!/sbin/runscript (diff)
downloadgentoo-4efd4972ad12c1131f32563f35abcff21c74c5ea.tar.gz
gentoo-4efd4972ad12c1131f32563f35abcff21c74c5ea.tar.bz2
gentoo-4efd4972ad12c1131f32563f35abcff21c74c5ea.zip
net-proxy/havp: remove old version
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-proxy/havp')
-rw-r--r--net-proxy/havp/havp-0.92a-r1.ebuild74
1 files changed, 0 insertions, 74 deletions
diff --git a/net-proxy/havp/havp-0.92a-r1.ebuild b/net-proxy/havp/havp-0.92a-r1.ebuild
deleted file mode 100644
index 8f5a0177c05b..000000000000
--- a/net-proxy/havp/havp-0.92a-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit autotools eutils toolchain-funcs user
-
-DESCRIPTION="HTTP AntiVirus Proxy"
-HOMEPAGE="http://www.server-side.de/"
-SRC_URI="http://www.server-side.de/download/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="clamav ssl"
-
-DEPEND="clamav? ( >=app-antivirus/clamav-0.98.5 )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- enewgroup ${PN}
- enewuser ${PN} -1 -1 /etc/${PN} ${PN}
-}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-0.92a-run.patch \
- "${FILESDIR}"/${PF}-pkg-config-libclamav.patch
- sed -i configure.in -e '/^CFLAGS=/d' || die
- mv configure.{in,ac} || die
- eautoreconf
-}
-
-src_configure() {
- tc-export AR
- export CFLAGS="${CXXFLAGS}"
- econf \
- $(use_enable clamav) \
- $(use_enable ssl ssl-tunnel) \
- --localstatedir=/var
-}
-
-src_install() {
- dosbin ${PN}/${PN}
-
- newinitd "${FILESDIR}/${PN}.initd" ${PN}
-
- insinto /etc
- rm -r etc/${PN}/${PN}.config.in
- doins -r etc/${PN}
-
- dodoc ChangeLog
-}
-
-pkg_postinst() {
- ewarn "/var/tmp/${PN} must be on a filesystem with mandatory locks!"
- ewarn "You should add \"mand\" to the mount options on the relevant line in /etc/fstab."
-
- if use ssl; then
- echo
- ewarn "Note: ssl USE flag only enable SSL pass-through, which means that"
- ewarn " HTTPS pages will not be scanned for viruses!"
- ewarn " It is impossible to decrypt data sent through SSL connections without knowing"
- ewarn " the private key of the used certificate."
- fi
-
- if use clamav; then
- echo
- ewarn "If you plan to use clamav daemon, you should make sure clamav user can read"
- ewarn "/var/tmp/${PN} content. This can be accomplished by enabling AllowSupplementaryGroups"
- ewarn "in /etc/clamd.conf and adding clamav user to the ${PN} group."
- fi
-}