summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-proxy/httpush
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-proxy/httpush')
-rw-r--r--net-proxy/httpush/Manifest1
-rw-r--r--net-proxy/httpush/httpush-0.9_beta11-r1.ebuild61
-rw-r--r--net-proxy/httpush/metadata.xml11
3 files changed, 73 insertions, 0 deletions
diff --git a/net-proxy/httpush/Manifest b/net-proxy/httpush/Manifest
new file mode 100644
index 000000000000..585d8444c6d0
--- /dev/null
+++ b/net-proxy/httpush/Manifest
@@ -0,0 +1 @@
+DIST httpush-0.9b11.tar.gz 39342 SHA256 f6c3a3bce0957557d744c27d1bf33dca33a09dede80842ee70fdbbfc42e608a8
diff --git a/net-proxy/httpush/httpush-0.9_beta11-r1.ebuild b/net-proxy/httpush/httpush-0.9_beta11-r1.ebuild
new file mode 100644
index 000000000000..112a5dade9ff
--- /dev/null
+++ b/net-proxy/httpush/httpush-0.9_beta11-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+MY_P="${P/_beta/b}"
+
+DESCRIPTION="Httpush is an intercepting proxy, allowing user to modify HTTP requests on-the-fly"
+HOMEPAGE="http://httpush.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="xml"
+
+RDEPEND="dev-perl/URI
+ virtual/perl-MIME-Base64
+ dev-perl/libwww-perl
+ dev-perl/Net-SSLeay
+ dev-perl/Crypt-SSLeay
+ dev-perl/HTML-Parser
+ xml? ( dev-perl/XML-Twig )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if ! use xml ; then
+ echo
+ einfo "If you'd like to use httpush's learning mode, please CTRL-C now"
+ einfo "and enable the xml USE flag."
+ epause 3
+ echo
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i 's:^\(require httpush;\)$:push @INC, "/usr/lib/httpush";\n\1:' \
+ httpush.pl || die "sed INC failed"
+ sed -i 's:^\(.*DATADIR="\)data\(.*\)$:\1/var/lib/httpush\2:' *.pl \
+ lib/plugin/broker.pm || die "sed DATADIR= failed"
+}
+
+src_install() {
+ keepdir /var/lib/httpush
+
+ insinto /usr/lib/httpush
+ doins -r httpush.{dtd,lck,pem,pm} lib
+
+ insinto /usr/share/httpush/plugins
+ doins plugins/*
+
+ newbin httpush.pl httpush
+ newbin reindex.pl httpush-reindex
+ ewarn "reindex script has been renamed httpush-reindex"
+
+ dodoc README ChangeLog doc/*
+}
diff --git a/net-proxy/httpush/metadata.xml b/net-proxy/httpush/metadata.xml
new file mode 100644
index 000000000000..af81e3a61e05
--- /dev/null
+++ b/net-proxy/httpush/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>HTTPush aims at providing an easy way to audit HTTP and HTTPS application/server security. It supports on-the-fly request modification, automated decision making and vulnerability detection through the use of plugins.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">httpush</remote-id>
+ </upstream>
+</pkgmetadata>