summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-proxy/mitmproxy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-proxy/mitmproxy')
-rw-r--r--net-proxy/mitmproxy/Manifest3
-rw-r--r--net-proxy/mitmproxy/files/mitmproxy-0.10-jsbeautifier-imports.patch44
-rw-r--r--net-proxy/mitmproxy/metadata.xml11
-rw-r--r--net-proxy/mitmproxy/mitmproxy-0.10.1.ebuild52
-rw-r--r--net-proxy/mitmproxy/mitmproxy-0.11.1.ebuild56
-rw-r--r--net-proxy/mitmproxy/mitmproxy-0.11.3.ebuild55
6 files changed, 221 insertions, 0 deletions
diff --git a/net-proxy/mitmproxy/Manifest b/net-proxy/mitmproxy/Manifest
new file mode 100644
index 000000000000..19fccf291ad6
--- /dev/null
+++ b/net-proxy/mitmproxy/Manifest
@@ -0,0 +1,3 @@
+DIST mitmproxy-0.10.1.tar.gz 3426109 SHA256 527cbff76e0d49d7db62561252d399e1c747730676515c4ed89250c223e2fe56 SHA512 2bef02f07942177044afa24749c4e8e2ba1aae5ee33e2cbffbecc557a09351865b70dc92b9acfd285716a82c84026a3eb93f889176fd288c1e8d67a415a5c79a WHIRLPOOL 73391bf717df855016db3158e4e38126f4b5e29a28566202843b3cf15412e9b1f281ad062d86f50965dfeab344488a11e2f8ba11a3181c1da56998a297b262d0
+DIST mitmproxy-0.11.1.tar.gz 6253324 SHA256 0d2de6210b5eee3f196943d9e6e137a27bf32bdc0213620bde54bfd5d384e53d SHA512 f265441825b22e2a7ec3c8f2f3152d123fbd6ac463fd4de0e973e24b2ab9feaf28689d3c995bb361ff06a88a6d88536b642944463573117640b1c096b79f20b1 WHIRLPOOL a32f44fa9a2392d08b9bb9c4fb701e3b6e351b4d820bb35b0fd27a8d3281e2982a2b88f1216cf8eedf3a3c0a14ad38406c9d80ee23b146706be8f98c27d197f1
+DIST mitmproxy-0.11.3.tar.gz 6172130 SHA256 e774760fc33864caa708eeaafb756e110d7adeb619f3734f2f50b2a0e4910d5c SHA512 81184b3034b78d51368b4066adcc8337fc59332c80ce085c854610f70cd96531612520c1b751135e26093265c5475c8fef5fcb0908b77b5a18a5c605c0c94934 WHIRLPOOL d0867387fe2188599d68e48a8db691b508748e9dc4704998af0bb062be3d5cd242445d220b07e8fb75cc4f26cebd87d6afffa7f5abe6f80607bae3f7ce93cb22
diff --git a/net-proxy/mitmproxy/files/mitmproxy-0.10-jsbeautifier-imports.patch b/net-proxy/mitmproxy/files/mitmproxy-0.10-jsbeautifier-imports.patch
new file mode 100644
index 000000000000..bd6f65aa920e
--- /dev/null
+++ b/net-proxy/mitmproxy/files/mitmproxy-0.10-jsbeautifier-imports.patch
@@ -0,0 +1,44 @@
+--- mitmproxy-0.10/libmproxy/contrib/jsbeautifier/__init__.py
++++ mitmproxy-0.10/libmproxy/contrib/jsbeautifier/__init__.py
+@@ -246,7 +246,7 @@
+ return sweet_code
+
+ def unpack(self, source, evalcode=False):
+- import jsbeautifier.unpackers as unpackers
++ from ..jsbeautifier import unpackers
+ try:
+ return unpackers.run(source, evalcode)
+ except unpackers.UnpackingError as error:
+--- mitmproxy-0.10/libmproxy/contrib/jsbeautifier/unpackers/__init__.py
++++ mitmproxy-0.10/libmproxy/contrib/jsbeautifier/unpackers/__init__.py
+@@ -7,7 +7,7 @@
+
+ import pkgutil
+ import re
+-from jsbeautifier.unpackers import evalbased
++from ...jsbeautifier.unpackers import evalbased
+
+ # NOTE: AT THE MOMENT, IT IS DEACTIVATED FOR YOUR SECURITY: it runs js!
+ BLACKLIST = ['jsbeautifier.unpackers.evalbased']
+--- mitmproxy-0.10/libmproxy/contrib/jsbeautifier/unpackers/myobfuscate.py
++++ mitmproxy-0.10/libmproxy/contrib/jsbeautifier/unpackers/myobfuscate.py
+@@ -40,7 +40,7 @@
+ except ImportError:
+ from urllib.parse import unquote
+
+-from jsbeautifier.unpackers import UnpackingError
++from ...jsbeautifier.unpackers import UnpackingError
+
+ PRIORITY = 1
+
+--- mitmproxy-0.10/libmproxy/contrib/jsbeautifier/unpackers/packer.py
++++ mitmproxy-0.10/libmproxy/contrib/jsbeautifier/unpackers/packer.py
+@@ -14,7 +14,7 @@
+
+ import re
+ import string
+-from jsbeautifier.unpackers import UnpackingError
++from ...jsbeautifier.unpackers import UnpackingError
+
+ PRIORITY = 1
+
diff --git a/net-proxy/mitmproxy/metadata.xml b/net-proxy/mitmproxy/metadata.xml
new file mode 100644
index 000000000000..3c1903962e95
--- /dev/null
+++ b/net-proxy/mitmproxy/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">mitmproxy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-proxy/mitmproxy/mitmproxy-0.10.1.ebuild b/net-proxy/mitmproxy/mitmproxy-0.10.1.ebuild
new file mode 100644
index 000000000000..d401aa159ebd
--- /dev/null
+++ b/net-proxy/mitmproxy/mitmproxy-0.10.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="An interactive, SSL-capable, man-in-the-middle HTTP proxy"
+HOMEPAGE="http://mitmproxy.org/"
+SRC_URI="http://mitmproxy.org/download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/pillow-2.3.0[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ >=dev-python/lxml-2.3[${PYTHON_USEDEP}]
+ =dev-python/netlib-$(get_version_component_range 1-2)*[${PYTHON_USEDEP}]
+ >dev-python/pyasn1-0.1.2[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+ >=dev-python/urwid-1.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
+ =www-servers/pathod-$(get_version_component_range 1-2)*[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.10-jsbeautifier-imports.patch )
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # remove unwanted bytecode files
+ rm -r libmproxy/protocol || die
+}
+
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGELOG CONTRIBUTORS )
+ use doc && local HTML_DOCS=( doc/. )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/net-proxy/mitmproxy/mitmproxy-0.11.1.ebuild b/net-proxy/mitmproxy/mitmproxy-0.11.1.ebuild
new file mode 100644
index 000000000000..b5c48f995118
--- /dev/null
+++ b/net-proxy/mitmproxy/mitmproxy-0.11.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="An interactive, SSL-capable, man-in-the-middle HTTP proxy"
+HOMEPAGE="http://mitmproxy.org/"
+SRC_URI="http://mitmproxy.org/download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/pillow-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.3.6[${PYTHON_USEDEP}]
+ =dev-python/netlib-$(get_version_component_range 1-2)*[${PYTHON_USEDEP}]
+ >dev-python/pyasn1-0.1.2[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.0.2[${PYTHON_USEDEP}]
+ >=dev-python/urwid-1.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
+ =www-servers/pathod-$(get_version_component_range 1-2)*[${PYTHON_USEDEP}]
+ )"
+
+#PATCHES=( "${FILESDIR}"/${PN}-0.10-jsbeautifier-imports.patch )
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # remove bundled netlib and pathod
+ rm -r libpathod netlib || die
+
+ # remove unused dep
+ sed -i '/sortedcontainers/d' setup.py || die
+}
+
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGELOG CONTRIBUTORS )
+ use doc && local HTML_DOCS=( doc/. )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/net-proxy/mitmproxy/mitmproxy-0.11.3.ebuild b/net-proxy/mitmproxy/mitmproxy-0.11.3.ebuild
new file mode 100644
index 000000000000..826a6f23913b
--- /dev/null
+++ b/net-proxy/mitmproxy/mitmproxy-0.11.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="An interactive, SSL-capable, man-in-the-middle HTTP proxy"
+HOMEPAGE="http://mitmproxy.org/"
+SRC_URI="http://mitmproxy.org/download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="
+ >=dev-python/pillow-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.3.6[${PYTHON_USEDEP}]
+ =dev-python/netlib-$(get_version_component_range 1-2)*[${PYTHON_USEDEP}]
+ >dev-python/pyasn1-0.1.2[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.0.2[${PYTHON_USEDEP}]
+ >=dev-python/urwid-1.1[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
+ =www-servers/pathod-$(get_version_component_range 1-2)*[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # don't run example scripts tests
+ rm test/test_examples.py || die
+
+}
+
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGELOG CONTRIBUTORS )
+ use doc && local HTML_DOCS=( doc/. )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}