summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-08-02 22:49:07 +0000
committerSam James <sam@gentoo.org>2020-08-02 22:49:26 +0000
commitc867d5836c411c0117c5a5263f736bdad1e1f0a3 (patch)
tree2bc011615e2dbf6f0f0e0c1bb4192937fbfef181 /net-proxy/sshuttle
parentpackage.mask: last-rite app-metrics/collectd sys-fs/owfs (diff)
downloadgentoo-c867d5836c411c0117c5a5263f736bdad1e1f0a3.tar.gz
gentoo-c867d5836c411c0117c5a5263f736bdad1e1f0a3.tar.bz2
gentoo-c867d5836c411c0117c5a5263f736bdad1e1f0a3.zip
net-proxy/sshuttle: bump to 1.0.3
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-proxy/sshuttle')
-rw-r--r--net-proxy/sshuttle/Manifest1
-rw-r--r--net-proxy/sshuttle/sshuttle-1.0.3.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-proxy/sshuttle/Manifest b/net-proxy/sshuttle/Manifest
index 10a76828e3ff..8290f7a320cc 100644
--- a/net-proxy/sshuttle/Manifest
+++ b/net-proxy/sshuttle/Manifest
@@ -1 +1,2 @@
DIST sshuttle-0.78.5.tar.gz 74663 BLAKE2B 47e295219c1ada7bee4f0340cc169620c5b91abd1f72b933289ef2dea0c5ba088673f2d1348d444f662e9f6c2638ee6dfd3e8df1fa8344bc7c48adf1a3a96d3f SHA512 562acbf0e825ad41458c5b6065592a45b8bac92cd64b20619027fe4d0bec60a22c5191c7a7ed6b216d8cf5c9e027f58a6cdca69dd3a11ec6f6d348ef2f13bb38
+DIST sshuttle-1.0.3.tar.gz 79216 BLAKE2B fefc93654c4991bad54de6b156916ee656f7d460d609c5333b15c601e9b2b0169c1670e911988dfa8290a5bc1885d94f9ec9656066d2b13da0b4d53d9739297a SHA512 22132dba0e6b7dd835f0af1368a5e8c3a95db66e11ffec9ec3cae72cc7ed4eec13580eeceb08071bee12cae8169852772578f8e29a69583cb79c71d350f474bb
diff --git a/net-proxy/sshuttle/sshuttle-1.0.3.ebuild b/net-proxy/sshuttle/sshuttle-1.0.3.ebuild
new file mode 100644
index 000000000000..5ef1619ca36f
--- /dev/null
+++ b/net-proxy/sshuttle/sshuttle-1.0.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1 linux-info
+
+DESCRIPTION="Transparent proxy server that works as a poor man's VPN using ssh"
+HOMEPAGE="https://github.com/sshuttle/sshuttle https://pypi.org/project/sshuttle/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-python/sphinx
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="|| ( net-firewall/iptables net-firewall/nftables )"
+
+CONFIG_CHECK="~NETFILTER_XT_TARGET_HL ~IP_NF_TARGET_REDIRECT ~IP_NF_MATCH_TTL ~NF_NAT"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't run tests via setup.py pytest
+ sed -i "/setup_requires=/s/'pytest-runner'//" setup.py || die
+
+ # don't require pytest-cov when running tests
+ sed -i "s/^addopts =/#\0/" setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ emake -j1 -C docs html man
+}
+
+python_install_all() {
+ HTML_DOCS=( docs/_build/html/. )
+ doman docs/_build/man/*
+ distutils-r1_python_install_all
+}