summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Efros <powerman-asdf@yandex.ru>2019-03-02 22:45:09 +0200
committerStefan Strogin <steils@gentoo.org>2019-05-28 15:56:51 +0300
commitd75cbc04fc3c8bfa79e6a2d6ef66c27d3a8a650c (patch)
tree773791bf8788ea5c72077d5a5e2501b5e1f4dc30 /net-proxy
parentsys-libs/e2fsprogs-libs: Removed old. (diff)
downloadgentoo-d75cbc04fc3c8bfa79e6a2d6ef66c27d3a8a650c.tar.gz
gentoo-d75cbc04fc3c8bfa79e6a2d6ef66c27d3a8a650c.tar.bz2
gentoo-d75cbc04fc3c8bfa79e6a2d6ef66c27d3a8a650c.zip
net-proxy/3proxy: Version bump to 0.8.12 and EAPI=7
Signed-off-by: Aleksandr Efros <powerman-asdf@yandex.ru> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/11220 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/3proxy/3proxy-0.8.12.ebuild40
-rw-r--r--net-proxy/3proxy/Manifest1
-rw-r--r--net-proxy/3proxy/files/3proxy-0.8.12-gentoo.patch49
3 files changed, 90 insertions, 0 deletions
diff --git a/net-proxy/3proxy/3proxy-0.8.12.ebuild b/net-proxy/3proxy/3proxy-0.8.12.ebuild
new file mode 100644
index 000000000000..3bf12098bc46
--- /dev/null
+++ b/net-proxy/3proxy/3proxy-0.8.12.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A really tiny cross-platform proxy servers set"
+HOMEPAGE="https://www.3proxy.ru/"
+SRC_URI="https://github.com/z3APA3A/3proxy/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~sparc ~x86"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.12-gentoo.patch
+)
+
+DOCS=( README cfg )
+HTML_DOCS=( doc/html/. )
+
+src_prepare() {
+ default
+ cp Makefile.Linux Makefile || die
+}
+
+src_install() {
+ local x
+
+ pushd src >/dev/null || die
+ dobin 3proxy
+ for x in proxy socks ftppr pop3p tcppm udppm mycrypt dighosts icqpr smtpp; do
+ newbin ${x} ${PN}-${x}
+ [[ -f "${S}"/man/${x}.8 ]] && newman "${S}"/man/${x}.8 ${PN}-${x}.8
+ done
+ popd >/dev/null
+
+ doman man/3proxy*.[38]
+
+ einstalldocs
+}
diff --git a/net-proxy/3proxy/Manifest b/net-proxy/3proxy/Manifest
index 120f5c7f4106..3d99915e3f4f 100644
--- a/net-proxy/3proxy/Manifest
+++ b/net-proxy/3proxy/Manifest
@@ -1 +1,2 @@
+DIST 3proxy-0.8.12.tar.gz 528990 BLAKE2B fb338c93e25fe4d03d626118f8c3ef52af7104599e11d535dfa572c4fb47d609da66f199406a3c6bb9739766163bb7b54b529f71d4d6ff637567f2f67d3a9ed1 SHA512 33412e89991055598e06210dbcd7b2f9ee6810753c8f40ada02f222def0a49047a90ff7f2efa6895bc4f8ad99193866c980de2e79464310a77cc8e63c8b9813d
DIST 3proxy-0.8.9.tar.gz 497006 BLAKE2B c57e98eb586dfacefd530e091fecbee274d8104698ca082b71ea0607294199cb7db63fc32787236b7e797c928a7ba4f7bafa3ef35551bef76aacfbdf1f259fff SHA512 35153882fec7077b05b23f9cea91443126a8a9faf9818915612e0739196a8bd1f00e0bcefb339a86bad10bb0c1b9891bd06847934787f4758ec55e6cc2e9e815
diff --git a/net-proxy/3proxy/files/3proxy-0.8.12-gentoo.patch b/net-proxy/3proxy/files/3proxy-0.8.12-gentoo.patch
new file mode 100644
index 000000000000..33950f45ceeb
--- /dev/null
+++ b/net-proxy/3proxy/files/3proxy-0.8.12-gentoo.patch
@@ -0,0 +1,49 @@
+diff -uNr a/Makefile.Linux b/Makefile.Linux
+--- a/Makefile.Linux 2018-04-18 22:48:45.000000000 +0300
++++ b/Makefile.Linux 2019-05-26 14:42:38.927811513 +0300
+@@ -8,13 +8,13 @@
+ # library support. Add -DSAFESQL for poorely written ODBC library / drivers.
+
+ BUILDDIR =
+-CC = gcc
++CC ?= gcc
+
+-CFLAGS = -g -O2 -fno-strict-aliasing -c -pthread -DGETHOSTBYNAME_R -D_THREAD_SAFE -D_REENTRANT -DNOODBC -DWITH_STD_MALLOC -DFD_SETSIZE=4096 -DWITH_POLL
++CFLAGS += -fno-strict-aliasing -c -pthread -DGETHOSTBYNAME_R -D_THREAD_SAFE -D_REENTRANT -DNOODBC -DWITH_STD_MALLOC -DFD_SETSIZE=4096 -DWITH_POLL
+ COUT = -o
+-LN = gcc
++LN ?= gcc
+ DCFLAGS = -fpic
+-LDFLAGS = -O2 -fno-strict-aliasing -pthread
++LDFLAGS += -fno-strict-aliasing -pthread
+ DLFLAGS = -shared
+ DLSUFFICS = .ld.so
+ # -lpthreads may be reuqired on some platforms instead of -pthreads
+@@ -39,12 +39,12 @@
+ include Makefile.inc
+
+ allplugins:
+- @list='$(PLUGINS)'; for p in $$list; do cp Makefile Makefile.var plugins/$$p; cd plugins/$$p ; make ; cd ../.. ; done
++ @list='$(PLUGINS)'; for p in $$list; do cp Makefile Makefile.var plugins/$$p; cd plugins/$$p ; $(MAKE) ; cd ../.. ; done
+
+ DESTDIR =
+-prefix = /usr/local
++prefix =
+ exec_prefix = $(prefix)
+-man_prefix = $(prefix)/share
++man_prefix = $(prefix)/usr/share
+
+ INSTALL = /usr/bin/install
+ INSTALL_BIN = $(INSTALL) -m 755
+diff -uNr a/src/stringtable.c b/src/stringtable.c
+--- a/src/stringtable.c 2018-04-18 22:48:45.000000000 +0300
++++ b/src/stringtable.c 2019-05-26 14:42:07.437810566 +0300
+@@ -38,7 +38,7 @@
+ /* 24 */ NULL,
+ #ifndef TPROXY_CONF
+ #ifndef _WIN32
+-/* 25 */ (unsigned char *)"/usr/local/etc/3proxy/3proxy.cfg",
++/* 25 */ (unsigned char *)"/etc/3proxy/3proxy.cfg",
+ #else
+ /* 25 */ (unsigned char *)"3proxy.cfg",
+ #endif