summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2018-02-10 16:22:38 -0500
committerChris Reffett <creffett@gentoo.org>2018-02-10 16:25:37 -0500
commitc4e19115458f5b8f8d1294c02d5dcdb3c2ab7049 (patch)
treef8c37e125be58b1142abea05dbac38a403cb5619 /net-voip/yate/yate-9999.ebuild
parentdev-libs/m17n-lib: stable 1.6.4 for hppa, bug #610450 (diff)
downloadgentoo-c4e19115458f5b8f8d1294c02d5dcdb3c2ab7049.tar.gz
gentoo-c4e19115458f5b8f8d1294c02d5dcdb3c2ab7049.tar.bz2
gentoo-c4e19115458f5b8f8d1294c02d5dcdb3c2ab7049.zip
net-voip/yate: Bump, remove qt4, cleanup.
Bug: https://bugs.gentoo.org/642544 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-voip/yate/yate-9999.ebuild')
-rw-r--r--net-voip/yate/yate-9999.ebuild29
1 files changed, 15 insertions, 14 deletions
diff --git a/net-voip/yate/yate-9999.ebuild b/net-voip/yate/yate-9999.ebuild
index 3cd9af1e385b..adfc9f09121a 100644
--- a/net-voip/yate/yate-9999.ebuild
+++ b/net-voip/yate/yate-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit autotools eutils
+inherit autotools
DESCRIPTION="The Yate AV Suite"
HOMEPAGE="http://yate.null.ro/"
@@ -13,33 +13,34 @@ if [[ ${PV} == 9999 ]] ; then
inherit subversion
KEYWORDS=""
else
- SRC_URI="http://voip.null.ro/tarballs/${PN}5/${P}-1.tar.gz"
+ SRC_URI="http://voip.null.ro/tarballs/${PN}6/${P}-1.tar.gz"
KEYWORDS="~amd64 ~arm ~x86"
S="${WORKDIR}/${PN}"
fi
LICENSE="GPL-2"
SLOT="0/${PV}"
-IUSE="doc cpu_flags_x86_sse2 sctp dahdi zaptel wpcard tdmcard wanpipe +ilbc +ilbc-webrtc +isac-float isac-fixed postgres mysql +gsm +speex h323 spandsp +ssl qt4 +zlib amrnb"
+IUSE="doc cpu_flags_x86_sse2 sctp dahdi zaptel wpcard tdmcard wanpipe +ilbc +ilbc-webrtc +isac-float isac-fixed postgres mysql +gsm +speex spandsp +ssl +zlib amrnb"
RDEPEND="
- postgres? ( dev-db/postgresql )
+ postgres? ( dev-db/postgresql:* )
mysql? ( virtual/mysql )
gsm? ( media-sound/gsm )
speex? ( media-libs/speex )
- ssl? ( dev-libs/openssl )
- h323? ( net-libs/h323plus )
+ ssl? ( dev-libs/openssl:0 )
zlib? ( sys-libs/zlib )
- qt4? ( dev-qt/qtgui:4 dev-qt/designer:4 )
ilbc? ( dev-libs/ilbc-rfc3951 )
spandsp? ( >=media-libs/spandsp-0.0.3 )
dahdi? ( net-misc/dahdi )
"
-DEPEND="doc? ( || ( app-doc/doxygen dev-util/kdoc ) )
+DEPEND="doc? ( app-doc/doxygen )
virtual/pkgconfig
${RDEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-dont-mess-with-cflags.patch )
+
src_prepare() {
+ default_src_prepare
eautoreconf
./yate-config.sh || die
}
@@ -53,6 +54,7 @@ src_prepare() {
src_configure() {
econf \
--with-archlib=$(get_libdir) \
+ --without-libqt4
$(use_enable cpu_flags_x86_sse2 sse2) \
$(use_enable sctp) \
$(use_enable dahdi) \
@@ -70,10 +72,7 @@ src_configure() {
$(use_with speex libspeex) \
$(use_with amrnb) \
$(use_with spandsp) \
- $(use_with h323 openh323 /usr) \
- $(use_with h323 pwlib /usr) \
- $(use_with ssl openssl) \
- $(use_with qt4 libqt4)
+ $(use_with ssl openssl)
}
src_compile() {
@@ -86,4 +85,6 @@ src_install() {
else
emake DESTDIR="${ED}" install-noapi
fi
+ newinitd "${FILESDIR}"/yate.initd yate
+ newconfd "${FILESDIR}"/yate.confd yate
}