summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2019-03-08 10:43:12 +0800
committerYixun Lan <dlan@gentoo.org>2019-03-08 11:31:23 +0800
commit05608a3ec85f66190a172e0dd126ff3cd91cff3d (patch)
tree3f7c6b3318252b852d12366926028214bd87a309 /net-vpn
parentsys-cluster/galera: amd64 stable wrt bug #672438 (diff)
downloadgentoo-05608a3ec85f66190a172e0dd126ff3cd91cff3d.tar.gz
gentoo-05608a3ec85f66190a172e0dd126ff3cd91cff3d.tar.bz2
gentoo-05608a3ec85f66190a172e0dd126ff3cd91cff3d.zip
net-vpn/tinc: version bump 1.1pre17
fix build err when >=dev-libs/openssl-1.1.1b also fix a bash_completion issue due to upstream packaging problem, I hope it will be fixed in upstream's next release. Closes: https://bugs.gentoo.org/679402 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/tinc/Manifest2
-rw-r--r--net-vpn/tinc/tinc-1.1_pre17.ebuild96
2 files changed, 98 insertions, 0 deletions
diff --git a/net-vpn/tinc/Manifest b/net-vpn/tinc/Manifest
index 4bef180b36b..a1316b926cf 100644
--- a/net-vpn/tinc/Manifest
+++ b/net-vpn/tinc/Manifest
@@ -1,2 +1,4 @@
DIST tinc-1.0.35.tar.gz 499277 BLAKE2B 419b581167614d534b6f2f3b804657f088c013529d7738766aff199da775860ffed42ecb61e8ed008c5b6fa410f071e2fe1ca59f0c6e443c0a8017cd10c31ce3 SHA512 037867306c21506d57d69d35c0f246b2936022047978fa3e01464b5f6b65f109760507d9cc740f82f8166f39c5ce44d9f8dde55655a6372dacd5b5974aeaee32
+DIST tinc-1.1-upstream-patches-2.tar.xz 23500 BLAKE2B ab44d2efcd494c6a49e9e0bc109670a586b087d5ce1daab9b9cdf8f50a4c9b9d927e102fe947e75e6f7be509ba9315936315006b557b39639399bc7f40109f5f SHA512 351537f212421e7fe28fcf97293550edaa4c4c8a578bf4eeca34ae591caefb222df4d5d96bfa03bddd6afcb5143e68b59f5341b2a6412c053a3cecf4fdd0bee8
DIST tinc-1.1pre16.tar.gz 703679 BLAKE2B c02636f52983c1fdebe28058a5e49f3952ac10b238c9d8f01a10b140960803f197a057c883860ca259b949883c406cf74f518d0e45bf84f10566a964570daf9b SHA512 b32a0a734a4c8a91bad4cef4177cb45757c97c09dc179da1e3357f2fde48b3b0747587dbac31ecb5400e1553b6712d474a6a1808ac24bce1a3494c1842bb6c43
+DIST tinc-1.1pre17.tar.gz 927313 BLAKE2B d16789b64f6d11deda4752fdeeb603fe62efd6b1d68b0286fbe9c329d8ea51494df59e0e5bf1564b25a0ed44e9244799eb61f73de9ded6a1a418417453adddc4 SHA512 b966dbfa522e12ff6766c4deb54a9da29cddc15c3a1df0f0e084df27ee5f1421ffbebc0e29472b1bcd79ea8b41f8c0ef904172e333dcba0b85bafe4654a63b30
diff --git a/net-vpn/tinc/tinc-1.1_pre17.ebuild b/net-vpn/tinc/tinc-1.1_pre17.ebuild
new file mode 100644
index 00000000000..6eb358d55d4
--- /dev/null
+++ b/net-vpn/tinc/tinc-1.1_pre17.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=${PV/_/}
+MY_P=${PN}-${MY_PV}
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools python-single-r1 systemd
+
+DESCRIPTION="tinc is an easy to configure VPN implementation"
+HOMEPAGE="http://www.tinc-vpn.org/"
+
+UPSTREAM_VER=2
+
+[[ -n ${UPSTREAM_VER} ]] && \
+ UPSTREAM_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${PN}-1.1-upstream-patches-${UPSTREAM_VER}.tar.xz"
+
+SRC_URI="http://www.tinc-vpn.org/packages/${MY_P}.tar.gz
+ ${UPSTREAM_PATCHSET_URI}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+lzo +ncurses libressl +readline +ssl uml vde upnp +zlib"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ lzo? ( dev-libs/lzo:2 )
+ ncurses? ( sys-libs/ncurses:= )
+ readline? ( sys-libs/readline:= )
+ upnp? ( net-libs/miniupnpc )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}
+ vde? ( net-misc/vde )"
+S="${WORKDIR}/${MY_P}"
+
+# Upstream's patchset
+if [[ -n ${UPSTREAM_VER} ]]; then
+ PATCHES=( "${WORKDIR}"/patches-upstream )
+fi
+
+PATCHES+=(
+ "${FILESDIR}"/tinc-1.1_pre16-r1-fix-paths.patch #560528
+ "${FILESDIR}"/${PN}-1.1-tinfo.patch #621868
+)
+
+src_prepare() {
+ default
+ eautoreconf
+
+ # Fix the static (failing UNKNOWN) version in the autoconf
+ # NOTE: When updating the ebuild, make sure to check that this
+ # line number hasn't changed in the upstream sources.
+ sed -i "6d" configure.ac
+ sed -i "6iAC_INIT([tinc], ${PVR})" configure.ac
+}
+
+src_configure() {
+ econf \
+ --enable-jumbograms \
+ --disable-silent-rules \
+ --enable-legacy-protocol \
+ --disable-tunemu \
+ --with-systemd="$(systemd_get_systemunitdir)" \
+ $(use_enable lzo) \
+ $(use_enable ncurses curses) \
+ $(use_enable readline) \
+ $(use_enable uml) \
+ $(use_enable vde) \
+ $(use_enable zlib) \
+ $(use_enable upnp miniupnpc) \
+ $(use_with ssl openssl)
+ #--without-libgcrypt \
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodir /etc/tinc
+ dodoc AUTHORS NEWS README THANKS
+ doconfd "${FILESDIR}"/tinc.networks
+ newconfd "${FILESDIR}"/tincd.conf tincd
+ newinitd "${FILESDIR}"/tincd-r2 tincd
+}
+
+pkg_postinst() {
+ elog "This package requires the tun/tap kernel device."
+ elog "Look at http://www.tinc-vpn.org/ for how to configure tinc"
+}