summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-07-22 21:38:16 +0200
committerHans de Graaff <graaff@gentoo.org>2018-07-22 21:38:34 +0200
commit2d707becfb19a25cabc2c1af3e08a464b5c1345e (patch)
treea2ffa49c7cb2d06c9eca10316afb248b5489b12f /net-vpn
parentapp-forensics/chkrootkit: arm stable wrt bug #660906 (diff)
downloadgentoo-2d707becfb19a25cabc2c1af3e08a464b5c1345e.tar.gz
gentoo-2d707becfb19a25cabc2c1af3e08a464b5c1345e.tar.bz2
gentoo-2d707becfb19a25cabc2c1af3e08a464b5c1345e.zip
net-vpn/libreswan: fix compilation with -curl
Backports an upstream bug fix. Closes: https://bugs.gentoo.org/661814 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/libreswan/files/libreswan-3.25-no-curl.patch25
-rw-r--r--net-vpn/libreswan/libreswan-3.25.ebuild2
2 files changed, 27 insertions, 0 deletions
diff --git a/net-vpn/libreswan/files/libreswan-3.25-no-curl.patch b/net-vpn/libreswan/files/libreswan-3.25-no-curl.patch
new file mode 100644
index 000000000000..f23e2f7f227c
--- /dev/null
+++ b/net-vpn/libreswan/files/libreswan-3.25-no-curl.patch
@@ -0,0 +1,25 @@
+From 903f953b271c35f33790bb7ba98b17acfdecede6 Mon Sep 17 00:00:00 2001
+From: Paul Wouters <pwouters@redhat.com>
+Date: Sun, 22 Jul 2018 11:37:04 -0700
+Subject: [PATCH] building: only call check_crls() if LIBCURL support is
+ compiled in
+
+Noted by Daniel M. Weeks
+---
+ programs/pluto/timer.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/programs/pluto/timer.c b/programs/pluto/timer.c
+index b8a465a91b..4e82e634ea 100644
+--- a/programs/pluto/timer.c
++++ b/programs/pluto/timer.c
+@@ -432,7 +432,9 @@ static void timer_event_cb(evutil_socket_t fd UNUSED, const short event UNUSED,
+ break;
+
+ case EVENT_CHECK_CRLS:
++#ifdef LIBCURL
+ check_crls();
++#endif
+ break;
+
+ case EVENT_v2_RELEASE_WHACK:
diff --git a/net-vpn/libreswan/libreswan-3.25.ebuild b/net-vpn/libreswan/libreswan-3.25.ebuild
index b71d536ae106..ef9392525b5b 100644
--- a/net-vpn/libreswan/libreswan-3.25.ebuild
+++ b/net-vpn/libreswan/libreswan-3.25.ebuild
@@ -50,6 +50,8 @@ usetf() {
}
src_prepare() {
+ eapply "${FILESDIR}/${P}-no-curl.patch"
+
sed -i -e 's:/sbin/runscript:/sbin/openrc-run:' initsystems/openrc/ipsec.init.in || die
sed -i -e '/^install/ s/postcheck//' -e '/^doinstall/ s/oldinitdcheck//' initsystems/systemd/Makefile || die
default