summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Vasquez <fearedbliss@gentoo.org>2018-07-06 16:10:12 -0400
committerJonathan Vasquez <fearedbliss@gentoo.org>2018-07-06 16:10:41 -0400
commit70ffe53880c2d20ee5911a846e5a42df2d1ca070 (patch)
treeee134752dd95a7064921e6c5435d45e854b0b85a /net-vpn
parentdev-lang/python: bump to 3.7.0 (diff)
downloadgentoo-70ffe53880c2d20ee5911a846e5a42df2d1ca070.tar.gz
gentoo-70ffe53880c2d20ee5911a846e5a42df2d1ca070.tar.bz2
gentoo-70ffe53880c2d20ee5911a846e5a42df2d1ca070.zip
net-vpn/tinc: version bump to 1.1_pre16 and minor improvements.
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/tinc/Manifest1
-rw-r--r--net-vpn/tinc/files/tinc-1.1_pre15-fix-paths.patch (renamed from net-vpn/tinc/files/tinc-1.1-fix-paths.patch)0
-rw-r--r--net-vpn/tinc/files/tinc-1.1_pre16-fix-paths.patch55
-rw-r--r--net-vpn/tinc/tinc-1.1_pre15.ebuild8
-rw-r--r--net-vpn/tinc/tinc-1.1_pre16.ebuild103
5 files changed, 166 insertions, 1 deletions
diff --git a/net-vpn/tinc/Manifest b/net-vpn/tinc/Manifest
index ca1d7e95537a..959505f8846c 100644
--- a/net-vpn/tinc/Manifest
+++ b/net-vpn/tinc/Manifest
@@ -1,3 +1,4 @@
DIST tinc-1.0.33.tar.gz 486374 BLAKE2B 542e9c95aa3dea941315c5a3293c06137be7131bbb4a3ba5d788e7c250327d0b01530db5b3371aee85b1e85a104b9997e9f09a6b33051090da087595e1bcb9da SHA512 f17c7682e177d85a049891255fc590069c7901307951ee93364a7a754f1a7c5ca4b6a6f7ddcb4c9ad150f0155ff7db7112990a3fc3a6496b48bdbfd3b1ae8804
DIST tinc-1.0.34.tar.gz 484174 BLAKE2B 8ba80983cb1293b03b814f305bd733a2208562b8450a539c0f80c25596c0e05fb7ebc8edf8e6617b9e18d8b96bb49a82098f902e692ce4b85c7c47b1072be2dd SHA512 b711a2c532f8efc94c77e9bbe5213ae284d2a3cb598d2760df700448e495a02ac56baa0393bbc6fbc735bf97a26ca5a79133c92952d98a9086a9ffd273eef725
DIST tinc-1.1pre15.tar.gz 704145 BLAKE2B e97f044066a3c399b4089ed73e77a78904837031cbf04445390a3132a5cd8cf3e9390c1908b1804364616d16fffdedbae6b88f8a42da7471a42e4c8eea614d0e SHA512 29b109c84a89204a9fe298e3cfb092169a7c3cbb62e0cabdb7fe8eaa01b03343b7d48bf028525754af1a340781de209e0b9412669c256a30e7226a8a21412c17
+DIST tinc-1.1pre16.tar.gz 703679 BLAKE2B c02636f52983c1fdebe28058a5e49f3952ac10b238c9d8f01a10b140960803f197a057c883860ca259b949883c406cf74f518d0e45bf84f10566a964570daf9b SHA512 b32a0a734a4c8a91bad4cef4177cb45757c97c09dc179da1e3357f2fde48b3b0747587dbac31ecb5400e1553b6712d474a6a1808ac24bce1a3494c1842bb6c43
diff --git a/net-vpn/tinc/files/tinc-1.1-fix-paths.patch b/net-vpn/tinc/files/tinc-1.1_pre15-fix-paths.patch
index 519677dd5034..519677dd5034 100644
--- a/net-vpn/tinc/files/tinc-1.1-fix-paths.patch
+++ b/net-vpn/tinc/files/tinc-1.1_pre15-fix-paths.patch
diff --git a/net-vpn/tinc/files/tinc-1.1_pre16-fix-paths.patch b/net-vpn/tinc/files/tinc-1.1_pre16-fix-paths.patch
new file mode 100644
index 000000000000..30cafee87878
--- /dev/null
+++ b/net-vpn/tinc/files/tinc-1.1_pre16-fix-paths.patch
@@ -0,0 +1,55 @@
+diff -Naur tinc-1.1pre16.orig/src/names.c tinc-1.1pre16/src/names.c
+--- tinc-1.1pre16.ori/src/names.c 2018-04-02 10:41:12.000000000 -0400
++++ tinc-1.1pre16/src/names.c 2018-07-06 15:11:35.970680875 -0400
+@@ -103,47 +103,13 @@
+ }
+
+ #else
+- bool fallback = false;
+-
+- if(daemon) {
+- if(access(LOCALSTATEDIR, R_OK | W_OK | X_OK)) {
+- fallback = true;
+- }
+- } else {
+- char fname[PATH_MAX];
+- snprintf(fname, sizeof(fname), LOCALSTATEDIR SLASH "run" SLASH "%s.pid", identname);
+-
+- if(access(fname, R_OK)) {
+- snprintf(fname, sizeof(fname), "%s" SLASH "pid", confbase);
+-
+- if(!access(fname, R_OK)) {
+- fallback = true;
+- }
+- }
++ if(!logfilename) {
++ xasprintf(&logfilename, "/var/log" SLASH "%s.log", identname);
+ }
+
+- if(!fallback) {
+- if(!logfilename) {
+- xasprintf(&logfilename, LOCALSTATEDIR SLASH "log" SLASH "%s.log", identname);
+- }
+-
+- if(!pidfilename) {
+- xasprintf(&pidfilename, LOCALSTATEDIR SLASH "run" SLASH "%s.pid", identname);
+- }
+- } else {
+- if(!logfilename) {
+- xasprintf(&logfilename, "%s" SLASH "log", confbase);
+- }
+-
+- if(!pidfilename) {
+- if(daemon) {
+- logger(DEBUG_ALWAYS, LOG_WARNING, "Could not access " LOCALSTATEDIR SLASH " (%s), storing pid and socket files in %s" SLASH, strerror(errno), confbase);
+- }
+-
+- xasprintf(&pidfilename, "%s" SLASH "pid", confbase);
+- }
++ if(!pidfilename) {
++ xasprintf(&pidfilename, "/run" SLASH "%s.pid", identname);
+ }
+-
+ #endif
+
+ if(!unixsocketname) {
diff --git a/net-vpn/tinc/tinc-1.1_pre15.ebuild b/net-vpn/tinc/tinc-1.1_pre15.ebuild
index ea6d0816b40c..359469d9dc7a 100644
--- a/net-vpn/tinc/tinc-1.1_pre15.ebuild
+++ b/net-vpn/tinc/tinc-1.1_pre15.ebuild
@@ -49,13 +49,19 @@ if [[ -n ${UPSTREAM_VER} ]]; then
fi
PATCHES+=(
- "${FILESDIR}"/${PN}-1.1-fix-paths.patch #560528
+ "${FILESDIR}"/${PF}-fix-paths.patch #560528
"${FILESDIR}"/${PN}-1.1-tinfo.patch #621868
)
src_prepare() {
default
eautoreconf
+
+ # Fix the static (failing UNKNOWN) version in the autoconf
+ # NOTE: When updating the ebuild, make sure to check that this
+ # line number hasn't changed in the upstream sources.
+ sed -i "4d" configure.ac
+ sed -i "4iAC_INIT([tinc], ${PVR})" configure.ac
}
src_configure() {
diff --git a/net-vpn/tinc/tinc-1.1_pre16.ebuild b/net-vpn/tinc/tinc-1.1_pre16.ebuild
new file mode 100644
index 000000000000..919232287018
--- /dev/null
+++ b/net-vpn/tinc/tinc-1.1_pre16.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PV=${PV/_/}
+MY_P=${PN}-${MY_PV}
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools python-single-r1 systemd
+
+DESCRIPTION="tinc is an easy to configure VPN implementation"
+HOMEPAGE="http://www.tinc-vpn.org/"
+
+# UPSTREAM_VER=1
+
+[[ -n ${UPSTREAM_VER} ]] && \
+ UPSTREAM_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${PN}-1.1-upstream-patches-${UPSTREAM_VER}.tar.xz"
+
+SRC_URI="http://www.tinc-vpn.org/packages/${MY_P}.tar.gz
+ ${UPSTREAM_PATCHSET_URI}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+lzo +ncurses gui libressl +readline +ssl uml vde upnp +zlib"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ gui? ( dev-python/wxpython:3.0[${PYTHON_USEDEP}] )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ lzo? ( dev-libs/lzo:2 )
+ ncurses? ( sys-libs/ncurses:= )
+ readline? ( sys-libs/readline:= )
+ upnp? ( net-libs/miniupnpc )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}
+ vde? ( net-misc/vde )"
+S="${WORKDIR}/${MY_P}"
+
+# Upstream's patchset
+if [[ -n ${UPSTREAM_VER} ]]; then
+ PATCHES=( "${WORKDIR}"/patches-upstream )
+fi
+
+PATCHES+=(
+ "${FILESDIR}"/${PF}-fix-paths.patch #560528
+ "${FILESDIR}"/${PN}-1.1-tinfo.patch #621868
+)
+
+src_prepare() {
+ default
+ eautoreconf
+
+ # Fix the static (failing UNKNOWN) version in the autoconf
+ # NOTE: When updating the ebuild, make sure to check that this
+ # line number hasn't changed in the upstream sources.
+ sed -i "6d" configure.ac
+ sed -i "6iAC_INIT([tinc], ${PVR})" configure.ac
+}
+
+src_configure() {
+ econf \
+ --enable-jumbograms \
+ --disable-silent-rules \
+ --enable-legacy-protocol \
+ --disable-tunemu \
+ --with-systemd="$(systemd_get_systemunitdir)" \
+ $(use_enable lzo) \
+ $(use_enable ncurses curses) \
+ $(use_enable readline) \
+ $(use_enable uml) \
+ $(use_enable vde) \
+ $(use_enable zlib) \
+ $(use_enable upnp miniupnpc) \
+ $(use_with ssl openssl)
+ #--without-libgcrypt \
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodir /etc/tinc
+ dodoc AUTHORS NEWS README THANKS
+ doconfd "${FILESDIR}"/tinc.networks
+ newconfd "${FILESDIR}"/tincd.conf tincd
+ newinitd "${FILESDIR}"/tincd-r2 tincd
+
+ if use gui; then
+ python_fix_shebang "${ED}"/usr/bin/tinc-gui
+ else
+ rm -f "${ED}"/usr/bin/tinc-gui || die
+ fi
+}
+
+pkg_postinst() {
+ elog "This package requires the tun/tap kernel device."
+ elog "Look at http://www.tinc-vpn.org/ for how to configure tinc"
+}