summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2019-01-06 17:58:25 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-01-06 17:58:52 +0100
commit869cca1402e8ec12d64c4eb99175eadc2070dc15 (patch)
tree604cf390be627393d89f8108bd1f887e26fc6695 /net-vpn
parentdev-util/rr-5.2.0: Fix error type ::ucontext_t not correctly defined (diff)
downloadgentoo-869cca1402e8ec12d64c4eb99175eadc2070dc15.tar.gz
gentoo-869cca1402e8ec12d64c4eb99175eadc2070dc15.tar.bz2
gentoo-869cca1402e8ec12d64c4eb99175eadc2070dc15.zip
net-vpn/openfortivpn: Version bump
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/openfortivpn/Manifest1
-rw-r--r--net-vpn/openfortivpn/openfortivpn-1.8.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/net-vpn/openfortivpn/Manifest b/net-vpn/openfortivpn/Manifest
index df1f0409b5bc..b309783b6496 100644
--- a/net-vpn/openfortivpn/Manifest
+++ b/net-vpn/openfortivpn/Manifest
@@ -1 +1,2 @@
DIST openfortivpn-1.7.1.tar.gz 61236 BLAKE2B b382ceac577e63ebb7a92ee3ca80c45e94f77eb95f8ea75f91a4c2ca2fb006f4d2e5e4c7bdf3974875cfb3611f34ef249218d194d58f66f3b51b30c8b90a3f82 SHA512 9c151ce3f914a7cba13be3e3b98e35d49329ac2c04410b653ce40dfb9fe1912c2e51d0322f9e37d5ed47bb28a46203a19ce87ab2fa670229f2b5ccf5b9bb6fc1
+DIST openfortivpn-1.8.1.tar.gz 70521 BLAKE2B 5451ab9937e0f6ba1c2601f9ad8a44d5b9954b9798f4a4aa81675d561f5aa95890946a5623af9a57db6e20fe074e65b0578655ca538c20751e7e1363df01ab68 SHA512 0c2f26e744c266125bf35a643bc2510d782c9c7b4e3324cef53cc7e9a350df3c968c4d0d34256a64cf6b7d1cad2ffc95019a39586786238481dda20030e524a9
diff --git a/net-vpn/openfortivpn/openfortivpn-1.8.1.ebuild b/net-vpn/openfortivpn/openfortivpn-1.8.1.ebuild
new file mode 100644
index 000000000000..a0280e748daa
--- /dev/null
+++ b/net-vpn/openfortivpn/openfortivpn-1.8.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools linux-info
+
+DESCRIPTION="A Fortinet compatible VPN client"
+HOMEPAGE="https://github.com/adrienverge/openfortivpn"
+SRC_URI="https://github.com/adrienverge/openfortivpn/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3-with-openssl-exception openssl"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libressl"
+
+DEPEND="
+ net-dialup/ppp
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~PPP ~PPP_ASYNC"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' Makefile.am || die "Failed to remove -Werror from Makefile.am"
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ keepdir /etc/openfortivpn
+}