summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Laurantin <olivier.laurantin@laposte.net>2020-08-21 18:14:24 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-09-15 17:11:18 +0300
commit2e56cbdd58cccc1340ac8973893b667e2aaa062e (patch)
treea32031b9424d512142d449e66804d9673dedf3a9 /net-wireless/blueberry
parentdev-util/packer: Version bump to 1.5.6 (diff)
downloadgentoo-2e56cbdd58cccc1340ac8973893b667e2aaa062e.tar.gz
gentoo-2e56cbdd58cccc1340ac8973893b667e2aaa062e.tar.bz2
gentoo-2e56cbdd58cccc1340ac8973893b667e2aaa062e.zip
net-wireless/blueberry: version bump
Update to latest upstream version Add python 3.8 compatibility Signed-off-by: Olivier Laurantin <olivier.laurantin@laposte.net> Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-wireless/blueberry')
-rw-r--r--net-wireless/blueberry/Manifest1
-rw-r--r--net-wireless/blueberry/blueberry-1.3.9.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/net-wireless/blueberry/Manifest b/net-wireless/blueberry/Manifest
index 85316f6cb51b..8744c4d77cb0 100644
--- a/net-wireless/blueberry/Manifest
+++ b/net-wireless/blueberry/Manifest
@@ -1 +1,2 @@
DIST blueberry-1.3.6.tar.gz 1411444 BLAKE2B b86db1f470f44ad8c0b8efa173f0d161112a6ddd734b9cb9545ece78762299ed244855d9d89d7f9090f876ca6da8ac0b8cd8e2b4627ea94588bfe52b466b43d5 SHA512 6ff6a9b3dc5ff46fc383f55a1c6f519447ca707fac2a31436a1a8d0955de50dd5bfc9977879fcd3191ef1a4e508629ccb0d790a2dce3fd3ff54be098218bbd8d
+DIST blueberry-1.3.9.tar.gz 1411969 BLAKE2B 2a11b12428166dce5dbeb00cc3813e9dea96b61891456622833400f7a9bb69a61317e9d6bdc862edce2c39f64fd04950dc793724338cb266ae365b1d10abee49 SHA512 7ee5e33daf0ce3b41bc3827042aa14ed4de1b58f862e76a50934d6beae79bf7e68b657461370da2e309d15c7ff858c8fb18aa7e891e7bc70e70c171884c5bb57
diff --git a/net-wireless/blueberry/blueberry-1.3.9.ebuild b/net-wireless/blueberry/blueberry-1.3.9.ebuild
new file mode 100644
index 000000000000..391bc9e2e03d
--- /dev/null
+++ b/net-wireless/blueberry/blueberry-1.3.9.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit eutils gnome2-utils python-single-r1 xdg-utils
+
+DESCRIPTION="A Bluetooth configuration tool"
+HOMEPAGE="https://github.com/linuxmint/blueberry"
+SRC_URI="https://github.com/linuxmint/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ dev-python/setproctitle[${PYTHON_MULTI_USEDEP}]
+ dev-python/xapp[${PYTHON_MULTI_USEDEP}]
+ ')
+ >=net-wireless/gnome-bluetooth-3.14[introspection]
+ net-wireless/bluez[obex]
+ net-wireless/bluez-tools
+ || (
+ >=sys-apps/util-linux-2.31_rc1
+ net-wireless/rfkill
+ )
+ x11-libs/libnotify[introspection]
+ x11-misc/wmctrl"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ python_fix_shebang usr/lib
+}
+
+src_install() {
+ doins -r etc
+ exeinto /usr/bin
+ doexe usr/bin/*
+ exeinto /usr/lib/blueberry
+ doexe usr/lib/blueberry/*
+ insinto /usr
+ doins -r usr/share
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}