summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-01 01:05:55 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-07 23:59:54 +0100
commit29c3f5492d1b4e4d15b9028b097d5d80408bf9b6 (patch)
tree0cb5742b7f5cb0f305d8d479749eaf10c62a569c /net-wireless/gr-foo
parentnet-wireless/gr-air-modes: EAPI-7 bump (diff)
downloadgentoo-29c3f5492d1b4e4d15b9028b097d5d80408bf9b6.tar.gz
gentoo-29c3f5492d1b4e4d15b9028b097d5d80408bf9b6.tar.bz2
gentoo-29c3f5492d1b4e4d15b9028b097d5d80408bf9b6.zip
net-wireless/gr-foo: EAPI-7 bump, add missing cmake-utils_src_prepare
missing || die Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-wireless/gr-foo')
-rw-r--r--net-wireless/gr-foo/gr-foo-9999.ebuild39
1 files changed, 20 insertions, 19 deletions
diff --git a/net-wireless/gr-foo/gr-foo-9999.ebuild b/net-wireless/gr-foo/gr-foo-9999.ebuild
index 79a25cbde951..b54cc9402c9a 100644
--- a/net-wireless/gr-foo/gr-foo-9999.ebuild
+++ b/net-wireless/gr-foo/gr-foo-9999.ebuild
@@ -1,45 +1,46 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake-utils python-single-r1
+EAPI=7
-DESCRIPTION="Some GNU Radio blocks that bastianbl uses"
-HOMEPAGE="https://github.com/rftap/gr-rftap"
+PYTHON_COMPAT=( python2_7 )
if [[ ${PV} == 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/bastibl/gr-foo.git"
+else
KEYWORDS=""
-#else
-# SRC_URI=""
-# KEYWORDS=""
fi
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="Some GNU Radio blocks that bastianbl uses"
+HOMEPAGE="https://github.com/rftap/gr-rftap"
LICENSE="GPL-3"
SLOT="0/${PV}"
-RDEPEND=">=net-wireless/gnuradio-3.7_rc:0=[${PYTHON_USEDEP}]
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
dev-libs/boost:=[${PYTHON_USEDEP}]
+ >=net-wireless/gnuradio-3.7_rc:0=[${PYTHON_USEDEP}]
net-wireless/uhd:=[${PYTHON_USEDEP}]
- ${PYTHON_DEPS}"
+"
DEPEND="${RDEPEND}
- dev-lang/swig:0"
+ dev-lang/swig:0
+"
#cppunit is listed in cmake, but only needed for tests and there are no tests
# dev-util/cppunit"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
src_prepare() {
+ cmake-utils_src_prepare
#although cppunit is not used, it fails if it isn't there, fix it
- sed -i 's#FATAL_ERROR "CppUnit#MESSAGE "CppUnit#' CMakeLists.txt
- sed -i '/${CPPUNIT_INCLUDE_DIRS}/d' CMakeLists.txt
- sed -i '/${CPPUNIT_LIBRARY_DIRS}/d' CMakeLists.txt
+ sed -i 's#FATAL_ERROR "CppUnit#MESSAGE "CppUnit#' CMakeLists.txt || die
+ sed -i '/${CPPUNIT_INCLUDE_DIRS}/d' CMakeLists.txt || die
+ sed -i '/${CPPUNIT_LIBRARY_DIRS}/d' CMakeLists.txt || die
}
src_configure() {
- mycmakeargs=( -DPYTHON_EXECUTABLE="${PYTHON}" )
+ local mycmakeargs=( -DPYTHON_EXECUTABLE="${PYTHON}" )
cmake-utils_src_configure
}