summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2016-03-15 12:30:36 -0400
committerZero_Chaos <zerochaos@gentoo.org>2016-03-15 12:30:55 -0400
commit58f96fc4ee39f99c45abd3302b34144d60baf5d4 (patch)
tree106e9e5d97a365f90d5266ba54aaacf7cdb0ff93 /net-wireless/portapack-firmware
parentapp-admin/lastpass-cli: drop old version 0.6.1 and 0.7.2 (diff)
downloadgentoo-58f96fc4ee39f99c45abd3302b34144d60baf5d4.tar.gz
gentoo-58f96fc4ee39f99c45abd3302b34144d60baf5d4.tar.bz2
gentoo-58f96fc4ee39f99c45abd3302b34144d60baf5d4.zip
net-wireless/portapack-firmware: version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-wireless/portapack-firmware')
-rw-r--r--net-wireless/portapack-firmware/Manifest1
-rw-r--r--net-wireless/portapack-firmware/portapack-firmware-20160222.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-wireless/portapack-firmware/Manifest b/net-wireless/portapack-firmware/Manifest
index e8d121008cfe..d94456095596 100644
--- a/net-wireless/portapack-firmware/Manifest
+++ b/net-wireless/portapack-firmware/Manifest
@@ -1 +1,2 @@
DIST portapack-h1-firmware-20150904.tar.bz2 96233 SHA256 25d6f44e6afcf4284316cb04702ea24ab528b33e4c780f9a57f067365f391df2 SHA512 0b7633a422b4311f5c7b66d88498b8f33a8f3bd1e0f23d18b5ba59fc901798b8d3c65b039c98bdaa428692b5ed00b5275de34a30ea72825a766cbb8fe84c2a7b WHIRLPOOL 1a816707cbe3d91d8dff8a51b1838999b2de485c425555183a3caea8f760a059e813ce0d734e7c6e41a599b974ec1702766ca10d5a78caeab11ff90791c1e101
+DIST portapack-h1-firmware-20160222.tar.bz2 117737 SHA256 43b6e8150a8c0b31e40703a05e1462acf6b365ff1814b0111968b2e5fd9a8148 SHA512 c330561126fe5cec53bd85fde6a76bac0f70d20d1fcc7e0ba578e9332bd8f8e5353673a14a084fe44ecef7f91a2829836c24a090c993a74eb065fb1ae65e65c3 WHIRLPOOL a2acc92ba99c1f27e013332103fe896beb8091608bf248c7effdd6e1b2976d7461b68f8e05ca7dd1a493a776ffd9dc77a28a38bfd7cbe741337b39c147c1c724
diff --git a/net-wireless/portapack-firmware/portapack-firmware-20160222.ebuild b/net-wireless/portapack-firmware/portapack-firmware-20160222.ebuild
new file mode 100644
index 000000000000..79d0b3af5612
--- /dev/null
+++ b/net-wireless/portapack-firmware/portapack-firmware-20160222.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Firmware and scripts for controlling the Portapack from Sharebrained"
+HOMEPAGE="https://github.com/sharebrained/portapack-hackrf/releases"
+SRC_URI="https://github.com/sharebrained/portapack-hackrf/releases/download/${PV}/portapack-h1-firmware-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+PDEPEND=">=net-wireless/hackrf-tools-2015.07.2-r1
+ =app-mobilephone/dfu-util-0.7"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/hackrf
+ newins portapack-h1-firmware.bin portapack-h1-firmware-${PV}.bin
+ ln -s portapack-h1-firmware-${PV}.bin "${ED}/usr/share/hackrf/portapack-h1-firmware.bin"
+
+ cat << EOF > switch_to_portapack
+#!/bin/sh
+printf "Hold down the HackRF's DFU button (the button closest to the antenna jack)\n"
+printf "then plug the HackRF into a USB port on your computer.\n"
+printf "After the HackRF is plugged in, you may release the DFU button.\n"
+printf "Press any key to continue or ^c to abort\n"
+read
+dfu-util --device 1fc9:000c --download /usr/share/hackrf/hackrf_one_usb_ram.dfu --reset
+sleep 2s
+hackrf_spiflash -w /usr/share/hackrf/portapack-h1-firmware.bin
+EOF
+ dobin switch_to_portapack
+ cat << EOF > switch_to_hackrf
+#!/bin/sh
+printf "Hold down the HackRF's DFU button (the button closest to the antenna jack)\n"
+printf "then plug the HackRF into a USB port on your computer.\n"
+printf "After the HackRF is plugged in, you may release the DFU button.\n"
+printf "Press any key to continue or ^c to abort\n"
+read
+dfu-util --device 1fc9:000c --download /usr/share/hackrf/hackrf_one_usb_ram.dfu --reset
+sleep 2s
+hackrf_spiflash -w /usr/share/hackrf/hackrf_one_usb_rom_to_ram.bin
+EOF
+ dobin switch_to_hackrf
+}