summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortharvik <tharvik@users.noreply.github.com>2016-10-10 17:40:31 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-10-14 08:50:41 +0200
commit2dc3aa5b996e008741c8b1fa324fc52a8dd19d2b (patch)
treed80e104038da9f8c237128351d4577b93dd96285 /net-wireless
parentdev-util/cloc: version bump 1.70. (diff)
downloadgentoo-2dc3aa5b996e008741c8b1fa324fc52a8dd19d2b.tar.gz
gentoo-2dc3aa5b996e008741c8b1fa324fc52a8dd19d2b.tar.bz2
gentoo-2dc3aa5b996e008741c8b1fa324fc52a8dd19d2b.zip
net-wireless/rfkill: remove git polling.
Acked-by: Tony Vroon <chainsaw@gentoo.org> Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2525 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/rfkill/rfkill-0.5-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-wireless/rfkill/rfkill-0.5-r1.ebuild b/net-wireless/rfkill/rfkill-0.5-r1.ebuild
new file mode 100644
index 000000000000..6a8f42c4b63c
--- /dev/null
+++ b/net-wireless/rfkill/rfkill-0.5-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool to read and control rfkill status through /dev/rfkill"
+HOMEPAGE="https://wireless.kernel.org/en/users/Documentation/rfkill"
+SRC_URI="https://www.kernel.org/pub/software/network/${PN}/${P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+src_prepare() {
+ default
+
+ sed -i "s|^SUFFIX=$|SUFFIX=-${PR}|" version.sh || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) LD=$(tc-getLD) V=1
+}
+
+src_install() {
+ emake install V=1 DESTDIR="${D}"
+}