summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-11-06 22:26:04 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-12-04 01:54:19 +0100
commit9040d6c5be62a68a0cfc2a5fc824e9abc5f19951 (patch)
treeeed08f769867f39257f72343cc27b196a6d587fc /net-wireless
parentnet-wireless/wpa_supplicant: Drop USE=qt4, bump to EAPI 6. (diff)
downloadgentoo-9040d6c5be62a68a0cfc2a5fc824e9abc5f19951.tar.gz
gentoo-9040d6c5be62a68a0cfc2a5fc824e9abc5f19951.tar.bz2
gentoo-9040d6c5be62a68a0cfc2a5fc824e9abc5f19951.zip
net-wireless/wpa_supplicant: Move USE=gnutls behind USE=ssl flag.
Gentoo-Bug: https://bugs.gentoo.org/587238 Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2673
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-2.6-r1.ebuild34
1 files changed, 20 insertions, 14 deletions
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-2.6-r1.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-2.6-r1.ebuild
index 5db32384b64..18e0b3ea15d 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-2.6-r1.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-2.6-r1.ebuild
@@ -14,7 +14,7 @@ LICENSE="|| ( GPL-2 BSD )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="ap dbus gnutls eap-sim fasteap +hs2-0 libressl p2p ps3 qt5 readline selinux smartcard ssl tdls uncommon-eap-types wimax wps kernel_linux kernel_FreeBSD"
-REQUIRED_USE="fasteap? ( !gnutls !ssl ) smartcard? ( ssl )"
+REQUIRED_USE="fasteap? ( !ssl ) smartcard? ( ssl )"
CDEPEND="dbus? ( sys-apps/dbus )
kernel_linux? (
@@ -34,16 +34,16 @@ CDEPEND="dbus? ( sys-apps/dbus )
sys-libs/readline:0=
)
ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
- !ssl? (
gnutls? (
- dev-libs/libgcrypt:*
- net-libs/gnutls
+ dev-libs/libgcrypt:0=
+ net-libs/gnutls:=
+ )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
)
- !gnutls? ( dev-libs/libtommath )
)
+ !ssl? ( dev-libs/libtommath )
"
DEPEND="${CDEPEND}
virtual/pkgconfig
@@ -72,8 +72,12 @@ Kconfig_style_config() {
}
pkg_setup() {
- if use gnutls && use ssl ; then
- elog "You have both 'gnutls' and 'ssl' USE flags enabled: defaulting to USE=\"ssl\""
+ if use ssl ; then
+ if use gnutls && use libressl ; then
+ elog "You have both 'gnutls' and 'libressl' USE flags enabled: defaulting to USE=\"gnutls\""
+ fi
+ else
+ elog "You have 'ssl' USE flag disabled: defaulting to internal TLS implementation"
fi
}
@@ -204,10 +208,12 @@ src_configure() {
# SSL authentication methods
if use ssl ; then
- Kconfig_style_config TLS openssl
- elif use gnutls ; then
- Kconfig_style_config TLS gnutls
- Kconfig_style_config GNUTLS_EXTRA
+ if use gnutls ; then
+ Kconfig_style_config TLS gnutls
+ Kconfig_style_config GNUTLS_EXTRA
+ else
+ Kconfig_style_config TLS openssl
+ fi
else
Kconfig_style_config TLS internal
fi