summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-11-19 15:15:31 +1300
committerKent Fredric <kentnl@gentoo.org>2016-11-19 15:25:17 +1300
commit1199060e3ab7816dd14a71524f0030264dbb0c27 (patch)
treeabd5857889ae559159e4490ad53502504393484e /perl-core
parentprofiles/arch/powerpc/ppc64/package.use.mask: no luajit on ppc64 (maybe time ... (diff)
downloadgentoo-1199060e3ab7816dd14a71524f0030264dbb0c27.tar.gz
gentoo-1199060e3ab7816dd14a71524f0030264dbb0c27.tar.bz2
gentoo-1199060e3ab7816dd14a71524f0030264dbb0c27.zip
perl-core/Math-BigInt: Bump to version 1.999.800 (masked)
This is added for staging and testing purposes, but is unlikely to be unmasked until deemed necessary to avoid complications with virtual management - Add USE=examples - Purge lots of toxic, slow, authortests. Package-Manager: portage-2.3.2
Diffstat (limited to 'perl-core')
-rw-r--r--perl-core/Math-BigInt/Manifest1
-rw-r--r--perl-core/Math-BigInt/Math-BigInt-1.999.800.ebuild36
-rw-r--r--perl-core/Math-BigInt/metadata.xml1
3 files changed, 38 insertions, 0 deletions
diff --git a/perl-core/Math-BigInt/Manifest b/perl-core/Math-BigInt/Manifest
index 654814920074..d74c7bdebf85 100644
--- a/perl-core/Math-BigInt/Manifest
+++ b/perl-core/Math-BigInt/Manifest
@@ -1,3 +1,4 @@
DIST Math-BigInt-1.9993.tar.gz 215143 SHA256 d937c0d1afbb3ddd9b666177faf56471b6c2d1917863db5879d04a2d1a69bf7e SHA512 23ae7d11094f6bf5df45a2c3a01a7d9895b244156b8f48497edbfee4de0e56588e59abb4b1fa8808f2e221bd63eae175cd13987c7dc93867b8f969fbf54b6f15 WHIRLPOOL 70d9899003d1b547b066170fb397d03cfddd0edfdeb9beadf4998ee59f4b18fcbce480bf371ef2f3d35ec86f30b883fcdf2a70765cf239b0f73320766c8048e0
DIST Math-BigInt-1.999710.tar.gz 225641 SHA256 879514c3dda33b6f05816569ca1a0f31b650df87660ecf80afbd60e396118610 SHA512 a5f938f5f2c61fd1b4c5c01caa99104aea2a009c8f6e089b465d52948a631cd7cb2df2c54917d9e4bd0bc34281c3a8aa865eb3bf7e6e84f15cff1eb79ccf358d WHIRLPOOL 73e26895de11824008b41e39968903c9a7b888a5b199e64f235e2b86e2360df8b095e6a9f2e29c3c29a385025e33cbbd88dc3f84220c6fd89add49596a1814ee
DIST Math-BigInt-1.999715.tar.gz 252193 SHA256 cfae5c43c4cabe92a940f13e4a23515be4e0dbe72cba8d448a3e96f869794987 SHA512 85d5e168e41f53a37cfcdbef3a2b9a998be7344e828675cda5e3d9db320d4d617555aa9611ecabd6a13974d3a3eee8ec624e9f839bc6ac7a3abecc6a67305bc7 WHIRLPOOL a0a293278391031948e0e5914f239bc6fb92297eefa4fcec92c540ebdfb796f5f60fe22c0f3dde76f9779a9a3b05c74d3da153d7b83a273b05053f308ac49fd5
+DIST Math-BigInt-1.999800.tar.gz 2727031 SHA256 216096d1f937252bfc449b1de01b760ffaab46e753e150cc2a685f4935bd030d SHA512 fa86e85b8cf9cef0fcd69bb692e75e690480b6a8778759f524614e70d42d515422079e36f28dc3a3cdbb654591b9a8eb93160a42f93df87cd837b94b191a97ef WHIRLPOOL 1d0b6ddfab3c3b41bef7b7707bae1d83d0dd8ba7640933394d8ec564e1afdeafa103b3822e2e2a8c3a6341d17d891e6bbe467cb08664f2fe03544d39574bb8fb
diff --git a/perl-core/Math-BigInt/Math-BigInt-1.999.800.ebuild b/perl-core/Math-BigInt/Math-BigInt-1.999.800.ebuild
new file mode 100644
index 000000000000..90a2e83f61e6
--- /dev/null
+++ b/perl-core/Math-BigInt/Math-BigInt-1.999.800.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=PJACKLAM
+DIST_VERSION=1.999800
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Arbitrary size floating point math package"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~ppc-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Math-Complex-1.390.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ test? ( >=virtual/perl-Test-Simple-0.940.0 )
+"
+
+PDEPEND="
+ >=virtual/perl-Math-BigInt-FastCalc-0.270.0
+ >=virtual/perl-bignum-0.220.0
+ >=virtual/perl-Math-BigRat-0.260.200
+"
+# where does this come from?
+
+src_test() {
+ perl_rm_files t/author-*.t t/03podcov.t t/00sig.t t/02pod.t
+ perl-module_src_test
+}
diff --git a/perl-core/Math-BigInt/metadata.xml b/perl-core/Math-BigInt/metadata.xml
index 1bb5705a3834..669e605bdbd5 100644
--- a/perl-core/Math-BigInt/metadata.xml
+++ b/perl-core/Math-BigInt/metadata.xml
@@ -11,5 +11,6 @@
<remote-id type="cpan-module">Math::BigInt</remote-id>
<remote-id type="cpan-module">Math::BigInt::Calc</remote-id>
<remote-id type="cpan-module">Math::BigInt::CalcEmu</remote-id>
+ <remote-id type="cpan-module">Math::BigInt::Lib</remote-id>
</upstream>
</pkgmetadata>