summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-08-03 18:51:35 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-03 22:06:09 +0200
commit7a0de6291c3cbcd225eb3e19f416a08c9ed94bd2 (patch)
tree42062e8c1513fa5286c08cf7b6a44f1323ad6cc0 /profiles
parentpackage.mask: Last rite sys-apps/yum & rdep, #499328 (diff)
downloadgentoo-7a0de6291c3cbcd225eb3e19f416a08c9ed94bd2.tar.gz
gentoo-7a0de6291c3cbcd225eb3e19f416a08c9ed94bd2.tar.bz2
gentoo-7a0de6291c3cbcd225eb3e19f416a08c9ed94bd2.zip
package.mask: Last rite sys-boot/plymouth & rdeps, #621470
Diffstat (limited to 'profiles')
-rw-r--r--profiles/base/package.use.mask6
-rw-r--r--profiles/package.mask12
2 files changed, 18 insertions, 0 deletions
diff --git a/profiles/base/package.use.mask b/profiles/base/package.use.mask
index d299d8de36a..7a651fe7e6c 100644
--- a/profiles/base/package.use.mask
+++ b/profiles/base/package.use.mask
@@ -8,6 +8,12 @@
# mask everywhere, unmask on arch/*) use arch/base.
# Michał Górny <mgorny@gentoo.org> (04 Aug 2017)
+# sys-boot/plymouth is being treecleaned wrt #621470.
+gnome-base/gdm plymouth
+kde-plasma/plasma-meta plymouth
+sys-kernel/genkernel-next plymouth
+
+# Michał Górny <mgorny@gentoo.org> (04 Aug 2017)
# sys-kernel/openvz-sources is being treecleaned wrt #580516.
app-emulation/libvirt openvz
diff --git a/profiles/package.mask b/profiles/package.mask
index bf700ab1070..27cb4019850 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -30,6 +30,18 @@
#--- END OF EXAMPLES ---
# Michał Górny <mgorny@gentoo.org> (04 Aug 2017)
+# sys-boot/plymouth is unmaintained since Apr 2016. The current version
+# has multiple bugs, including not supporting OpenRC. It really needs
+# an active maintainer. Removal in 30 days. Bug #621470.
+#
+# The remaining packages are sys-boot/plymouth reverse dependencies.
+# They have no use without it, so they are being removed as well.
+kde-plasma/breeze-plymouth
+kde-plasma/plymouth-kcm
+sys-boot/plymouth
+sys-boot/plymouth-openrc-plugin
+
+# Michał Górny <mgorny@gentoo.org> (04 Aug 2017)
# sys-apps/yum is severely outdated (last bump 2013), unmaintained
# since 2010. It has vulnerabilities. Removal in 30 days. Bug #499328.
#