summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-27 11:09:39 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-27 11:26:05 +0200
commit91460f125f7f0f04784fe408b237bba8982d2dd9 (patch)
treed2d6246e21522e48016c8cff0ad04369c4e35268 /ros-meta/navigation/navigation-1.16.0.ebuild
parentdev-ros/voxel_grid: Bump to 1.16.0. (diff)
downloadgentoo-91460f125f7f0f04784fe408b237bba8982d2dd9.tar.gz
gentoo-91460f125f7f0f04784fe408b237bba8982d2dd9.tar.bz2
gentoo-91460f125f7f0f04784fe408b237bba8982d2dd9.zip
ros-meta/navigation: Bump to 1.16.0.
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'ros-meta/navigation/navigation-1.16.0.ebuild')
-rw-r--r--ros-meta/navigation/navigation-1.16.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/ros-meta/navigation/navigation-1.16.0.ebuild b/ros-meta/navigation/navigation-1.16.0.ebuild
new file mode 100644
index 000000000000..12d224293a7e
--- /dev/null
+++ b/ros-meta/navigation/navigation-1.16.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="2D navigation stack"
+LICENSE="BSD LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/amcl
+ dev-ros/base_local_planner
+ dev-ros/carrot_planner
+ dev-ros/clear_costmap_recovery
+ dev-ros/costmap_2d
+ dev-ros/dwa_local_planner
+ dev-ros/fake_localization
+ dev-ros/global_planner
+ dev-ros/map_server
+ dev-ros/move_base
+ dev-ros/move_slow_and_clear
+ dev-ros/nav_core
+ dev-ros/navfn
+ dev-ros/rotate_recovery
+ dev-ros/voxel_grid
+"
+DEPEND="${RDEPEND}"