summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-08-04 20:37:18 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-08-04 20:46:35 +0200
commit88f3838bb2d7135c5b6c6cdba95822ee8e5ea138 (patch)
tree0505a0caf0c263d997a3e176d2504eb4ae830083 /ros-meta/navigation/navigation-1.16.2.ebuild
parentdev-ros/voxel_grid: Bump to 1.16.2. (diff)
downloadgentoo-88f3838bb2d7135c5b6c6cdba95822ee8e5ea138.tar.gz
gentoo-88f3838bb2d7135c5b6c6cdba95822ee8e5ea138.tar.bz2
gentoo-88f3838bb2d7135c5b6c6cdba95822ee8e5ea138.zip
ros-meta/navigation: Bump to 1.16.2.
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'ros-meta/navigation/navigation-1.16.2.ebuild')
-rw-r--r--ros-meta/navigation/navigation-1.16.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/ros-meta/navigation/navigation-1.16.2.ebuild b/ros-meta/navigation/navigation-1.16.2.ebuild
new file mode 100644
index 000000000000..12d224293a7e
--- /dev/null
+++ b/ros-meta/navigation/navigation-1.16.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="2D navigation stack"
+LICENSE="BSD LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/amcl
+ dev-ros/base_local_planner
+ dev-ros/carrot_planner
+ dev-ros/clear_costmap_recovery
+ dev-ros/costmap_2d
+ dev-ros/dwa_local_planner
+ dev-ros/fake_localization
+ dev-ros/global_planner
+ dev-ros/map_server
+ dev-ros/move_base
+ dev-ros/move_slow_and_clear
+ dev-ros/nav_core
+ dev-ros/navfn
+ dev-ros/rotate_recovery
+ dev-ros/voxel_grid
+"
+DEPEND="${RDEPEND}"