summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-05-11 10:29:13 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-05-11 10:45:28 +0200
commitf1231a1669cb4926c1b0cf94d06e0c57d35ef04e (patch)
tree357df9fa2f39b59e7a40b2ab99b223a8ff3d92bb /ros-meta/robot/robot-1.3.0.ebuild
parentros-meta/simulators: bump to 1.3.0 (diff)
downloadgentoo-f1231a1669cb4926c1b0cf94d06e0c57d35ef04e.tar.gz
gentoo-f1231a1669cb4926c1b0cf94d06e0c57d35ef04e.tar.bz2
gentoo-f1231a1669cb4926c1b0cf94d06e0c57d35ef04e.zip
ros-meta/robot: bump to 1.3.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'ros-meta/robot/robot-1.3.0.ebuild')
-rw-r--r--ros-meta/robot/robot-1.3.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/ros-meta/robot/robot-1.3.0.ebuild b/ros-meta/robot/robot-1.3.0.ebuild
new file mode 100644
index 000000000000..075d3ba57399
--- /dev/null
+++ b/ros-meta/robot/robot-1.3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/metapackages"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Metapackage which extends ros_base and includes ROS libaries for any robot hardware"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ ros-meta/ros_base
+ dev-ros/control_msgs
+ ros-meta/diagnostics
+ dev-ros/filters
+ ros-meta/geometry
+ ros-meta/robot_model
+ dev-ros/robot_state_publisher
+ dev-ros/xacro
+ ros-meta/executive_smach
+ dev-ros/actionlib
+ ros-meta/bond_core
+ dev-ros/class_loader
+ dev-ros/dynamic_reconfigure
+ ros-meta/common_tutorials
+ ros-meta/nodelet_core
+ dev-ros/pluginlib
+"
+DEPEND="${RDEPEND}"