summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-09 08:26:26 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-09 09:14:20 +0200
commitb5dba2bbac544631a43cd0ccce58549916a0b9fd (patch)
tree70cce855f9760f1616c51e33cb7b06d067e1ef08 /ros-meta/ros_base/ros_base-1.3.1.ebuild
parentros-meta/ros_core: bump to 1.3.1 (diff)
downloadgentoo-b5dba2bbac544631a43cd0ccce58549916a0b9fd.tar.gz
gentoo-b5dba2bbac544631a43cd0ccce58549916a0b9fd.tar.bz2
gentoo-b5dba2bbac544631a43cd0ccce58549916a0b9fd.zip
ros-meta/ros_base: bump to 1.3.1
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'ros-meta/ros_base/ros_base-1.3.1.ebuild')
-rw-r--r--ros-meta/ros_base/ros_base-1.3.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/ros-meta/ros_base/ros_base-1.3.1.ebuild b/ros-meta/ros_base/ros_base-1.3.1.ebuild
new file mode 100644
index 000000000000..daf30c8a83fb
--- /dev/null
+++ b/ros-meta/ros_base/ros_base-1.3.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/metapackages"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Metapackage which extends ros_core and includes other basic non-robot tools"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib
+ ros-meta/bond_core
+ dev-ros/class_loader
+ dev-ros/dynamic_reconfigure
+ ros-meta/common_tutorials
+ ros-meta/nodelet_core
+ dev-ros/pluginlib
+"
+DEPEND="${RDEPEND}"