summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-05-13 12:42:32 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-05-13 12:48:57 +0200
commit6b71fdc19c1af107384465553d0cf753fe4961e7 (patch)
treec76d2eca829d1c3ab19bc07ab5838378c9dbdad4 /ros-meta/ros_base/ros_base-1.4.0.ebuild
parentros-meta/robot: bump to 1.4.0 (diff)
downloadgentoo-6b71fdc19c1af107384465553d0cf753fe4961e7.tar.gz
gentoo-6b71fdc19c1af107384465553d0cf753fe4961e7.tar.bz2
gentoo-6b71fdc19c1af107384465553d0cf753fe4961e7.zip
ros-meta/ros_base: bump to 1.4.0
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'ros-meta/ros_base/ros_base-1.4.0.ebuild')
-rw-r--r--ros-meta/ros_base/ros_base-1.4.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/ros-meta/ros_base/ros_base-1.4.0.ebuild b/ros-meta/ros_base/ros_base-1.4.0.ebuild
new file mode 100644
index 000000000000..96e3b6f80ab5
--- /dev/null
+++ b/ros-meta/ros_base/ros_base-1.4.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/metapackages"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Metapackage which extends ros_core and includes other basic non-robot tools"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib
+ ros-meta/bond_core
+ dev-ros/class_loader
+ dev-ros/dynamic_reconfigure
+ ros-meta/nodelet_core
+ dev-ros/pluginlib
+"
+DEPEND="${RDEPEND}"