summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-28 20:24:20 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:20:47 +0200
commitc5f18b38714135458b4491da6223ac73834381a0 (patch)
tree2bb0ef61205598c311fd134344a58659d971b4e5 /ros-meta/ros_comm
parentros-meta/ros_control: eapi7 (diff)
downloadgentoo-c5f18b38714135458b4491da6223ac73834381a0.tar.gz
gentoo-c5f18b38714135458b4491da6223ac73834381a0.tar.bz2
gentoo-c5f18b38714135458b4491da6223ac73834381a0.zip
ros-meta/ros_comm: eapi7
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'ros-meta/ros_comm')
-rw-r--r--ros-meta/ros_comm/Manifest4
-rw-r--r--ros-meta/ros_comm/ros_comm-1.13.6.ebuild59
-rw-r--r--ros-meta/ros_comm/ros_comm-1.14.2.ebuild58
-rw-r--r--ros-meta/ros_comm/ros_comm-1.14.3.ebuild58
-rw-r--r--ros-meta/ros_comm/ros_comm-1.15.4.ebuild58
-rw-r--r--ros-meta/ros_comm/ros_comm-1.15.7.ebuild2
-rw-r--r--ros-meta/ros_comm/ros_comm-9999.ebuild4
7 files changed, 3 insertions, 240 deletions
diff --git a/ros-meta/ros_comm/Manifest b/ros-meta/ros_comm/Manifest
index 3580932d152b..5d86517495e4 100644
--- a/ros-meta/ros_comm/Manifest
+++ b/ros-meta/ros_comm/Manifest
@@ -1,5 +1 @@
-DIST ros_comm-1.13.6.tar.gz 1047870 BLAKE2B 874e31faa1a6a77292dab4b7fa64ed13a1f1f63f76512ea351e53bd14ce87662cea5c648e48c3c16668104129cc5eb172bc8f381516bdba676c7212f1acbaaf9 SHA512 382e81847141ab95462fc84a8215b945af995d29f9c0d507665e22faaf79aee9789950546ca7737bd40059f3ed1ecd284ff11bd3e6f1732f3c47a433c5d25155
-DIST ros_comm-1.14.2.tar.gz 1044745 BLAKE2B 1a5d47a4c6682c7a629d9d84be121a5eafcfc16621dec9a9ab9b57c2c7f9070f0007e15492ee44d86e1879351fae20bb9a759093424dd22ae7d44ae0f28e00e1 SHA512 8cece09572dc6b94a42eb49537cbcddbb954f70df01dc7ac9bd8aba17f53207b86afd8ccff81d929eca33bb9642ad7c530835d3f43471de497611940edae4777
-DIST ros_comm-1.14.3.tar.gz 1045287 BLAKE2B c079983aa730e70028d1bf2c365d01d99ce09ced0c0f6443b18f9d0fb83715f6af4b313d6db4eb99dcc10052c81fa3e6560e7b3591b2fbe14b9ec20fac24babe SHA512 52df24f10f476697ee6fa340da354b45431f35018a25e2674dc9306f175929a4b0368753503ea143f87aeb4945a2e67c37f83d833f54b53f9a76a81022c280a3
-DIST ros_comm-1.15.4.tar.gz 1071246 BLAKE2B 57867c192bfd48f3a0534762808c668031081a6155510879e68f9618226b9c5eff0d5fc9ec0e7ec8d0cc1f0d74794a4e55151036275ae6fc5bb613cc42137ddc SHA512 f92233cbf5ee97832023545730d3e756dfa08507072c074ac3e0763db1c2c2ab9fcbb0c90995a0c5d43f0ddc2ee528c185173a664b19abe4f8159aa3f3cb20dc
DIST ros_comm-1.15.7.tar.gz 1080092 BLAKE2B d5c0dd1f54eac7aa11be21bbc680f85f988cc9328382c0c675b7d5986e888be603ed82affa5f51a270974d07044debe3ecf86f5647fd59cb29e8e791a227feb9 SHA512 67dc100e8ed03a25ea228cc7d456ec2203324098f9e11c9a249299df73bfc34efc75b1221c0fb6fceb38fece627f1dc5f2c23be93c9a1c85b1075784a45ff20e
diff --git a/ros-meta/ros_comm/ros_comm-1.13.6.ebuild b/ros-meta/ros_comm/ros_comm-1.13.6.ebuild
deleted file mode 100644
index 7302c050fcff..000000000000
--- a/ros-meta/ros_comm/ros_comm-1.13.6.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-ROS_REPO_URI="https://github.com/ros/ros_comm"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="ROS communications-related packages"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-# utilities subdir
-RDEPEND="
- dev-ros/roslz4
- dev-ros/xmlrpcpp
- dev-ros/roswtf
- dev-ros/message_filters
-"
-# tools subdir
-RDEPEND="${RDEPEND}
- dev-ros/rosbag
- dev-ros/rosbag_storage
- dev-ros/rosconsole
- dev-ros/rosgraph
- dev-ros/roslaunch
- dev-ros/rosmaster
- dev-ros/rosmsg
- dev-ros/rosnode
- dev-ros/rosout
- dev-ros/rosparam
- dev-ros/rosservice
- dev-ros/rostest
- dev-ros/rostopic
- dev-ros/topic_tools
-"
-# clients subdir
-RDEPEND="${RDEPEND}
- dev-ros/roscpp
- dev-ros/rospy
-"
-# test subdir
-RDEPEND="${RDEPEND}
- dev-ros/test_rosbag
- dev-ros/test_rosbag_storage
- dev-ros/test_roscpp
- dev-ros/test_rosgraph
- dev-ros/test_roslaunch
- dev-ros/test_roslib_comm
- dev-ros/test_rosmaster
- dev-ros/test_rosparam
- dev-ros/test_rospy
- dev-ros/test_rosservice
-"
-DEPEND="${RDEPEND}"
diff --git a/ros-meta/ros_comm/ros_comm-1.14.2.ebuild b/ros-meta/ros_comm/ros_comm-1.14.2.ebuild
deleted file mode 100644
index b3bda6139bb7..000000000000
--- a/ros-meta/ros_comm/ros_comm-1.14.2.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-ROS_REPO_URI="https://github.com/ros/ros_comm"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="ROS communications-related packages"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-# utilities subdir
-RDEPEND="
- dev-ros/roslz4
- dev-ros/xmlrpcpp
- dev-ros/roswtf
- dev-ros/message_filters
-"
-# tools subdir
-RDEPEND="${RDEPEND}
- dev-ros/rosbag
- dev-ros/rosbag_storage
- dev-ros/rosgraph
- dev-ros/roslaunch
- dev-ros/rosmaster
- dev-ros/rosmsg
- dev-ros/rosnode
- dev-ros/rosout
- dev-ros/rosparam
- dev-ros/rosservice
- dev-ros/rostest
- dev-ros/rostopic
- dev-ros/topic_tools
-"
-# clients subdir
-RDEPEND="${RDEPEND}
- dev-ros/roscpp
- dev-ros/rospy
-"
-# test subdir
-RDEPEND="${RDEPEND}
- dev-ros/test_rosbag
- dev-ros/test_rosbag_storage
- dev-ros/test_roscpp
- dev-ros/test_rosgraph
- dev-ros/test_roslaunch
- dev-ros/test_roslib_comm
- dev-ros/test_rosmaster
- dev-ros/test_rosparam
- dev-ros/test_rospy
- dev-ros/test_rosservice
-"
-DEPEND="${RDEPEND}"
diff --git a/ros-meta/ros_comm/ros_comm-1.14.3.ebuild b/ros-meta/ros_comm/ros_comm-1.14.3.ebuild
deleted file mode 100644
index b3bda6139bb7..000000000000
--- a/ros-meta/ros_comm/ros_comm-1.14.3.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-ROS_REPO_URI="https://github.com/ros/ros_comm"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="ROS communications-related packages"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-# utilities subdir
-RDEPEND="
- dev-ros/roslz4
- dev-ros/xmlrpcpp
- dev-ros/roswtf
- dev-ros/message_filters
-"
-# tools subdir
-RDEPEND="${RDEPEND}
- dev-ros/rosbag
- dev-ros/rosbag_storage
- dev-ros/rosgraph
- dev-ros/roslaunch
- dev-ros/rosmaster
- dev-ros/rosmsg
- dev-ros/rosnode
- dev-ros/rosout
- dev-ros/rosparam
- dev-ros/rosservice
- dev-ros/rostest
- dev-ros/rostopic
- dev-ros/topic_tools
-"
-# clients subdir
-RDEPEND="${RDEPEND}
- dev-ros/roscpp
- dev-ros/rospy
-"
-# test subdir
-RDEPEND="${RDEPEND}
- dev-ros/test_rosbag
- dev-ros/test_rosbag_storage
- dev-ros/test_roscpp
- dev-ros/test_rosgraph
- dev-ros/test_roslaunch
- dev-ros/test_roslib_comm
- dev-ros/test_rosmaster
- dev-ros/test_rosparam
- dev-ros/test_rospy
- dev-ros/test_rosservice
-"
-DEPEND="${RDEPEND}"
diff --git a/ros-meta/ros_comm/ros_comm-1.15.4.ebuild b/ros-meta/ros_comm/ros_comm-1.15.4.ebuild
deleted file mode 100644
index f7f96f5e5e58..000000000000
--- a/ros-meta/ros_comm/ros_comm-1.15.4.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-ROS_REPO_URI="https://github.com/ros/ros_comm"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="ROS communications-related packages"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-# utilities subdir
-RDEPEND="
- dev-ros/roslz4
- dev-ros/xmlrpcpp
- dev-ros/roswtf
- dev-ros/message_filters
-"
-# tools subdir
-RDEPEND="${RDEPEND}
- dev-ros/rosbag
- dev-ros/rosbag_storage
- dev-ros/rosgraph
- dev-ros/roslaunch
- dev-ros/rosmaster
- dev-ros/rosmsg
- dev-ros/rosnode
- dev-ros/rosout
- dev-ros/rosparam
- dev-ros/rosservice
- dev-ros/rostest
- dev-ros/rostopic
- dev-ros/topic_tools
-"
-# clients subdir
-RDEPEND="${RDEPEND}
- dev-ros/roscpp
- dev-ros/rospy
-"
-# test subdir
-RDEPEND="${RDEPEND}
- dev-ros/test_rosbag
- dev-ros/test_rosbag_storage
- dev-ros/test_roscpp
- dev-ros/test_rosgraph
- dev-ros/test_roslaunch
- dev-ros/test_roslib_comm
- dev-ros/test_rosmaster
- dev-ros/test_rosparam
- dev-ros/test_rospy
- dev-ros/test_rosservice
-"
-DEPEND="${RDEPEND}"
diff --git a/ros-meta/ros_comm/ros_comm-1.15.7.ebuild b/ros-meta/ros_comm/ros_comm-1.15.7.ebuild
index f7f96f5e5e58..e9db26e11347 100644
--- a/ros-meta/ros_comm/ros_comm-1.15.7.ebuild
+++ b/ros-meta/ros_comm/ros_comm-1.15.7.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/ros_comm"
KEYWORDS="~amd64 ~arm"
diff --git a/ros-meta/ros_comm/ros_comm-9999.ebuild b/ros-meta/ros_comm/ros_comm-9999.ebuild
index b3bda6139bb7..e9db26e11347 100644
--- a/ros-meta/ros_comm/ros_comm-9999.ebuild
+++ b/ros-meta/ros_comm/ros_comm-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/ros_comm"
KEYWORDS="~amd64 ~arm"