summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 17:08:03 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 17:08:03 +0200
commitbe3b15a3d41728b0a97758dfaab04ddaeb8db76a (patch)
tree08346e1c1b3737ffd29daeb3becacb2a19424864 /ros-meta/ros_core/ros_core-9999.ebuild
parentdev-ros/roslisp: Initial import. Ebuild by me. (diff)
downloadgentoo-be3b15a3d41728b0a97758dfaab04ddaeb8db76a.tar.gz
gentoo-be3b15a3d41728b0a97758dfaab04ddaeb8db76a.tar.bz2
gentoo-be3b15a3d41728b0a97758dfaab04ddaeb8db76a.zip
ros-meta/ros_core: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'ros-meta/ros_core/ros_core-9999.ebuild')
-rw-r--r--ros-meta/ros_core/ros_core-9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/ros-meta/ros_core/ros_core-9999.ebuild b/ros-meta/ros_core/ros_core-9999.ebuild
new file mode 100644
index 000000000000..639e93a7e6ae
--- /dev/null
+++ b/ros-meta/ros_core/ros_core-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/metapackages"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Metapackage to aggregate the packages required to use core ROS concepts"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-util/catkin
+ dev-ros/cmake_modules
+ ros-meta/common_msgs
+ dev-ros/gencpp
+ dev-ros/geneus
+ dev-ros/genlisp
+ dev-ros/genpy
+ dev-ros/genmsg
+ dev-ros/message_generation
+ dev-ros/message_runtime
+ ros-meta/ros
+ ros-meta/ros_comm
+ dev-ros/rosconsole_bridge
+ ros-meta/roscpp_core
+ dev-ros/rosgraph_msgs
+ dev-ros/rospack
+ dev-ros/std_msgs
+ dev-ros/std_srvs
+ ros-meta/ros_tutorials
+ dev-ros/roslisp
+"
+DEPEND="${RDEPEND}"