summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:48:51 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:48:51 +0200
commit8d6cb380bd321418c6046fde50b37abdaa38fade (patch)
tree13987208826c66298fc532837b8aa36ec0325b38 /ros-meta
parentdev-ros/urdf_tutorial: Initial import. Ebuild by me. (diff)
downloadgentoo-8d6cb380bd321418c6046fde50b37abdaa38fade.tar.gz
gentoo-8d6cb380bd321418c6046fde50b37abdaa38fade.tar.bz2
gentoo-8d6cb380bd321418c6046fde50b37abdaa38fade.zip
ros-meta/pr2_common: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'ros-meta')
-rw-r--r--ros-meta/pr2_common/Manifest1
-rw-r--r--ros-meta/pr2_common/metadata.xml5
-rw-r--r--ros-meta/pr2_common/pr2_common-1.11.9.ebuild23
-rw-r--r--ros-meta/pr2_common/pr2_common-9999.ebuild23
4 files changed, 52 insertions, 0 deletions
diff --git a/ros-meta/pr2_common/Manifest b/ros-meta/pr2_common/Manifest
new file mode 100644
index 000000000000..81a1f402439c
--- /dev/null
+++ b/ros-meta/pr2_common/Manifest
@@ -0,0 +1 @@
+DIST pr2_common-1.11.9.tar.gz 33337556 SHA256 c6134939602c8a81d006bf4a4bfc48bf8746f5eb0c5b12baa1da8c946d1b4ce1 SHA512 44eb4f802a7b6983b621ca5b2c1c0e2516f16992f35902c2fb4afbdc9ffc8e63c1ed647f4ef09fd4cbeef747aba133a55172cec64c3cf9d759d2c83f7ec8a213 WHIRLPOOL ad5d6c543b1faca2ed48a66405eb8d6c17b9ef6352fa16b6fc55f9b093a6b1b7da3e0571ade5a6013c84d3695c16e910549ea2673c36a4179043ea4f085c1e05
diff --git a/ros-meta/pr2_common/metadata.xml b/ros-meta/pr2_common/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/ros-meta/pr2_common/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/ros-meta/pr2_common/pr2_common-1.11.9.ebuild b/ros-meta/pr2_common/pr2_common-1.11.9.ebuild
new file mode 100644
index 000000000000..3befd2ea38b1
--- /dev/null
+++ b/ros-meta/pr2_common/pr2_common-1.11.9.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/pr2/pr2_common"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="URDF description and 3D models of robot components of the PR2 robot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/pr2_msgs
+ dev-ros/pr2_dashboard_aggregator
+ dev-ros/pr2_description
+ dev-ros/pr2_machine
+"
+DEPEND="${RDEPEND}"
diff --git a/ros-meta/pr2_common/pr2_common-9999.ebuild b/ros-meta/pr2_common/pr2_common-9999.ebuild
new file mode 100644
index 000000000000..3befd2ea38b1
--- /dev/null
+++ b/ros-meta/pr2_common/pr2_common-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/pr2/pr2_common"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="URDF description and 3D models of robot components of the PR2 robot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/pr2_msgs
+ dev-ros/pr2_dashboard_aggregator
+ dev-ros/pr2_description
+ dev-ros/pr2_machine
+"
+DEPEND="${RDEPEND}"