summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-21 21:25:16 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-21 21:26:44 +0100
commit639df19a4b1fc3b4a9a350a14ca5d9d164c6e4f3 (patch)
tree1dc35eb9a39d80df5c424b22f148eb723d48d626 /sci-astronomy/celestia
parentgames-strategy/gwp: Remove last-rited pkg (diff)
downloadgentoo-639df19a4b1fc3b4a9a350a14ca5d9d164c6e4f3.tar.gz
gentoo-639df19a4b1fc3b4a9a350a14ca5d9d164c6e4f3.tar.bz2
gentoo-639df19a4b1fc3b4a9a350a14ca5d9d164c6e4f3.zip
sci-astronomy/celestia: Remove last-rited versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-astronomy/celestia')
-rw-r--r--sci-astronomy/celestia/Manifest1
-rw-r--r--sci-astronomy/celestia/celestia-1.6.1-r1.ebuild120
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.0-cfg.patch11
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.1-gcc46.patch14
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.1-gcc47.patch22
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.1-libpng15.patch14
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.1-libpng16.patch25
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.1-linking.patch65
8 files changed, 0 insertions, 272 deletions
diff --git a/sci-astronomy/celestia/Manifest b/sci-astronomy/celestia/Manifest
deleted file mode 100644
index db3189dd9fd8..000000000000
--- a/sci-astronomy/celestia/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST celestia-1.6.1.tar.gz 52600436 BLAKE2B aa5b515a75b0344f6e5d59bf385bf1c368e3c38098a1bb9c273fd87ae34a7c8e88a4bf789935bb35ee16f2037004c8f54e21592023a0675766cb4ce005c704f4 SHA512 5b1221e97ee03f7def317e5e29c5100ebe714a4a3aeb8b9818dc9445e4282b6f87026ab35c7b3d5eb02fa6dbb33693977999d14d9648fc4e6d1947abe32a413f
diff --git a/sci-astronomy/celestia/celestia-1.6.1-r1.ebuild b/sci-astronomy/celestia/celestia-1.6.1-r1.ebuild
deleted file mode 100644
index 99276ceb7056..000000000000
--- a/sci-astronomy/celestia/celestia-1.6.1-r1.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-WANT_AUTOMAKE="1.11"
-
-inherit eutils flag-o-matic gnome2 autotools
-
-DESCRIPTION="OpenGL 3D space simulator"
-HOMEPAGE="http://www.shatters.net/celestia/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="cairo gnome gtk nls pch theora threads"
-
-RDEPEND="
- virtual/opengl
- virtual/jpeg:0
- media-libs/libpng:0=
- <dev-lang/lua-5.2:*
- gtk? ( !gnome? ( x11-libs/gtk+:2 >=x11-libs/gtkglext-1.0 ) )
- gnome? (
- x11-libs/gtk+:2
- >=x11-libs/gtkglext-1.0
- >=gnome-base/libgnomeui-2.0
- )
- !gtk? ( !gnome? ( media-libs/freeglut ) )
- cairo? ( x11-libs/cairo )
- theora? ( media-libs/libtheora )"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-pkg_setup() {
- # Check for one for the following use flags to be set.
- if use gnome; then
- einfo "USE=\"gnome\" detected."
- USE_DESTDIR="1"
- CELESTIA_GUI="gnome"
- elif use gtk; then
- einfo "USE=\"gtk\" detected."
- CELESTIA_GUI="gtk"
- else
- ewarn "If you want to use the full gui, set USE=\"{gnome|gtk}\""
- ewarn "Defaulting to glut support (no GUI)."
- CELESTIA_GUI="glut"
- fi
-}
-
-src_prepare() {
- # make better desktop files
- epatch "${FILESDIR}"/${PN}-1.5.0-desktop.patch
- # add a ~/.celestia for extra directories
- epatch "${FILESDIR}"/${PN}-1.6.0-cfg.patch
- # fix missing includes for gcc-4.6
- epatch "${FILESDIR}"/${P}-gcc46.patch
- # missing zlib.h include with libpng15
- epatch "${FILESDIR}"/${P}-libpng15.patch \
- "${FILESDIR}"/${P}-linking.patch
-
- # gcc-47, #414015
- epatch "${FILESDIR}"/${P}-gcc47.patch
-
- # libpng16 #464764
- epatch "${FILESDIR}"/${P}-libpng16.patch
-
- # remove flags to let the user decide
- local
- for cf in -O2 -ffast-math \
- -fexpensive-optimizations \
- -fomit-frame-pointer; do
- sed -i \
- -e "s/${cf}//g" \
- configure.in admin/* || die "sed failed"
- done
- # remove an unused gconf macro killing autoconf when no gnome
- # (not needed without eautoreconf)
- if ! use gnome; then
- sed -i \
- -e '/AM_GCONF_SOURCE_2/d' \
- configure.in || die "sed failed"
- fi
- eautoreconf
- filter-flags "-funroll-loops -frerun-loop-opt"
-
- ### This version of Celestia has a bug in the font rendering and
- ### requires -fsigned-char. We should be able to force this flag
- ### on all architectures. See bug #316573.
- append-flags "-fsigned-char"
-}
-
-src_configure() {
- # force lua in 1.6.1. seems to be inevitable
- econf \
- --disable-rpath \
- --with-${CELESTIA_GUI} \
- --with-lua \
- $(use_enable cairo) \
- $(use_enable threads threading) \
- $(use_enable nls) \
- $(use_enable pch) \
- $(use_enable theora)
-}
-
-src_install() {
- if [[ ${CELESTIA_GUI} == gnome ]]; then
- gnome2_src_install
- else
- emake DESTDIR="${D}" install
- local size
- for size in 16 22 32 48 ; do
- insinto /usr/share/icons/hicolor/${size}x${size}/apps
- newins "${S}"/src/celestia/kde/data/hi${size}-app-${PN}.png ${PN}.png
- done
- fi
- [[ ${CELESTIA_GUI} == glut ]] && domenu celestia.desktop
- dodoc AUTHORS README TRANSLATORS *.txt
-}
diff --git a/sci-astronomy/celestia/files/celestia-1.6.0-cfg.patch b/sci-astronomy/celestia/files/celestia-1.6.0-cfg.patch
deleted file mode 100644
index 2319c255b2b5..000000000000
--- a/sci-astronomy/celestia/files/celestia-1.6.0-cfg.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/celestia.cfg
-+++ b/celestia.cfg
-@@ -195,7 +195,7 @@
- # or
- # ExtrasDirectories [ "D:\\celestia-extras" ]
- #------------------------------------------------------------------------
-- ExtrasDirectories [ "extras-standard" "extras" ]
-+ ExtrasDirectories [ "extras-standard" "extras" "~/.celestia" ]
-
-
- #------------------------------------------------------------------------
diff --git a/sci-astronomy/celestia/files/celestia-1.6.1-gcc46.patch b/sci-astronomy/celestia/files/celestia-1.6.1-gcc46.patch
deleted file mode 100644
index 757cd6c5d407..000000000000
--- a/sci-astronomy/celestia/files/celestia-1.6.1-gcc46.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-http://bugs.gentoo.org/show_bug.cgi?id=366073
-http://celestia.svn.sourceforge.net/viewvc/celestia?view=revision&revision=5178
-
-Patch written by Nils Larsson <ni1s@nerdshack.com>
---- a/src/celengine/frametree.h
-+++ b/src/celengine/frametree.h
-@@ -14,6 +14,7 @@
- #define _CELENGINE_FRAMETREE_H_
-
- #include <vector>
-+#include <cstddef>
-
- class Star;
- class Body;
diff --git a/sci-astronomy/celestia/files/celestia-1.6.1-gcc47.patch b/sci-astronomy/celestia/files/celestia-1.6.1-gcc47.patch
deleted file mode 100644
index 385f39a20511..000000000000
--- a/sci-astronomy/celestia/files/celestia-1.6.1-gcc47.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -up celestia-1.6.1/src/celengine/frametree.h.gcc47 celestia-1.6.1/src/celengine/frametree.h
---- celestia-1.6.1/src/celengine/frametree.h.gcc47 2012-03-22 12:56:56.096087430 -0400
-+++ celestia-1.6.1/src/celengine/frametree.h 2012-03-22 12:57:04.333022427 -0400
-@@ -13,6 +13,7 @@
- #ifndef _CELENGINE_FRAMETREE_H_
- #define _CELENGINE_FRAMETREE_H_
-
-+#include <unistd.h>
- #include <vector>
-
- class Star;
-diff -up celestia-1.6.1/src/celengine/planetgrid.cpp.gcc47 celestia-1.6.1/src/celengine/planetgrid.cpp
---- celestia-1.6.1/src/celengine/planetgrid.cpp.gcc47 2012-03-22 12:53:01.496950513 -0400
-+++ celestia-1.6.1/src/celengine/planetgrid.cpp 2012-03-22 12:53:08.812891865 -0400
-@@ -12,6 +12,7 @@
-
- #include <cstdio>
- #include <cmath>
-+#include <celmath/mathlib.h>
- #include <celmath/intersect.h>
- #include "planetgrid.h"
- #include "body.h"
diff --git a/sci-astronomy/celestia/files/celestia-1.6.1-libpng15.patch b/sci-astronomy/celestia/files/celestia-1.6.1-libpng15.patch
deleted file mode 100644
index 0a772ffdf6ac..000000000000
--- a/sci-astronomy/celestia/files/celestia-1.6.1-libpng15.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-imagecapture.cpp:184:40: error: ‘Z_BEST_COMPRESSION’ was not declared in this scope
-
---- a/src/celestia/imagecapture.cpp
-+++ b/src/celestia/imagecapture.cpp
-@@ -31,6 +31,9 @@
- #include "png.h"
- #endif
-
-+// Z_BEST_COMPRESSION
-+#include <zlib.h>
-+
- // Define png_jmpbuf() in case we are using a pre-1.0.6 version of libpng
- #ifndef png_jmpbuf
- #define png_jmpbuf(png_ptr) png_ptr->jmpbuf
diff --git a/sci-astronomy/celestia/files/celestia-1.6.1-libpng16.patch b/sci-astronomy/celestia/files/celestia-1.6.1-libpng16.patch
deleted file mode 100644
index 0905be66b6b6..000000000000
--- a/sci-astronomy/celestia/files/celestia-1.6.1-libpng16.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-image.cpp:530:61: error: ‘memcpy’ was not declared in this scope
-
-https://bugs.gentoo.org/show_bug.cgi?id=464764
-
-Patch written by Lars Wendler <polynomial-c@gentoo.org>
---- a/src/celengine/image.cpp
-+++ b/src/celengine/image.cpp
-@@ -42,6 +42,7 @@ extern "C" {
- #include "jpeglib.h"
- #else
- #include <cstdio>
-+#include <string.h>
- #include <jpeglib.h>
- #endif
- }
---- a/src/celengine/texture.cpp
-+++ b/src/celengine/texture.cpp
-@@ -28,6 +28,7 @@
- #include <cstdlib>
- #include <cstdio>
- #include <cassert>
-+#include <string.h>
-
- #ifndef _WIN32
- #ifndef TARGET_OS_MAC
diff --git a/sci-astronomy/celestia/files/celestia-1.6.1-linking.patch b/sci-astronomy/celestia/files/celestia-1.6.1-linking.patch
deleted file mode 100644
index dd5f93e609a6..000000000000
--- a/sci-astronomy/celestia/files/celestia-1.6.1-linking.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-Fix linking issues:
- * underlinking GLUT (bug #372123, #387609)
- * as-needed (bug #281258)
- * theora with glut (bug #399237)
-
---- a/src/celestia/Makefile.am
-+++ b/src/celestia/Makefile.am
-@@ -7,14 +7,15 @@
-
- if ENABLE_KDE
- SUBDIRS += kde
--celestiaKDELIBS = $(LIB_QT) $(LIB_KDECORE) $(LIB_KDEUI) $(LIB_KFILE) \
-- $(LIBSOCKET) -lDCOP kde/libkdegui.a
-+celestiaKDELIBS = kde/libkdegui.a
- celestia_LDFLAGS = $(all_libraries) $(KDE_RPATH)
-+LIBS += $(LIB_QT) $(LIB_KDECORE) $(LIB_KDEUI) $(LIB_KFILE) $(LIBSOCKET) -lDCOP
- endif
-
- if ENABLE_GTK
- SUBDIRS += gtk
--celestiaGTKLIBS = $(GTK_LIBS) gtk/libgtkgui.a
-+celestiaGTKLIBS = gtk/libgtkgui.a
-+LIBS += $(GTK_LIBS)
- endif
-
- COMMONSOURCES = \
-@@ -62,6 +63,7 @@
-
- if ENABLE_GLUT
- GLUTSOURCES = glutmain.cpp
-+GLUTLIBS = -lGL
- endif
-
- if ENABLE_THEORA
-@@ -80,15 +82,16 @@
- celestia_LDADD = \
- $(celestiaKDELIBS) \
- $(celestiaGTKLIBS) \
-- $(DL_LIBS) \
-- $(LUA_LIBS) \
-- $(THEORA_LIBS) \
- ../celengine/libcelengine.a \
- ../celtxf/libceltxf.a \
- ../cel3ds/libcel3ds.a \
- ../celmath/libcelmath.a \
- ../celutil/libcelutil.a \
-- $(SPICE_LIBS)
-+ $(LUA_LIBS) \
-+ $(THEORA_LIBS) \
-+ $(GLUTLIBS) \
-+ $(SPICE_LIBS) \
-+ $(DL_LIBS)
-
- noinst_HEADERS = $(wildcard *.h)
- noinst_DATA = ../../celestia
---- a/configure.in
-+++ b/configure.in
-@@ -252,6 +252,7 @@
- dnl Check for GLUT.
- AC_CHECK_LIB(glut, glutKeyboardUpFunc, ,
- [AC_MSG_ERROR([GLUT library version >= 3.7 not found])])
-+ check_theora="yes"
- fi
- AM_CONDITIONAL(ENABLE_GLUT, test "$ui_glut" = "yes")
-