summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-17 12:55:29 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-17 13:38:59 +0100
commit176365bd5d96e177b730afbe2bd01e19c5a8e34b (patch)
tree9bc29d9addcf9ddcc30d2bb822768f0b08236925 /sci-astronomy
parentgames-board/gnome-mines-3.30.0: depend on librsvg[vala] (diff)
downloadgentoo-176365bd5d96e177b730afbe2bd01e19c5a8e34b.tar.gz
gentoo-176365bd5d96e177b730afbe2bd01e19c5a8e34b.tar.bz2
gentoo-176365bd5d96e177b730afbe2bd01e19c5a8e34b.zip
sci-astronomy/celestia: Switch gnome2-utils -> xdg, EAPI-7 bump
Add missing cmake-utils_src_prepare Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/celestia/celestia-9999.ebuild33
1 files changed, 12 insertions, 21 deletions
diff --git a/sci-astronomy/celestia/celestia-9999.ebuild b/sci-astronomy/celestia/celestia-9999.ebuild
index b3f1f95bcbf7..182456385fd5 100644
--- a/sci-astronomy/celestia/celestia-9999.ebuild
+++ b/sci-astronomy/celestia/celestia-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils desktop flag-o-matic gnome2-utils xdg-utils
+inherit desktop flag-o-matic xdg cmake-utils
DESCRIPTION="OpenGL 3D space simulator"
HOMEPAGE="https://celestia.space"
@@ -22,14 +22,19 @@ IUSE="glut gtk nls +qt5 theora"
REQUIRED_USE="|| ( glut gtk qt5 )"
-RDEPEND="
+BDEPEND="
+ dev-cpp/eigen
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+DEPEND="
>=dev-lang/lua-5.1:*
dev-libs/libfmt
media-libs/glew:0
+ media-libs/libpng:0=
virtual/glu
- virtual/opengl
virtual/jpeg:0
- media-libs/libpng:0=
+ virtual/opengl
glut? ( media-libs/freeglut )
gtk? (
x11-libs/gtk+:2
@@ -47,11 +52,7 @@ RDEPEND="
media-libs/libtheora
)
"
-
-DEPEND="${RDEPEND}
- dev-cpp/eigen
- virtual/pkgconfig
- nls? ( sys-devel/gettext )"
+RDEPEND="${DEPEND}"
PATCHES=(
# make better desktop files
@@ -61,7 +62,7 @@ PATCHES=(
)
src_prepare() {
- default
+ cmake-utils_src_prepare
filter-flags "-funroll-loops -frerun-loop-opt"
@@ -107,13 +108,3 @@ src_install() {
done
dodoc AUTHORS README TRANSLATORS *.txt
}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
-}