summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-04-07 00:14:29 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-04-07 00:33:31 +0000
commit5407c4732942d4b9c29d78672355d59bdbb400b6 (patch)
tree866eb3ebfcde0fe368ce58cec674e9e93d22b53b /sci-astronomy
parentsci-libs/scikits_image: move heavy dask dependency to optfeature (diff)
downloadgentoo-5407c4732942d4b9c29d78672355d59bdbb400b6.tar.gz
gentoo-5407c4732942d4b9c29d78672355d59bdbb400b6.tar.bz2
gentoo-5407c4732942d4b9c29d78672355d59bdbb400b6.zip
sci-astronomy/healpix: initial import
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/healpix/Manifest1
-rw-r--r--sci-astronomy/healpix/healpix-3.30.ebuild141
-rw-r--r--sci-astronomy/healpix/metadata.xml20
3 files changed, 162 insertions, 0 deletions
diff --git a/sci-astronomy/healpix/Manifest b/sci-astronomy/healpix/Manifest
new file mode 100644
index 000000000000..a03e15029832
--- /dev/null
+++ b/sci-astronomy/healpix/Manifest
@@ -0,0 +1 @@
+DIST Healpix_3.30_2015Oct08.tar.gz 23465221 SHA256 efcc8ff9775f393bd3e7e9d36202126e34e5c762ee568495a728329fa6650bfb SHA512 a7be82687a2188f5dff99c6826355e3290ccc91cc440e67267c58fa13af9fa5d301eca9b37676ef6f0af262b2ff1c06e722d0dcd3aca00a4c9d2794bc666c0c7 WHIRLPOOL 56584726daa1efd8809440cb7608c82a6b2ee6f1f35ddff701e98d3ddc3c77c0a3c339003c0b08e150747db5c6b0eb18da9ef153f89e1f33bc897e4135692152
diff --git a/sci-astronomy/healpix/healpix-3.30.ebuild b/sci-astronomy/healpix/healpix-3.30.ebuild
new file mode 100644
index 000000000000..e94bed6c62d4
--- /dev/null
+++ b/sci-astronomy/healpix/healpix-3.30.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools toolchain-funcs eutils java-pkg-opt-2 java-ant-2
+
+MYP="Healpix_${PV}"
+MYPF=${MYP}_2015Oct08
+
+DESCRIPTION="Hierarchical Equal Area isoLatitude Pixelization of a sphere"
+HOMEPAGE="http://healpix.sourceforge.net/"
+SRC_URI="mirror://sourceforge/healpix/${MYP}/${MYPF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+# might add fortran in the future if requested
+IUSE="cxx doc idl java openmp static-libs test"
+
+RDEPEND="
+ >=sci-libs/cfitsio-3
+ idl? (
+ dev-lang/gdl
+ sci-astronomy/idlastro )
+ java? ( >=virtual/jre-1.6:* )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ java? ( >=virtual/jdk-1.6:* test? ( dev-java/ant-junit4:0 ) )"
+
+S="${WORKDIR}/${MYP}"
+
+pkg_pretend() {
+ if use cxx && use openmp && [[ $(tc-getCXX)$ == *g++* ]] && [[ ${MERGE_TYPE} != binary ]]; then
+ tc-has-openmp || \
+ die "You are using gcc but without OpenMP capabilities that you requested"
+ fi
+}
+
+pkg_setup() {
+ java-pkg-opt-2_pkg_setup
+}
+
+src_prepare() {
+ pushd src/C/autotools > /dev/null
+ eautoreconf
+ popd > /dev/null
+ # why was static-libtool-libs forced?
+ if use cxx; then
+ pushd src/cxx/autotools > /dev/null
+ sed -i -e '/-static-libtool-libs/d' Makefile.am || die
+ eautoreconf
+ popd > /dev/null
+ fi
+ # duplicate of idlastro (in rdeps)
+ rm -r src/idl/zzz_external/astron || die
+ mv src/idl/zzz_external/README src/idl/README.external || die
+ java-pkg-opt-2_src_prepare
+ default
+}
+
+src_configure() {
+ pushd src/C/autotools > /dev/null
+ econf $(use_enable static-libs static)
+ popd > /dev/null
+ if use cxx; then
+ pushd src/cxx/autotools > /dev/null
+ econf \
+ --disable-native-optimizations \
+ $(use_enable openmp) \
+ $(use_enable static-libs static)
+ popd > /dev/null
+ fi
+}
+
+src_compile() {
+ pushd src/C/autotools > /dev/null
+ emake
+ popd > /dev/null
+ if use cxx; then
+ pushd src/cxx/autotools > /dev/null
+ emake
+ popd > /dev/null
+ fi
+ if use java; then
+ pushd src/java > /dev/null
+ eant dist-notest
+ popd > /dev/null
+ fi
+}
+
+src_test() {
+ pushd src/C/autotools > /dev/null
+ emake check
+ popd > /dev/null
+ if use cxx; then
+ pushd src/cxx/autotools > /dev/null
+ emake check
+ popd > /dev/null
+ fi
+ if use java; then
+ pushd src/java > /dev/null
+ EANT_GENTOO_CLASSPATH="ant-junit4" ANT_TASKS="ant-junit4" eant test
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ dodoc READ_Copyrights_Licenses.txt
+ pushd src/C/autotools > /dev/null
+ emake install DESTDIR="${D}"
+ popd > /dev/null
+ if use cxx; then
+ pushd src/cxx/autotools > /dev/null
+ emake install DESTDIR="${D}"
+ docinto cxx
+ dodoc ../CHANGES
+ popd > /dev/null
+ fi
+ use static-libs || prune_libtool_files --all
+ if use idl; then
+ pushd src/idl > /dev/null
+ insinto /usr/share/gnudatalanguage/healpix
+ doins -r examples fits interfaces misc toolkit visu zzz_external
+ doins HEALPix_startup
+ docinto idl
+ dodoc README.*
+ popd > /dev/null
+ fi
+ if use java; then
+ pushd src/java > /dev/null
+ java-pkg_dojar dist/*.jar
+ docinto java
+ dodoc README CHANGES
+ popd > /dev/null
+ fi
+ use doc && dodoc -r doc/html
+}
diff --git a/sci-astronomy/healpix/metadata.xml b/sci-astronomy/healpix/metadata.xml
new file mode 100644
index 000000000000..d83a73a67095
--- /dev/null
+++ b/sci-astronomy/healpix/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ HEALPix is an acronym for Hierarchical Equal Area isoLatitude
+ Pixelization of a sphere. As suggested in the name, this pixelization produces a
+ subdivision of a spherical surface in which each pixel covers the same
+ surface area as every other pixel.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">healpix</remote-id>
+ </upstream>
+ <use>
+ <flag name="idl">Install healpix IDL/GDL routines</flag>
+ </use>
+</pkgmetadata>