summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2019-04-22 00:28:59 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-18 18:34:59 +0200
commit64cb9588fcd6c541757ab62926b620422bc2c4d3 (patch)
tree55c31243aa77d0f1197db5bb0627099f22a94c8b /sci-astronomy
parentkde-plasma/xdg-desktop-portal-kde: Use QScrollArea for AppChooser (diff)
downloadgentoo-64cb9588fcd6c541757ab62926b620422bc2c4d3.tar.gz
gentoo-64cb9588fcd6c541757ab62926b620422bc2c4d3.tar.bz2
gentoo-64cb9588fcd6c541757ab62926b620422bc2c4d3.zip
sci-astronomy/stellarium: bump version to 0.19.0
Signed-off-by: Alexey Sokolov <sokolov@google.com> Closes: https://bugs.gentoo.org/684060 Package-Manager: Portage-2.3.62, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/11770 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/stellarium/Manifest1
-rw-r--r--sci-astronomy/stellarium/files/stellarium-0.19.0-static.patch104
-rw-r--r--sci-astronomy/stellarium/stellarium-0.19.0.ebuild87
3 files changed, 192 insertions, 0 deletions
diff --git a/sci-astronomy/stellarium/Manifest b/sci-astronomy/stellarium/Manifest
index c60c05657bac..be30a0328bd1 100644
--- a/sci-astronomy/stellarium/Manifest
+++ b/sci-astronomy/stellarium/Manifest
@@ -4,3 +4,4 @@ DIST stars_6_2v0_1.cat 148352404 BLAKE2B c605b284b3d768cb1619ada3f58d406fa7737f0
DIST stars_7_2v0_1.cat 305710678 BLAKE2B 1cc9b4a6bc35a9339e495f7e0da4f7e90a0e92b05b5de8599be1bbdd2a8053cbcec44b0e58bc9248364666db9cdf23449edf236e3f21fdc0e8f1a4a706afc919 SHA512 43b866eb793e8812c9d5502101a6c985d2055fb88bdbda274726bcd51e1527ecf342b22acd673318c9c8e88cac68eace18de8f27d29ffe64933fd32a5b84c5e3
DIST stars_8_2v0_1.cat 559068934 BLAKE2B c040a369cdf6885759998e1315b554d21a5e2b9b149a67967a8af45606aebf57bec407fab5ce1904978af0dc529aa6bddd267331ca45f58617bbf56d5ca99dee SHA512 06d4fa298b9dff8452f550377df99fcaa5e7107cfc7b75c9a4769b3cb6d97a822a54213c706102c1d7ef2dabc16df32a85f46b2f6d6c6f76a4e919353b739de4
DIST stellarium-0.18.2.tar.gz 265334731 BLAKE2B d8527f93f2ea856466f98e7ab326a34e4265c4937c4d399755878cc6bbb1202580c825a6253e090986ebc80119fb33881b120a1ed6873278dacef75a1e69c517 SHA512 f658b19524b78739a5125ac7c89f5d2b48284d8696da54e39d2390bbbe5eeb8da70837c4e9055a650a492f3f71ebbc966c4c1341729982ba37d93b26fcb91912
+DIST stellarium-0.19.0.tar.gz 309151408 BLAKE2B d5726762c402cebca47c7cb218a2edc918aceb11e4bf44f0473bf86a8bfc75b908467112e8ce797c90f9c1307884f853a24f919efe11e86ef04c9eb0ff356a3b SHA512 26cb44fe4280275ce64594d01bdded4ddd2cda5d21887b4329de51188cc392e8390036702ee316446dcdb54182dec5d217a387898c4c7aa82ce14742b4d4694f
diff --git a/sci-astronomy/stellarium/files/stellarium-0.19.0-static.patch b/sci-astronomy/stellarium/files/stellarium-0.19.0-static.patch
new file mode 100644
index 000000000000..9675d389f204
--- /dev/null
+++ b/sci-astronomy/stellarium/files/stellarium-0.19.0-static.patch
@@ -0,0 +1,104 @@
+diff --git a/plugins/TelescopeControl/src/INDI/CMakeLists.txt b/plugins/TelescopeControl/src/INDI/CMakeLists.txt
+index 40c27601a0..a250e1bb0f 100644
+--- a/plugins/TelescopeControl/src/INDI/CMakeLists.txt
++++ b/plugins/TelescopeControl/src/INDI/CMakeLists.txt
+@@ -10,7 +10,7 @@ SET(TelescopeControl_INDI_UIS
+
+ QT5_WRAP_UI(TelescopeControl_INDI_UIS_H ${TelescopeControl_INDI_UIS})
+
+-add_library(TelescopeControl_INDI
++add_library(TelescopeControl_INDI STATIC
+ INDIConnection.hpp
+ INDIConnection.cpp
+ TelescopeClientINDI.hpp
+diff --git a/plugins/TelescopeControl/src/Lx200/CMakeLists.txt b/plugins/TelescopeControl/src/Lx200/CMakeLists.txt
+index 068ecf6380..d12cefabb5 100644
+--- a/plugins/TelescopeControl/src/Lx200/CMakeLists.txt
++++ b/plugins/TelescopeControl/src/Lx200/CMakeLists.txt
+@@ -1,7 +1,7 @@
+ set(CMAKE_INCLUDE_CURRENT_DIR ON)
+ set(CMAKE_AUTOMOC ON)
+
+-add_library(TelescopeControl_Lx200
++add_library(TelescopeControl_Lx200 STATIC
+ Lx200Command.hpp
+ Lx200Command.cpp
+ Lx200Connection.hpp
+diff --git a/plugins/TelescopeControl/src/NexStar/CMakeLists.txt b/plugins/TelescopeControl/src/NexStar/CMakeLists.txt
+index 6c3ce1f0d8..cd1f4bddb7 100644
+--- a/plugins/TelescopeControl/src/NexStar/CMakeLists.txt
++++ b/plugins/TelescopeControl/src/NexStar/CMakeLists.txt
+@@ -1,7 +1,7 @@
+ set(CMAKE_INCLUDE_CURRENT_DIR ON)
+ set(CMAKE_AUTOMOC ON)
+
+-add_library(TelescopeControl_NexStar
++add_library(TelescopeControl_NexStar STATIC
+ NexStarCommand.hpp
+ NexStarCommand.cpp
+ NexStarConnection.hpp
+diff --git a/plugins/TelescopeControl/src/Rts2/CMakeLists.txt b/plugins/TelescopeControl/src/Rts2/CMakeLists.txt
+index d48bd80fc7..abb1016ab1 100644
+--- a/plugins/TelescopeControl/src/Rts2/CMakeLists.txt
++++ b/plugins/TelescopeControl/src/Rts2/CMakeLists.txt
+@@ -1,7 +1,7 @@
+ set(CMAKE_INCLUDE_CURRENT_DIR ON)
+ set(CMAKE_AUTOMOC ON)
+
+-add_library(TelescopeControl_Rts2
++add_library(TelescopeControl_Rts2 STATIC
+ TelescopeClientJsonRts2.hpp
+ TelescopeClientJsonRts2.cpp
+ )
+diff --git a/plugins/TelescopeControl/src/common/CMakeLists.txt b/plugins/TelescopeControl/src/common/CMakeLists.txt
+index be09183bb9..bdf7c20395 100644
+--- a/plugins/TelescopeControl/src/common/CMakeLists.txt
++++ b/plugins/TelescopeControl/src/common/CMakeLists.txt
+@@ -1,7 +1,7 @@
+ set(CMAKE_INCLUDE_CURRENT_DIR ON)
+ set(CMAKE_AUTOMOC ON)
+
+-add_library(TelescopeControl_common
++add_library(TelescopeControl_common STATIC
+ LogFile.hpp
+ LogFile.cpp
+ Socket.hpp
+diff --git a/plugins/TelescopeControl/src/gui/CMakeLists.txt b/plugins/TelescopeControl/src/gui/CMakeLists.txt
+index c5d62942cc..d73383c62e 100644
+--- a/plugins/TelescopeControl/src/gui/CMakeLists.txt
++++ b/plugins/TelescopeControl/src/gui/CMakeLists.txt
+@@ -10,7 +10,7 @@ SET(TelescopeControl_GUI_UIS
+
+ QT5_WRAP_UI(TelescopeControl_GUI_UIS_H ${TelescopeControl_GUI_UIS})
+
+-add_library(TelescopeControl_gui
++add_library(TelescopeControl_gui STATIC
+ SlewDialog.hpp
+ SlewDialog.cpp
+ TelescopeDialog.hpp
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 2ad5af164b..a34ee2eefc 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -469,7 +469,7 @@ IF(GENERATE_STELMAINLIB)
+ #stelMain should be after the plug-ins, otherwise the build crashes
+ TARGET_LINK_LIBRARIES(stellarium stelMain ${winMMLib})
+ ELSE()
+- ADD_LIBRARY(stelMain ${stellarium_lib_SRCS} ${stellarium_RES_CXX})
++ ADD_LIBRARY(stelMain STATIC ${stellarium_lib_SRCS} ${stellarium_RES_CXX})
+ TARGET_LINK_LIBRARIES(stelMain ${STELMAIN_DEPS})
+ ADD_EXECUTABLE(stellarium WIN32 ${stellarium_exe_SRCS})
+ TARGET_LINK_LIBRARIES(stellarium ${winMMLib} ${STELMAIN_DEPS} stelMain)
+diff --git a/src/external/CMakeLists.txt b/src/external/CMakeLists.txt
+index 42a073e828..4c56837314 100644
+--- a/src/external/CMakeLists.txt
++++ b/src/external/CMakeLists.txt
+@@ -190,7 +190,7 @@ IF(USE_PLUGIN_TELESCOPECONTROL)
+ include_directories(libindi)
+ include_directories(libindi/libs)
+ include_directories(libindi/libs/indibase)
+- add_library(indiclient
++ add_library(indiclient STATIC
+ libindi/libs/lilxml.c
+ libindi/base64.c
+ libindi/libs/indibase/basedevice.h
diff --git a/sci-astronomy/stellarium/stellarium-0.19.0.ebuild b/sci-astronomy/stellarium/stellarium-0.19.0.ebuild
new file mode 100644
index 000000000000..90e1f884b68a
--- /dev/null
+++ b/sci-astronomy/stellarium/stellarium-0.19.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils desktop flag-o-matic xdg virtualx
+
+DESCRIPTION="3D photo-realistic skies in real time"
+HOMEPAGE="https://www.stellarium.org/"
+SRC_URI="
+ https://github.com/Stellarium/stellarium/releases/download/v${PV}/${P}.tar.gz
+ stars? (
+ https://github.com/Stellarium/stellarium-data/releases/download/stars-2.0/stars_4_1v0_2.cat
+ https://github.com/Stellarium/stellarium-data/releases/download/stars-2.0/stars_5_2v0_1.cat
+ https://github.com/Stellarium/stellarium-data/releases/download/stars-2.0/stars_6_2v0_1.cat
+ https://github.com/Stellarium/stellarium-data/releases/download/stars-2.0/stars_7_2v0_1.cat
+ https://github.com/Stellarium/stellarium-data/releases/download/stars-2.0/stars_8_2v0_1.cat
+ )"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug gps media nls stars test"
+
+BDEPEND="
+ nls? ( dev-qt/linguist-tools:5 )
+"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtscript:5
+ dev-qt/qtserialport:5
+ dev-qt/qtwidgets:5
+ media-fonts/dejavu
+ sys-libs/zlib
+ virtual/opengl
+ gps? ( dev-qt/qtpositioning:5 )
+ media? ( dev-qt/qtmultimedia:5[widgets] )
+"
+DEPEND="${RDEPEND}
+ dev-qt/qtconcurrent:5
+ test? ( dev-qt/qttest:5 )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-static.patch
+)
+
+src_prepare() {
+ xdg_environment_reset
+ cmake-utils_src_prepare
+ use debug || append-cppflags -DQT_NO_DEBUG #415769
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_GPS="$(usex gps)"
+ -DENABLE_MEDIA="$(usex media)"
+ -DENABLE_NLS="$(usex nls)"
+ -DENABLE_TESTING="$(usex test)"
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ virtx cmake-utils_src_test
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # use the more up-to-date system fonts
+ rm "${ED}"/usr/share/stellarium/data/DejaVuSans{Mono,}.ttf || die
+ dosym ../../fonts/dejavu/DejaVuSans.ttf /usr/share/stellarium/data/DejaVuSans.ttf
+ dosym ../../fonts/dejavu/DejaVuSansMono.ttf /usr/share/stellarium/data/DejaVuSansMono.ttf
+
+ if use stars ; then
+ insinto /usr/share/${PN}/stars/default
+ doins "${DISTDIR}"/stars_4_1v0_2.cat
+ doins "${DISTDIR}"/stars_{5,6,7,8}_2v0_1.cat
+ fi
+ newicon doc/images/stellarium-logo.png ${PN}.png
+}