summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-11 01:25:30 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-11 01:46:56 +0100
commitff4801a202d133d2bf2650aa7cfc0dd4f6bf552c (patch)
treec41ad96cc15d96a976f5a5394587bbe842163346 /sci-astronomy
parentdev-python/tempora: bump to 2.1.0 (diff)
downloadgentoo-ff4801a202d133d2bf2650aa7cfc0dd4f6bf552c.tar.gz
gentoo-ff4801a202d133d2bf2650aa7cfc0dd4f6bf552c.tar.bz2
gentoo-ff4801a202d133d2bf2650aa7cfc0dd4f6bf552c.zip
sci-astronomy/celestia: Drop USE gtk, switch to cmake.eclass
gtk still depended on ancient x11-libs/gtkglext. Bug: https://bugs.gentoo.org/644334 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/celestia/celestia-9999.ebuild48
1 files changed, 19 insertions, 29 deletions
diff --git a/sci-astronomy/celestia/celestia-9999.ebuild b/sci-astronomy/celestia/celestia-9999.ebuild
index cf7966b4a411..60ddc68e30fc 100644
--- a/sci-astronomy/celestia/celestia-9999.ebuild
+++ b/sci-astronomy/celestia/celestia-9999.ebuild
@@ -1,26 +1,25 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit desktop flag-o-matic xdg cmake-utils
-
-DESCRIPTION="OpenGL 3D space simulator"
-HOMEPAGE="https://celestia.space"
if [[ "${PV}" = 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/CelestiaProject/Celestia.git"
else
- # Old URI! Please update once we have a release > v1.6.1
- SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ SRC_URI="https://github.com/${PN^}Project/${PN^}/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
fi
+inherit desktop flag-o-matic xdg cmake
+
+DESCRIPTION="OpenGL 3D space simulator"
+HOMEPAGE="https://celestia.space"
LICENSE="GPL-2"
SLOT="0"
-IUSE="glut gtk nls +qt5 theora"
+IUSE="glut nls +qt5 theora"
-REQUIRED_USE="|| ( glut gtk qt5 )"
+REQUIRED_USE="|| ( glut qt5 )"
BDEPEND="
dev-cpp/eigen
@@ -36,12 +35,6 @@ DEPEND="
virtual/jpeg:0
virtual/opengl
glut? ( media-libs/freeglut )
- gtk? (
- x11-libs/gtk+:2
- >=x11-libs/gtkglext-1.0
- x11-libs/gdk-pixbuf:2
- x11-libs/pango
- )
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
@@ -62,7 +55,7 @@ PATCHES=(
)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
filter-flags "-funroll-loops -frerun-loop-opt"
@@ -79,16 +72,16 @@ src_configure() {
-DENABLE_CELX=ON
-DENABLE_NLS="$(usex nls)"
-DENABLE_GLUT="$(usex glut)"
- -DENABLE_GTK="$(usex gtk)"
+ -DENABLE_GTK=OFF
-DENABLE_QT="$(usex qt5)"
-DENABLE_WIN=OFF
-DENABLE_THEORA="$(usex theora)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
local size
for size in 16 22 32 48 ; do
@@ -96,15 +89,12 @@ src_install() {
done
use glut && domenu ${PN}.desktop
- local ui
- for ui in gtk qt5 ; do
- if use ${ui} ; then
- sed \
- -e "/^Name/s@\$@ (${ui} interface)@" \
- -e "/^Exec/s@${PN}@${PN}-${ui/qt5/qt}@" \
- ${PN}.desktop > "${T}"/${PN}-${ui}.desktop || die
- domenu "${T}"/${PN}-${ui}.desktop
- fi
- done
+ if use qt5 ; then
+ sed \
+ -e "/^Name/s@\$@ (qt5 interface)@" \
+ -e "/^Exec/s@${PN}@${PN}-${ui/qt5/qt}@" \
+ ${PN}.desktop > "${T}"/${PN}-qt5.desktop || die
+ domenu "${T}"/${PN}-qt5.desktop
+ fi
dodoc AUTHORS README TRANSLATORS *.txt
}