summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/last
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/last')
-rw-r--r--sci-biology/last/Manifest2
-rw-r--r--sci-biology/last/files/162-gcc46.patch15
-rw-r--r--sci-biology/last/files/162-ldflags.patch16
-rw-r--r--sci-biology/last/last-230.ebuild40
-rw-r--r--sci-biology/last/last-299.ebuild50
-rw-r--r--sci-biology/last/metadata.xml5
6 files changed, 128 insertions, 0 deletions
diff --git a/sci-biology/last/Manifest b/sci-biology/last/Manifest
new file mode 100644
index 000000000000..0fad882975fa
--- /dev/null
+++ b/sci-biology/last/Manifest
@@ -0,0 +1,2 @@
+DIST last-230.zip 418077 SHA256 8d55ee95e05a08afa72690df9086886e97142adcfbf750cf5cf6015b91215484 SHA512 46c858c2bd4a9aa00ac3b448ce78bdee6c1edd4f6569cff3c81ec8a7c661d89a9b5e7a888cbc6da190b243f0ec83c485b4574dadc6a58669d9b955eb70c329d1 WHIRLPOOL aaa0483a58821cca0fdd7875cb4e7c62493fd724729d957df1d51c7612e92e3acefae2727789f63a248f02c976a45c3209d6bac2c39f54d84f02d1106c2d0f85
+DIST last-299.zip 453159 SHA256 cc68e9c0b5220da67fd0239c9663dc0d1a05e63b337a6c98cfef6d5c38d0c54c SHA512 74e89129cc17482ec1a99e2d940ca62374c130fea2fa53ea7d2c3703b6ca5751f348110909d61562c4839d8fb1793619c2f41c25c8968b3ab53f0c7191f4a00b WHIRLPOOL 12e826c22c2d91845e89aa0c6e99af785973e8a276dec4f97ed292e144327c7c58024622d3f7285c6107bca7af1bf3c29a23ec9d22dc88ff5dc041a0df96f3ce
diff --git a/sci-biology/last/files/162-gcc46.patch b/sci-biology/last/files/162-gcc46.patch
new file mode 100644
index 000000000000..9c66c6d39f00
--- /dev/null
+++ b/sci-biology/last/files/162-gcc46.patch
@@ -0,0 +1,15 @@
+ src/XdropAligner.hh | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/src/XdropAligner.hh b/src/XdropAligner.hh
+index 9dea32e..3c0e35f 100644
+--- a/src/XdropAligner.hh
++++ b/src/XdropAligner.hh
+@@ -12,6 +12,7 @@
+ #include <vector>
+ #include <cassert>
+ #include <climits> // INT_MAX
++#include <cstddef>
+
+ namespace cbrc{
+
diff --git a/sci-biology/last/files/162-ldflags.patch b/sci-biology/last/files/162-ldflags.patch
new file mode 100644
index 000000000000..e5dd3ee2234e
--- /dev/null
+++ b/sci-biology/last/files/162-ldflags.patch
@@ -0,0 +1,16 @@
+ src/makefile | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/makefile b/src/makefile
+index e77ffa7..92e4575 100644
+--- a/src/makefile
++++ b/src/makefile
+@@ -51,7 +51,7 @@ lastal: $(ALSRC) $(ALINC) makefile $(OBJ)
+ $(CXX) $(STRICT) $(CXXFLAGS) -o $@ $(ALSRC) $(OBJ)
+
+ lastex: $(EXSRC) $(EXINC) makefile
+- $(CXX) -Igumbel_params $(CXXFLAGS) -o $@ $(EXSRC)
++ $(CXX) $(STRICT) -Igumbel_params $(CXXFLAGS) -o $@ $(EXSRC)
+
+ $(OBJ): CA_code/*.c CA_code/*.h makefile
+ $(CC) $(CFLAGS) -c CA_code/lambda_calculator.c
diff --git a/sci-biology/last/last-230.ebuild b/sci-biology/last/last-230.ebuild
new file mode 100644
index 000000000000..51dc9ee0faf0
--- /dev/null
+++ b/sci-biology/last/last-230.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Genome-scale comparison of biological sequences"
+HOMEPAGE="http://last.cbrc.jp/"
+SRC_URI="http://last.cbrc.jp/archive/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="amd64 x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_prepare() {
+ sed \
+ -e 's:-o $@:$(LDFLAGS) -o $@:g' \
+ -i src/makefile || die
+}
+
+src_compile() {
+ emake \
+ -e -C src \
+ CXX="$(tc-getCXX)" \
+ CC="$(tc-getCC)" \
+ STRICT="" || die
+}
+
+src_install() {
+ dobin src/last{al,db,ex}
+ exeinto /usr/share/${PN}/scripts
+ doexe scripts/*
+ dodoc doc/*.txt ChangeLog.txt README.txt
+}
diff --git a/sci-biology/last/last-299.ebuild b/sci-biology/last/last-299.ebuild
new file mode 100644
index 000000000000..9d32fdf11c3c
--- /dev/null
+++ b/sci-biology/last/last-299.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils toolchain-funcs python-r1
+
+DESCRIPTION="Genome-scale comparison of biological sequences"
+HOMEPAGE="http://last.cbrc.jp/"
+SRC_URI="http://last.cbrc.jp/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_prepare() {
+ sed \
+ -e 's:-o $@:$(LDFLAGS) -o $@:g' \
+ -i src/makefile || die
+}
+
+src_compile() {
+ emake \
+ -e -C src \
+ CXX="$(tc-getCXX)" \
+ CC="$(tc-getCC)" \
+ STRICT="" || die
+}
+
+src_install() {
+ local i
+
+ dobin src/last{al,db,ex}
+
+ dodoc doc/*.txt ChangeLog.txt README.txt
+ dohtml doc/*html
+
+ cd scripts || die
+ for i in *py; do
+ python_parallel_foreach_impl python_newscript ${i} ${i%.py}
+ done
+ dobin *sh
+}
diff --git a/sci-biology/last/metadata.xml b/sci-biology/last/metadata.xml
new file mode 100644
index 000000000000..f17a827e3101
--- /dev/null
+++ b/sci-biology/last/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>